Sophix 7" android tablet

Last Updated:

  1. thejerk

    thejerk Well-Known Member

    got this on a trade. technically, you can say i spent 40$ on it, since the item i traded was valued at that.


    its running ICS 4.0.4. want to root, but cant find any one-clicks that work. can i downgrade to 2.3 and root like i did my ascend II? would also love to install CM7 or 10 on it if possible.

  2. thejerk

    thejerk Well-Known Member

    ahh figured it out. ADB drivers were not installed.

    installed them, one click razer's edge root, 4 reboots and bam i have a SU prompt now :D
    apnsb likes this.
  3. shinaku666

    shinaku666 New Member

    Is it a Sophix 7 Tablet model TAB-730? if so can you help me root it?
  4. apnsb

    apnsb Active Member

    Rooted mine the same way. But I can't get into recovery mode.
  5. messymatthew

    messymatthew New Member

    has anyone gotten custom recovery on this tablet yet root was no problem but cant get recovery what tablet would be like it i could use as reference
  6. messymatthew

    messymatthew New Member

    if anyone needs help or gets a custom recovery on theres please email me at
  7. ryokojr

    ryokojr New Member

    I got into where it shows the android with the red exclamation point and its open, then press the home button and recovery menu pops up ;p
  8. apnsb

    apnsb Active Member

    I installed Pimp my Rom on it and the changes are amazing. I hope someone makes a custom rom soon.
  9. anh102

    anh102 Member

    I want to root my Sophix, can someone link or send me a root guide or info?
  10. Phubu

    Phubu Well-Known Member

    sharing how would be nice pls :), i just got this tablet for the wify. Want to make it as enjoyable as possible for her.
  11. jlong321

    jlong321 New Member

    My tablet had the android laying down with the red exclamation point. It seems to have went into recovery mode. How do you get out of this recovery window?
  12. Phubu

    Phubu Well-Known Member

    Ok I'am being unsuccessful rooting the device, I have the Sophix 7" Tablet model: TAB-730.
    The method mentioned above is not doing anything, can a small tutorial/steps be posted with the files needed?

    I'm wondering why there isn't a section for this tablet yet? Admins wuzzzup? :)
  13. apnsb

    apnsb Active Member

    Does anyone know how to get into recovery mode?
  14. apnsb

    apnsb Active Member

    Well......Ive bricked my 80 dollar tablet. :mad:
  15. Monsieur_E

    Monsieur_E New Member

    The adb drivers from superoneclick along with bin4rys root with restore should work. I've tried it, but a difx_dll error keeps prompting when I go to install the drivers. Could I get adb drivers installed without s1c?
  16. JoeSchmoe717

    JoeSchmoe717 Active Member

    Recently updated the firmware on my TAB-740G to Android 4.4.2 (Download - Support). Very exciting because I only paid $20 out-of-pocket for this tablet and the update really kicked this thing into high-gear!

    I'm know trying to re-root. I've tried a few different options (TowelRoot, Famaroot) but they have not worked.

    I did also figure out how to get updated ADB drivers using MoboRobo (MoboRobo - The Android Smartphone PC Manager. Free for Life!) but every batch file I've used cannot find the /data/local/tmp directly and therefore won't continue the root process.

    Anyone out there know anything about the TAB-740G and other ideas no root?

Share This Page