"Sorry The application Samsung Home (process com.sec.android.app.twlauncher) has stopped unexpectedlGeneral


Last Updated:

  1. JonathanMcfl

    JonathanMcfl New Member This Topic's Starter

    Joined:
    Oct 5, 2011
    Messages:
    2
    Likes Received:
    4
    I have a samsung galaxy mini which, after downloading the Android "WhatsApp" has stopped working and comes up with the message
    "Sorry The application Samsung Home (process com.sec.android.app.twlauncher) has stopped unexpectedly. Please try again."
    "Force close"
    I have 'forced close' many times. Switched the phone off and back on many times and taken the battery out and put it back in a few times - i am at the end of my tether, bringing it back to the retailer isn't an option, for a couple reasons, pleas, anybody help me, im lost without my phone.
    :(

     

    Advertisement
  2. xSuhaasx

    xSuhaasx Member

    Joined:
    Oct 1, 2011
    Messages:
    20
    Likes Received:
    1
    Uninstall It and Reinstall it o_O and Clear the Cache
     
  3. dhruvbatra205

    dhruvbatra205 Well-Known Member

    Joined:
    Aug 29, 2011
    Messages:
    146
    Likes Received:
    4
    try different launchers
    try go launcher.
    but i guess the error msg will still keep popping up. so you can try reflashing your firmware.
    was it so ever since you bought the phone or you upgraded it?
     
  4. CSN

    CSN New Member

    Joined:
    Oct 7, 2011
    Messages:
    1
    Likes Received:
    2
    navnil and shaneo568 like this.
  5. yagya

    yagya Well-Known Member

    Joined:
    Aug 28, 2011
    Messages:
    481
    Likes Received:
    71
    nursiamsyah likes this.
  6. JayDevil

    JayDevil Member

    Joined:
    Oct 7, 2011
    Messages:
    11
    Likes Received:
    24
    I have the same problem, but its after that i install AppBrain, i had full shortcuts and then AppBrain tells me if I want a shortcut on my homepage, so i clicked on Continue and then it started to vibrates and pop-up. The same problem "Sorry The application Samsung Home (process com.sec.android.app.twlauncher) has stopped unexpectedly. Please try again."
     
    zhenye1998 likes this.
  7. JayDevil

    JayDevil Member

    Joined:
    Oct 7, 2011
    Messages:
    11
    Likes Received:
    24
    I also uninstalled it, By holding the Home key and Task Manager, Package and then uninstalled. Doesn't work.
     
    zhenye1998 likes this.
  8. JayDevil

    JayDevil Member

    Joined:
    Oct 7, 2011
    Messages:
    11
    Likes Received:
    24
    I resolved this problem, with :
    1. Turn off the phone
    2. Press and hold Home Button ( middle ) + power on for at least 10 seconds
    3. Android System Recovery Mode Appear
    4. There are 4 options

    reboot system now
    apply sdcard:update.zip
    wipe data/factory reset
    wipe cache partition

    5. Move the options to " Wipe data / factory reset " using volume down ( - ) button and menu button to confirm, because the touchscreen doesn't work in reovery mode (Use the home to choose Yes)
    6. After the process done, phone will reboot. (It if does not, Choose "reboot system now")

    Thanks: matrix69
     
  9. nukuk0

    nukuk0 New Member

    Joined:
    Oct 21, 2011
    Messages:
    1
    Likes Received:
    1
    THANK you so much//this worked for me perfectly.
     
    bdperen likes this.
  10. amar3pathi

    amar3pathi New Member

    Joined:
    Nov 5, 2011
    Messages:
    1
    Likes Received:
    0
    after applying these steps
    1. Turn off the phone
    2. Press and hold Home Button ( middle ) + power on for at least 10 seconds

    i get on screen RAMDUMP Mode(ARM9 mode) and now phone keys are not working no power key and no menu key
     
  11. mspcbe

    mspcbe New Member

    Joined:
    Nov 8, 2011
    Messages:
    1
    Likes Received:
    1
    Thanks buddy! It worked like a magic! Thanks once again
     
    zzullqm likes this.
  12. annaeiram

    annaeiram New Member

    Joined:
    Nov 22, 2011
    Messages:
    2
    Likes Received:
    0
    its not working !!!!
     
  13. S5570Owner

    S5570Owner New Member

    Joined:
    Dec 6, 2011
    Messages:
    1
    Likes Received:
    2
    Can you please make a tutorial in YouTube? I can't get it... And yeah, I have this problem too.. I am trying to remove one of the menu page(whatever you call that) then suddenly that note appears.. I turned off my phone, take off the battery and Sim card, but still it doesn't work..
     
    cajunmami3 and anishetty like this.
  14. anishetty

    anishetty New Member

    Joined:
    Dec 7, 2011
    Messages:
    1
    Likes Received:
    0
    Thanks Buddy..........i am very thankful to you.

    I have installed one bloody application finger print scanner due to this, i had faced this problem.

    Dear All, I want to suggest that plz do not install this application......it is creating hell


    Thanks
     
  15. jeetubaba777

    jeetubaba777 New Member

    Joined:
    Dec 17, 2011
    Messages:
    1
    Likes Received:
    0


    Thanks its working good...........
     
  16. thessjavier26

    thessjavier26 New Member

    Joined:
    Dec 18, 2011
    Messages:
    2
    Likes Received:
    0
    please help me how it works again

     
  17. jonvank

    jonvank New Member

    Joined:
    Dec 19, 2011
    Messages:
    1
    Likes Received:
    0
    Go settings>applications>manage apps>select the "All" tab> go to twlauncher and force stop/clear cache

    This worked for me and I haven't had that error come back in months now. Also saves the hassle of flashing.
     
  18. shaneo568

    shaneo568 New Member

    Joined:
    Dec 25, 2011
    Messages:
    1
    Likes Received:
    0
  19. anice

    anice New Member

    Joined:
    Jan 3, 2012
    Messages:
    1
    Likes Received:
    0
    I just having the same probs.but still can access internet.can receive sms,but cant reply.can make a call too.
    but i'm still dont know how to solve the problem.
    when trying to Press and hold Home Button ( middle ) + power on for at least 10 seconds..it doesnt appear this menu..how??

    reboot system now
    apply sdcard:update.zip
    wipe data/factory reset
    wipe cache partition
     
  20. santoshng

    santoshng New Member

    Joined:
    Jan 14, 2012
    Messages:
    1
    Likes Received:
    3
    I too had same problem today but solved the problem by without wiping data/factory otherwise all your applications/data will be lost by following steps
    Try to launch market application in phone and install "Go launcher" application from market and open the Go launcher then go to settings ->Applications->Manage Applications then select "Samsung Home" application and clear data

    Alternatively if you able to open settings then you can performing above steps will resolve your issues
     
    adqc, zhenye1998 and Tundroid like this.
  21. Sinja2060

    Sinja2060 New Member

    Joined:
    Jan 19, 2012
    Messages:
    1
    Likes Received:
    0
    It worked perfectly for me too :) :) :)
    Many thanks
     
  22. Hollycolliep

    Hollycolliep New Member

    Joined:
    Jan 26, 2012
    Messages:
    1
    Likes Received:
    0
    If I do the Go Launcher will it delete any of my information? Why are we getting this error?
     
  23. ah99

    ah99 New Member

    Joined:
    Jan 26, 2012
    Messages:
    1
    Likes Received:
    0
    Hi,

    I just encountered this error a few minutes ago, did some search and then went another but home screen related route. I didn't have to do a factory reset nor push install another app. I simply had to do the following:

    1. Went to Settings -> Application settings -> Manage applications
    2. Went to All tab
    3. Opened Samsung Home
    4. Cleared the data (this will reset your home screen back to its original settings)
    5. Force stop the app (since it is in limbo)
    6. Reset the phone

    In my case, I think what happened was that I got tired of using the Facebook app I just installed minutes earlier so I tried to uninstall it but during the clicking of the negative button to uninstall the app, I think it tried to also add it in the Home screen. I actually got a hanging message that there was no more space for the icon which lost me because I was trying to uninstall it. Then I ended up getting this Home screen error.

    Hope this helps others as well.

    Looking forward to setting up a "new home" later...
     
  24. samsunggirl92

    samsunggirl92 New Member

    Joined:
    Jan 31, 2012
    Messages:
    1
    Likes Received:
    0
    Thanks veryy muchhh!!! its work ;)
     
  25. gerard12241984

    gerard12241984 New Member

    Joined:
    Feb 11, 2012
    Messages:
    1
    Likes Received:
    0
    thank u very much ita work..but my all aplication..dwonloading is lost=c
     
  26. vmarklester21

    vmarklester21 New Member

    Joined:
    Sep 28, 2011
    Messages:
    2
    Likes Received:
    3
    Best Answer


    samsung home a.k.a. twlauncher error/failed

    if possible to access setting, go to settings/application/manage app/"all" tab/scroll down until u found Samsung Home open it, first, force stop then clear cache and data but if u cannot access the setting and don't want to reset your phone to factory settings (it will delete all of your data) try to find wi-fi that your phone can access and a computer that have internet. Now, using computer go to android market and log in your acct. then find application called
    " go launcher ex " click on that app and install it (don't worry, its free app) then, with your malfunctioning phone but wi-fi connected, it will download the app and install itself. Now the tricky part, once installed a pop-up will ask you if you want to switch either go launcher or samsung home and below a check-box of the default you want to use, (REMEMBER THAT DO NOT CLICK ON THAT CHECKBOX) now, choose go launcher ex as your new home (JUST LEAVE THE BOX BELOW UNCHECKED) you can now operate your phone (but not fixed yet) you can now access the setting, just follow the procedure i mention above but don't exit on that page,
    now that we are almost done with the fix, scroll down you will see clear default button and hit that. Restart your phone then a pop-up will launch again now you can choose what fits for you "go launcher ex" or the classic "samsung home" but after you choose, check that checkbox for your default home if you choose samsung home, you can now uninstall go launcher ex.

    Here is my advise:
    Try to install application called Smart Task Switcher or Smart Taskbar and pin to your task bar, with that application slide down your tastbar and you can access the phone setting instatly even if twlaucher error happens again, and there is no need to find wi-fi hot-spot, install go laucher ex again, just go to setting and fix it and dont forget to reboot when you're done.

    :rolleyes:
     
    avagut, Prutser and ovhal like this.

Share This Page

Loading...