Sound is off during callSupport


Last Updated:

  1. schio

    schio Member

    Dear all, I would really appreciate some help with an issue I am having with my Android phone.

    I have a Samsung Exhibit II, rooted and unlocked. Since I bought it I have been having a most distressing issue:

    Sometimes I try to make a phone call and the sound is completely turned off. The other side cannot hear me, and I cannot hear them. I can see the time running, the call is connected (I can see that even through the other device), but there is no sound on both ends, regardless of what is the other phone (mobile or land line).

    To help cutting to the chase:

    1. No, I am not pressing mute or add call with my face.
    2. It does not help at all to press speaker phone, mute, or any other button while on call.
    3. No, I do not plug in headsets or headphones prior to calls, nor at any other given time. Since I got the phone about 2 months ago, I only plugged the headphones once.
    4. Yes, it does take sometimes 2 or 3 reboots so that the problem goes away. But the problem does return very often. At least once a day now.
    5. Restoring phone to stock did not work at all.
    6. The issue is also not related to my ROM, as I already installed different ROMs (currently, I have PeachSunrise, but I am using Go Launcher Ex on top of it).
    7. I even tried replacing some files to see if I could have the problem solved, but nothing changed at all. And, since I am not very savvy at these things, I tried replacing what I personally thought could be linked to the problem. These were:
    a) phone.apk
    b) contacts.apk
    c) contactsprovider.apk
    d) Phone_Util.apk
    e) PhoneCrashNotifier.apk
    f) PhoneErrService.apk
    g) SpeechRecorder.apk

    8. I am living in Brazil, and had the phone for about 2 months. I cannot return it since I am here, and the phone is not stock anymore (bought it at Walmart).


    I would REALLY appreciate any help on this. I am very much disappointed at this point, and I already lost so much time trying to deal with it. But I will not quit.

    Advertisement
  2. schio

    schio Member

    No one knows the answer for the riddle above yet? It would be great to have my phone working again, though.
  3. ZenPit

    ZenPit Well-Known Member

    I remember having this issue although mine was rom related. Which other roms have you tried? If you could get alogcat app and post the log on pastebin and notify on the specific rom your using Dev thread you might get some help.
    schio likes this.
  4. schio

    schio Member

    Thanks a lot for your message ZenPit. So, I am letting alogcat populate my entire log. It is taking a long itme, though. Should I just wait, or a sample would be already good? Also, I have been using since the first day Easy battery saver and lookout (they are the only active programs all the time). I wonder if these could possibly be causing the problem. I am going to close all processes and services related to them for a while to be sure.

    Again, thanks a lot. I will wait for your advice on how to post my log on Dev thread, if you may.
  5. ZenPit

    ZenPit Well-Known Member

    Close the processes and run Alogcat then make a brief call to a number that will answer. Then copy your alogcat and go to pastebin. Paste the log onto the pastebin text box and submit it. Grab the URL to your logs paste bin then go to the ROM your using Dev thread and paste the URL there. Tell them your issue and then you gotta hang tight. Most the devs are pretty active. The log should be able to let them see what could be going wrong. Alogcat only needs to be on for the call.

    Hope this helps, I know when I was having this issue it was quite frustrating. Do you know if the other end of the line can hear you?
    schio likes this.
  6. schio

    schio Member

    ZenPit, I did what you told me, and I am now posting the log on PeachSunrise's Dev thread.

    Something that I forgot to answer before: I used the stock ROM, Go Launcher Ex after rooting over stock ROM, and now Go Launcher Ex on top of PeachSunrise.

    I also uninstalled Easy Battery Saver and Lookout and the issue is still happening.

    Thanks again for the help, I hope I can solve this soon!
  7. ZenPit

    ZenPit Well-Known Member

    I don't think it would be any of the apps causing this. If they have "call" permissions then maybe, however I think that's unlikely. Go Launcher shouldn't cause any issue as its a theme app nor your battery saver app or Lookout. Like I said when I was having the issue it was ROM based. Did you happen to delete any apps in TitaniumBackUp? You may have accidentally deleted something important?

    Good Jocala is very active so your problem could be addressed soon by him and hopefully resolved ASAP.
    schio likes this.
  8. schio

    schio Member

    ha! Also forgot to mention:

    I made tests calling another cell phone next to me and land lines. In all occasions the call is completely muted for both parts, but the call is in fact connected.

    I will try posting it now on Dev Thread and hope that Jocala or someone else answers me.
  9. ZenPit

    ZenPit Well-Known Member

    Yea don't worry someone will, you may want to PM Jocala about this. Be sure to mention that the sound is dead on both lines. That you've tested on another mobile and a land line and to include your logs pastebin.

    Your problem will be addressed as the Android community is fairly friendly and helps one another out.

    I'm glad I could help you out with this and I hope you're back to hearing people on your phone before nightfalls
  10. schio

    schio Member

    and no, unfortunately it was not caused by deleting any programs on TitaniumBackUp. Never deleted anything there, and the problem comes with me since stock ROM.
  11. schio

    schio Member

  12. ZenPit

    ZenPit Well-Known Member

    Eek well I hope it isn't a hardware issue with the phone. Do you insurance or warranty still? If so flash back to stock (since rooting voids warranty and we wouldn't want anyone to know that ;D ) if nothing ends up working and take it to your carrier for a replacement.
  13. ZenPit

    ZenPit Well-Known Member

  14. schio

    schio Member

    yes, fingers crossed it's not hardware related. Especially because form Brazil it would be a pain to get Samsung to send me a new phone to replace this one.

    I will also post on XDA Developers!
  15. ZenPit

    ZenPit Well-Known Member

    You get it fixed mate?
  16. schio

    schio Member

    Nothing came up yet (at xda developers nobody answered me yet). Someone said in the the other post that the problem seems to be hardware - since it occurs with different ROMs. What I can't understand is why, if that is the case, the phone works as often as it does not.

    Also,what puzzles me is that throughout the internet you find many people reporting what seems to be the same problem as I reported here, but on random different phone models from different brands.

    Again, my biggest problem is that I am not sure that Samsung is going to have it back and send me another one to Brazil (as I understood, this phone is being sold just ion the USA)...
  17. ZenPit

    ZenPit Well-Known Member

    The phone is sold as Samsung Ancora internationally if I'm not mistaken. I'm sorry to hear you haven't gotten it working by now.

Share This Page