1. Introducing Channels - a new way to chat with other Android users!
    Dismiss Notice

Source of poor battery life (not let's fix it)


Last Updated:

  1. flipz

    flipz New Member This Topic's Starter

    Joined:
    Oct 14, 2009
    Messages:
    4
    Likes Received:
    0
    My friend and I both purchased Heros and we are both seeing pretty poor battery life. Using a couple of different things we believe we have figured out where the problem lies, but we are unsure how to fix it!

    Here's what we know:

    Menu < Settings < About Phone < Status < Awake Time

    Both of ours have an awake time of 100%. According to other Android users, the lower this number is the better your battery life. So basically this is saying that even when the phone is off, it's not asleep. It is fully awake 100% of the time. Up time should not be the same as awake time.

    Using an app called Spare Parts (Cyrket - Spare Parts) you can dig a little deeper.

    Spare Parts < Battery History < Partial Wake Usage < Since Last Unplugged.

    My phone is showing that the dialer has a wake lock for 16h. This appears to mean that the phone can't sleep because the dialer has locked it.

    You can also check under "Other Usage." I have "Running", "Screen on", and "Phone on." Running says:

    Time spent without sleeping: 16 hours (100%).

    PowerManager | Android Developers
    So now the problem is how do we fix it?!

    Edit: I also posted this on Sprint's forums to maybe get some attention from the big guys. Source of Hero's poor battery life
     

    Advertisement
  2. Edaze55

    Edaze55 Well-Known Member

    Joined:
    Aug 26, 2009
    Messages:
    973
    Likes Received:
    1
    That would certainly kill the battery. Have you restarted your handset? I'd start with that as it seems something got crossed somehwere.

    Give it a few mins and see if you are getting any "sleep time"
     
  3. flipz

    flipz New Member This Topic's Starter

    Joined:
    Oct 14, 2009
    Messages:
    4
    Likes Received:
    0
    I also wanted to add this just to show that it makes sense:

    PowerManager | Android Developers

    My phone has been restarted multiple times without any change. His phone is doing the same thing. They were purchased at two different Best Buy's across the country from each other.
     
  4. Edaze55

    Edaze55 Well-Known Member

    Joined:
    Aug 26, 2009
    Messages:
    973
    Likes Received:
    1
    And you have killed the dialer using your task manager?
     
  5. flipz

    flipz New Member This Topic's Starter

    Joined:
    Oct 14, 2009
    Messages:
    4
    Likes Received:
    0
    The dialer itself actually doesn't show up in the one I'm using (TasKiller). Can you make another recommendation? This is my first android phone.

    Ok, using TaskControl I was able to find voice dialer and I killed that. We'll see if it makes any difference.

    PROGRESS! Using Task Manager 1.10.7 (http://www.cyrket.com/package/com.wingtseng123.SystemMemoryMonitor) I was able to kill "Phone." After hitting the power button I immediately started getting a difference between Up Time and Awake Time (5 minute difference now). I was able to both call and text my phone. After doing so "Phone" showed back up in task manager however the phone is still sleeping properly. I'm not sure if a reset will cause it to break again yet.
     
  6. flipz

    flipz New Member This Topic's Starter

    Joined:
    Oct 14, 2009
    Messages:
    4
    Likes Received:
    0
    I am going to continue this thread over on sprint.com because it's getting a lot more attention (Source of Hero's poor battery life) but I wanted to update you all with what I found.

    So we have determined exactly when it happens. We tried all of the following:
    receiving e-mail
    checking e-mail
    browsing the web
    loading google maps and locking location
    receiving text
    reading text
    making a phone call
    receiving a phone call

    Every single one allows the unit to go back to sleep without any issues. There are two things that prevent it from sleeping every time:

    Send a text
    Turning the phone on with no activity



    So sending a text is obvious. Every single time we sent a text, the phone would stop sleeping. Receiving a text is fine. What i mean by turning the phone on with no activity is if I turn the phone on and just let it boot up and disable the screen on it's own and never send or receive a text, it will stay awake even though the screen is off. The phone ends up turning the screen off before it actually boots 100%. Once I turn the phone back on and actually look at my home screen (after it's done booting) and then turn it off again, it will sleep properly.
     
  7. tagta3

    tagta3 Well-Known Member

    Joined:
    Oct 13, 2009
    Messages:
    62
    Likes Received:
    1
    I haven't tested all the combinations but like you I did notice an awake time of 99% and restarted the phone. I'm going to try and send a txt and see if it keeps the phone from sleeping just to verify your findings. This is a big issue.
     
  8. tagta3

    tagta3 Well-Known Member

    Joined:
    Oct 13, 2009
    Messages:
    62
    Likes Received:
    1
    Verification results: I sent a txt message and then went to home screen and left the phone to go into standby on its own (without me touching the end call button to force standby), and the phone stayed awake (screen off). You are right sending txts keep the phone from sleeping. This absolutely sucks, I sold my iphone to get this phone and the hero is suffering from a fairly large power management issue.
     
  9. pr0n

    pr0n Member

    Joined:
    Oct 14, 2009
    Messages:
    14
    Likes Received:
    0
    Has anyone tried using an app to send or receive text messages other than the stock "messages" app?

    Is it maybe because looking at "Messages" has something to do with it? I would give that a shot.
     
  10. Edaze55

    Edaze55 Well-Known Member

    Joined:
    Aug 26, 2009
    Messages:
    973
    Likes Received:
    1
    Right, because the iPhone was so power efficient?! Most of the people I know with the iPhone have to charge their phones several times a day.
     
  11. ron

    ron Well-Known Member

    Joined:
    Sep 17, 2009
    Messages:
    93
    Likes Received:
    8
    This info from the Sprint forums:
    CONFIRMED: Fix for HTC Hero "Dialer"...

    THIS IS THE FIX!!!!

    The Messages app is keeping the phone from sleeping, and the fix is to use a different app for texting:

    Go download ChompSMS for free from Marketplace. Use that instead, it looks just like iPhone SMS and works great. I've tried sending/receiving a bunch of texts and Dialer is behaving!!! I LOVE ANDROID. No other mobile OS could you just download a different SMS client!


    -----

    More of a work around than a fix but you are 100% correct! Just tested and confirmed on my phone too. I don't really love the client heh. But My phone is sleeping properly after having sent a text through comp instead of through the original sms client. And I agree completely, no other phone would let you just do that.

    -----
    When you start up the phone, make sure you are the one putting it to sleep and it's not auto sleep (screen dims). Then it sleeps.


    Finally when sending/receiving texts use either ChompSMS or another SMS client other than the built-in Messages app and you will be flying high!!


    Make sure you reboot (poweroff/on) your phone before you start using ChompSMS or another SMS app exclusively so any issue caused by the Messages app has been cleared.


    Not only is the battery drain gone for me my phone is charging twice as fast!



    -----

    Go to Messages (The app) > Settings > Notifications. You can turn it off there. I had been using chompsms since I got the phone, knew about it before I got it, and it's a great app.
     
  12. pr0n

    pr0n Member

    Joined:
    Oct 14, 2009
    Messages:
    14
    Likes Received:
    0
    YES! Nice find! I had a feeling it had to do with that, all Sprint needs to do now is make an adjustment to the messages app. I kind of like it actually, but to save battery power I'll make the sacrifice.
     
  13. ron

    ron Well-Known Member

    Joined:
    Sep 17, 2009
    Messages:
    93
    Likes Received:
    8
    What's nice about ChompSMS is at least you don't have to go scrolling to find the send button. It's right there.
     
  14. RhinoDoc

    RhinoDoc Well-Known Member

    Joined:
    Oct 8, 2009
    Messages:
    88
    Likes Received:
    5
    If I download ChompSMS, how do I deactivate the Sprint SMS? Is it done automatically when I boot up Chomp?
     
  15. ron

    ron Well-Known Member

    Joined:
    Sep 17, 2009
    Messages:
    93
    Likes Received:
    8
    Rhinodoc, simply restart your phone and do not use the Messages app. In fact, hide the icon ;-) Once you have used it once you are screwed until you restart the phone.
     
  16. RhinoDoc

    RhinoDoc Well-Known Member

    Joined:
    Oct 8, 2009
    Messages:
    88
    Likes Received:
    5
    Thanks.

    I also loaded Locale last night and saw my battery plummet today, so I just dumped it.
     
  17. jlachesk

    jlachesk Member

    Joined:
    Oct 14, 2009
    Messages:
    23
    Likes Received:
    0
    First off, awesome job on tracking down the source of this problem. I noticed that my Awake time was oddly high (85%+), but haven't had time to look into it. Thankfully there is a work around.

    I installed Locale a couple of days ago and haven't noticed much difference (keeping in mind that my battery life was poor to begin with), but I LOVE the app. Might have to do some more testing and see how it impacts battery life. Anyone have experience with it?
     
  18. Fake Name

    Fake Name Well-Known Member

    Joined:
    Oct 8, 2009
    Messages:
    135
    Likes Received:
    0
    When I was messing around with that app, it told me if I were to use satellite GPS that will cause high battery consumption
     
  19. jlachesk

    jlachesk Member

    Joined:
    Oct 14, 2009
    Messages:
    23
    Likes Received:
    0
    Yea, the more ways you let it determine your location, the more precise it is, but the harder it is on the battery.

    My current profiles are generic enough that I don't need GPS level location, Mobile Network works just fine.

    Honestly, the only time I have the GPS turned on is when I'm trying to get un-lost with Google Maps.
     
  20. nathanotis

    nathanotis Well-Known Member

    Joined:
    Sep 22, 2009
    Messages:
    399
    Likes Received:
    17
    I want to make certain I'm understanding this... I've changed the setting in "Messages" and removed it from the "desktop". Then I installed Chomp (whose UI I really like). Then I restarted.

    I'm only getting notifications from Chomp, but when I open Advanced Task Killer, it shows "Messages" and has a check box like I need to kill it. Can/should I ignore it?

    Thanks.
     
  21. Slug

    Slug Check six! Moderator

    Joined:
    Aug 1, 2009
    Messages:
    20,096
    Likes Received:
    15,688
    I use it constantly and don't find it significantly affect battery usage. As mentioned, tracking GPS sats will hammer the battery fastest. In urban areas though I find that the location awareness is precise enough just using the cell masts so I don't need GPS.
     
    huedawg likes this.
  22. pdragon

    pdragon Well-Known Member

    Joined:
    Oct 15, 2009
    Messages:
    395
    Likes Received:
    19
    Just wanted to say thank you for finding a fix for this! I'd wondered about the poor battery life on mine but I thought it was just because I was using it so much lately. This has helped tremendously!
     
  23. dvdqnoc

    dvdqnoc Well-Known Member

    Joined:
    Sep 7, 2009
    Messages:
    341
    Likes Received:
    0
    So I downloaded chompSMS and it looks like a great app. My question is, even though we use chompSMS isntead of the "Messages" app, wouldnt the Messages app still be active in recieving SMS's? In other words, when we recieve an SMS wouldnt we get TWO notifications - one from chompSMS and one from Messages? If there was a way to I guess "turn off" or disable Messages that would be cool...
     
  24. pdragon

    pdragon Well-Known Member

    Joined:
    Oct 15, 2009
    Messages:
    395
    Likes Received:
    19
    dvdnque,

    You can turn off the notification from the Messages program in its Settings. Then chomp should be the only one notifying you.
     
  25. childoftheko4n

    childoftheko4n Member

    Joined:
    Oct 15, 2009
    Messages:
    12
    Likes Received:
    0
    So to get this all straight (Just got my phone, so really new):
    Ive downloaded chompsms, and task manager

    However my phone still shows 100% awake time, and phone/dial does not show up on task manager to close.

    What am i missing? o_O
     

Share This Page

Loading...