Speakerphone problem with galaxy rom?


  1. deeoh1084

    deeoh1084 Well-Known Member

    does anyone know how to fix the speakerphone for bh2 with the galaxy rom??? i flashed mine 6 times already tried to update 1 over and over and over still not working right it turns on sometimes with very very low volume... and sometimes it won't just turn on at all.... i have been asking people in behold2 chat but they are saying it's a known issue but i just wanna get this thing fixed and get over with because i use my speakerphone a lot :( but just to let you guys know who doesn't have this rom... GET IT!!! it's a must!!!!

    Advertisement
  2. mesovortex888

    mesovortex888 Active Member

  3. deeoh1084

    deeoh1084 Well-Known Member

    really?? for some reason mine doesn't work and i did the update #1 many times to get this fixed and i asked kam187 who created this galaxy rom and he told me to do the update #1 but still doesn't work and i asked him again and he told me that it goes in and out...... am i doing something wrong????
  4. mesovortex888

    mesovortex888 Active Member

    Then I have no idea. I did what the instruction told me to do and it work fine.
  5. deeoh1084

    deeoh1084 Well-Known Member

    quick question then when you are almost at the end.. you know how you have to copy and paste each line to adb???
    "# Take care the following must be typed consecutively. I suggest u copy/paste it
    echo "#!/system/bin/sh
    /system/bin/try3 /system/bin/sh
    mount -o rw,remount /dev/st9 /system
    cat /system/bin/sh > /system/bin/su
    chmod 04755 /system/bin/su
    mount -o rw,remount rootfs /
    mkdir /data/dbdata
    mkdir /data/dbdata/databases
    mkdir /data/dbdata/databases/com.android.providers.media
    mkdir /data/dbdata/databases/com.android.providers.contacts
    chmod 777 /data/dbdata
    chmod 777 /data/dbdata/databases
    chmod 777 /data/dbdata/databases/com.android.providers.media
    chmod 777 /data/dbdata/databases/com.android.providers.contacts
    ln -s /data/dbdata /dbdata
    /system/bin/playlogo_real" > /system/bin/playlogo"

    but right around chmod777 /data/dbdata

    the phone reboots by itself without me typing reboot
    and before it reboots in cmd it says "#end of image" did you have
    the same problem too??
  6. mesovortex888

    mesovortex888 Active Member

    If I remember right I don't think I saw end of image and the phone definitely didn't reboot by itself. Did you tried to ODIN the phone back to factory setting and then root it again and flash the Galaxy rom in? Sorry I can't really help you much on this because I am pretty much a noob myself too :) This is as far as I can help. Good luck. There are a few very helpful guys around here so I think someone will have the solution to your problem If you odin your phone and try again and still have the same result.
  7. deeoh1084

    deeoh1084 Well-Known Member

    yeah i did that many times actually i have no clue why my phone would
    do that... i root my phone all the time so i know rooting is not the problem but thanks for your help i'll ask those guys in the chat live again
  8. kam187

    kam187 Well-Known Member

    Hmm end of image is wierd. If you take too long running everything the phone will reboot, thats because we replaced half its apps without killing them.

    You should copy and paste the commands in blocks as i marked out, that'll make it really fast for you to do.

    RE the speaker, can you do some simple tests..

    - Root it as per normal
    - Factory reset
    - On boot, make a call and press speaker phone WHILE its rining - report the result here
    - Factory reset (no need to root again)
    - On boot, make a call, let the person pick up, then press speaker phone - report the result here
  9. deeoh1084

    deeoh1084 Well-Known Member

    am i suppose to flash the rom again first?? because i just tried with the current galaxy rom that was installed to my bh2 i'll try again by flashing the rom again
  10. kkarlin

    kkarlin Well-Known Member

    @deeoh1084 / KAM182
    I had the same issue, was really getting frustrated as I spent 2.5 hours on a congference call today and neither speakerphone nor headset would work. Anyway, I was searching for this solution (I had read about it over the last week), I called voicemail and placed the call on speaker - nothing came out. I then was reading this post and forgot the call was still active. Suddenly after about a minute the speakerphone started working and now appears to work flawlessly.

    HTH,

    KAM - THANK YOU so much for everything you have done to support this phone and community.

    Best,

    Kevin

Share This Page