Speeding up 'Album'


Last Updated:

  1. jsp_1983

    jsp_1983 Well-Known Member This Topic's Starter

    Joined:
    Dec 8, 2009
    Messages:
    123
    Likes Received:
    0
    Does anybody know how I can get Album to work faster, so that it doesn't take 2 minutes and 53 seconds (the present record) to display a list of files and respond to instructions?

    I know it's a lot to ask of a phone these days, but I thought it might be worth asking...
     

    Advertisement
  2. JimR123

    JimR123 Well-Known Member

    Joined:
    Nov 15, 2009
    Messages:
    103
    Likes Received:
    2
    2:53?!? Exactly what are you doing that takes that long?

    Perhaps it's the resolution of the photos you're browsing? If the photos are especially high-res, it might show a bit of a delay to load it into memory and show the thumbnail.

    And how many files are in the list?
     
  3. jsp_1983

    jsp_1983 Well-Known Member This Topic's Starter

    Joined:
    Dec 8, 2009
    Messages:
    123
    Likes Received:
    0
    They're pics that I transferred from my N95, alongside some that I've taken with the Hero itself. The rest I don't know, as I can't actually browse the pictures themselves! There are 495 in the 'all pictures' folder - not an unusual amount in itself, anyway.

    I've unticked 'downloads' in the folder display setting, but it seems insistent on displaying every image/ film clip on my SD card anyway.

    I've noticed that, aside from the sluggish performance of the app anyway, it seems to want to rebuild the thumbnails each time it's launched.

    I'm lucky if the app doesn't decide to quit on me after several minutes.

    Is this because Android is crap, or is it because the Hero is crap?
     
  4. jimeller

    jimeller Well-Known Member

    Joined:
    Aug 6, 2009
    Messages:
    409
    Likes Received:
    23
    If you clear the album cache that will slow down the loading of thumbnails as the phone will have to reload them again. Also task killers (spit) killing the album app (if there is one) won't you help either.
     
  5. Bunjiweb

    Bunjiweb Well-Known Member

    Joined:
    Jul 9, 2009
    Messages:
    259
    Likes Received:
    40
    Slow SD card? If you are using a card that is not at least Class 4 then it will be very slow to load high res photos, especially if it creating thumbnails of lots of them...

    Ben
     
  6. jsp_1983

    jsp_1983 Well-Known Member This Topic's Starter

    Joined:
    Dec 8, 2009
    Messages:
    123
    Likes Received:
    0
    Clearing the cache was one of the first things I tried, but to no avail :/

    The card is class 4, but even so, I've never had this problem before with other devices using the same speed card.

    Part of the problem seems to be that, as mentioned before, each time Albums opens, the thumbnails appeared to recreated from fresh.
     

Share This Page

Loading...