SPF'ed 6.05 Can't boot into recovery


  1. zoggynog

    zoggynog Member

    Hey Folks,

    Self admitted noob here, but I listen well.

    My Stepfather's DroidX went to crap on him, and he gave it to me. Battery was dead, wouldn't charge, going to bootloader. Went to Verizon and bought a new charged battery. Booted to red moto logo. Held down keys to get into bootloader, that worked.

    Followed SBF tutorial.

    Used 6.05 (had to take a guess, not sure what he had updated to)

    Everything in RSDlite 5.6.4 reported back fine, made it to 100%, rebooted phone back to bootloader.

    Per the tutorial, I pulled battery, put it back in, and held home while powering on. I am unable to get to recovery to do data/cache wipe. No exclamiation points, just the red moto logo.

    Let phone boot with no buttons held, stays at red moto logo.

    No SD card inserted (don't think that matters).

    What should I do next? I was really hoping he didn't go to SBF 6.21, but who knows. I could try to go to it, but I really don't want to lock down what rom I use.

    Looking for advice. I'll wait patiently, and keep myself from doing something stupid.

    Thanks knowledgeable people

    Advertisement
    :
  2. SaurusX

    SaurusX Well-Known Member

    I think if he was already on .621 and you tried to flash .605 that you'd end up at the bootloader screen with an error message. I lifted these instructions to get into stock recovery on Gingerbread from MyDroidWorld:

    1. Turn your phone off.
    2. Hold down “Home” and press the “Power”. Hold them until the Motorola logo appears
    3. Release the “Power” button, but continue to hold the “Home” button until you see an exclamation mark (!)
    4. Release the “Home” button and press the “Volume UP & Down” keys at the same time once (and only once!)
    5. Power button to select and Volume up and down to scroll

    If that doesn't work, then try the linux boot disc SBF method detailed at DroidXForums.

    Linux solution to your Windows/RSD lite problems
  3. colchiro

    colchiro Well-Known Member

    See if you can get into recovery and factory reset.
  4. zoggynog

    zoggynog Member

    Ok guys, So I sat there and pulled battery/put back in several times while holding home and hitting the power button.

    I finally got into Recovery.

    I performed a data wipe/cache wipe/factory reset.

    Phone is still staying on moto red logo.

    Is there any signs that would let me know I am on 6.21? Bootloader version, navigation buttons for recovery? It is responding to the up/down arrows and power button in recovery. 30.04 boot loader.

    If I use the Linux CD do I still have to provide my own SBF file? If so, which one do I use? Should I give 6.21 a try since 6.05 seems to have been a flop? I was really hoping to check out the CM9 build. Running it on my Galaxy Tab 7 and loving it. Bummer.
  5. SaurusX

    SaurusX Well-Known Member

    To me, using that last sbf would be my absolute last resort. The Linux boot disc is an all in one package that includes the sbf file. You literally boot it up and follow very simple on screen instructions.
  6. zoggynog

    zoggynog Member

    Alrighty Then.

    I'll report back with results.
  7. ylexot

    ylexot Well-Known Member

    Bootloader 30.04 is not .621

    BTW, it's .605 and .621, not 6.05 and 6.21. ;)

    Sent from my DROIDX using Tapatalk
  8. zoggynog

    zoggynog Member

    Told ya I was a noob!

    noted. Well I used the linux CD with .602 and SBF'ed this bad boy again. Everything went "well". I pulled battery, put back in, held home button, pressed power/held power button, let off of power button when the Moto logo showed, and....nothing. Now I can't boot into recovery again.

    I let it sit for 5 min, put battery back in and the only difference I notice now is a very small vibration shortly after the moto logo shows. Tried to get to recovery several more times. Pulled battery again. I'm going to let this sit on my ride home from work (30 min) and pop back in battery and try for recovery again.

    Good to hear that the 30.04 bootloader means it's pre .621! Too bad I'm failing to get it to actually function. Any other ideas? Maybe this thing is just broken. Weird that I can push out these flashes and WAS able to get to recovery though.
  9. SaurusX

    SaurusX Well-Known Member

    I've had instances of the phone booting, but the red M staying on the screen. When that happens what happens if your press the power button like your trying to do a shutdown or reboot? Does it vibrate? If so, it sounds like its booting, but the screen is locked at the M. Usually this problem resolves itself for me after a single reboot.
  10. zoggynog

    zoggynog Member

    Pressing the power button once it has the red M logo, doesn't do anything. The phone has to have the battery removed to shut down.

    The only way I've been able to get the power button to work is if I booted it into bootloader (which I can still do). I can use the power button there.

    No vibration except for a tiny one whe the Red M first shows (I assume the hardware is running a check)? It is VERY tiny. I bet some folks wouldn't notice.
  11. colchiro

    colchiro Well-Known Member

    So you're letting it sit for 30 minutes with the battery out, how long are you letting it boot? (have you tried 10 minutes?)

    Have you done a factory reset and format cache partition again?

    What shape is your battery in? Do you have a way to charge it (co-worker, ext charger)?

    It will not charge until it boots again so you need to plan for that.
  12. zoggynog

    zoggynog Member

    After using the Linux CD with .602, and having everything come back "normal", I pulled the battery several times and popped it back in. Now, I've let it sit for over 2 hours, and tried....with no luck. I then left the battery in for 15 min...pulled and tried again...no luck.

    That's what I can't do. When I first posed, I did the .605 SBF using RSDlite 5.6.4, which appeared to go well. I couldn't get into recovery. After I posted, I was somehow able to get in. I did factory reset. Phone still wouldn't boot.

    I moved onto the .602 Linux CD. It went fine. Pulled battery to start up recovery...can't get to picture of ! with Mr. Green man. I've tried leaving the battery out for a long time, leaving it in for 15 min, multiple pullings/putting in of batteries and holding down the home key then holding power. Letting off of power when I see the logo.

    The original battery was completely dead. I went to Verizon today before I started this and bought a brand new battery, with a charge. That's how I've been able to flash at all.

    Yup! It's starting to scare me now that I've flashed twice.

    Don't know what to do. It sounds like my boot loader version indicates the phone hasn't been pushed over to .621, but I can't get anything to actually flash and then boot. .605 with RSDLite 5.6.4 and the latest Linux ISO with .602 have been tried. With .605 I could get to recovery, but it didn't matter. With .602 I can't even get to recovery.

    Any other suggestions? Do I go Froyo? If so, Linux CD or RSDLite?

    Thanks all, this is frustrating. If I wasn't seeing completed flashes each time, and seeing recovery once, I would have already given up.
  13. SaurusX

    SaurusX Well-Known Member

    Truthfully, this sounds like some kind of hardware failure to me. At this point I can't see any reason that the phone shouldn't be booting up.
  14. jabbaj

    jabbaj Member

    Hi,

    I am presently in this same predicament. Was this issue ever resolved? If so,. how?
  15. lateralus73

    lateralus73 Member

    I went through this last night and drove myself crazy....install Droid 2 boot strap, then click on "Bootstrap Recovery", if successful it will say successful, make sure debugging is unchecked (under Applications), then reopen boot strap, click on "Reboot Recovery", and you should boot straight to recovery....seriously works like a charm. :D
Loading...

Share This Page