Root SPRevcovery didnt block my update??

Discussion in 'Android Devices' started by joshi3joshi, May 5, 2010.

  1. joshi3joshi

    joshi3joshi Active Member
    15

    Nov 14, 2009
    41
    0
    15
    update: Im actually now using Fabolous' NexBeast 1.0 rom, and i still have the 2.1 update downloading in the system updates..I installed the OTAfix.zip, but im not sure if i should update in case recovery doesnt block it again? WHat should i do?

    I've been running an ese53 rom for a while now, and a while back in March, i received the ota update, and since it was killing my battery life, I did the otacerts.zip trick into the security folder and sprecovery successfully blocked the update. For some reason, I got the 2.1 OTA update AGAIN today, and thinking that sprecovery would simply block the update once again, I clicked "install now". when it rebooted into sprecovery, it just installed!!?? It didn't block the update for some reason. Now Im back to stock 2.1, with no root priveleges and everything is force closing, i cant even get to the home screen. Fortunately, I made a nandroid backup, and sprecovery still works (but no root..), so i recovered back to my old backup, and things are working fine. however, the 2.1 update keeps telling me to install, and it keeps giving me the notification. anyone have a way to fix this? i dont know whats going on
     

    Advertisement
  2. dodger55fan

    dodger55fan Well-Known Member
    38

    Mar 18, 2010
    104
    20
    38
    Los Angeles
    There's actually an article about this here: http://www.droid-life.com/2010/05/04/new-android-2-1-updates-locking-down-droids/It's not the original 2.1 update, but actually a new update - read up on it, but I believe if you have sprecovery already installed you should be safe to update, but definitely double check with the article.

    I don't believe the OTAfix will necessarily block this thing, unless they have updated it in the past couple days...
     
  3. joshi3joshi

    joshi3joshi Active Member
    15

    Nov 14, 2009
    41
    0
    15
    hmm. okay. well i do have sprecovery installed, and it didnt block it.
    and the link you posted is broken i think. it says the page cannot be found. thanks for the help though!
     
  4. iamloco724

    iamloco724 Well-Known Member
    61

    Nov 6, 2009
    739
    4
    61
    with sp recovery your suppose to accept the update it will restart attempt to install then fail and then the notification will go away
     
  5. joshi3joshi

    joshi3joshi Active Member
    15

    Nov 14, 2009
    41
    0
    15
    no i understand, i have done this before with the previous ese81 ota update. that time sp recovery blocked it. however this time, when i click install, it ACTUALY installs WITHOUT blocking it, so thats my problem. im not sure why its not blocking it this time
     
  6. iamloco724

    iamloco724 Well-Known Member
    61

    Nov 6, 2009
    739
    4
    61
    not sure then..maybe reflash sprecovery?
     
  7. joshi3joshi

    joshi3joshi Active Member
    15

    Nov 14, 2009
    41
    0
    15
    hm, how should i go about doing that? haha sorry ive never needed to reflash a recovery, so im not sure what to do
     
  8. ska.t73

    ska.t73 Well-Known Member
    163

    Mar 11, 2010
    1,659
    305
    163
    Phoenix, AZ
  9. iamloco724

    iamloco724 Well-Known Member
    61

    Nov 6, 2009
    739
    4
    61
  10. joshi3joshi

    joshi3joshi Active Member
    15

    Nov 14, 2009
    41
    0
    15
    ill try. if it doesnt work, maybe ill just leave it in the system updates and not install it lol. as long as its downloaded and doesnt keep downloading and wasting my battery life, i guess its fine..
     

Share This Page

Loading...