[Sprint/Cricket] Rooted/Screen turns upside down when in landscape


  1. sgt0331gunr

    sgt0331gunr New Member

    Rooted my Galaxy S3 for Sprint within hours after I picked it up yesterday, now when I turn it in landscape mode, the screen flips upside down. My wife's phone does the same thing. Since I rooted it right away, I can't say whether it was doing it out of the box. Anyone having this issue or know how I can fix it. Also, is this a rooting problem? Thanks.

    Advertisement
  2. damewolf13

    damewolf13 live~laugh~love VIP Member

    Welcome to Android Forums!
    We are glad you have joined us here.

    I went ahead and moved this into the "all things root" section of this forum because I believe this is where you will get the help that you need.:)
  3. Hunterbeav

    Hunterbeav Well-Known Member

    If I were you I would first unroot one of the phones using the link on this site.... http://forum.xda-developers.com/showthread.php?t=1726558 I would reroot....you can't go wrong if you follow the video that's attached to the thread....just make sure you disable any virus protection you have running on your computer before rooting.
  4. amazin1988

    amazin1988 Well-Known Member

    That's strange I rooted my phone today n I haven't had that problem is yet
  5. digitaldmy

    digitaldmy New Member

    I had exchanged 4 galaxy s III that had factory problems. 1 of them after rooting where the screen turns upside down in landscape. I just rooted my replacement and BAM! there it is again. so it's definitely a problem after rooting and a factory reset even flashing to factory with odin still does the same thing. The reason I rooted is 1: being able to take control and leave the confines of AT&T bloatware. 2: to mask data usage with WiFi tethering root.

    Any answers? I'm at my wits end and AT&T is gonna crucify me if I go to replace another S III.
  6. youdoofus

    youdoofus Disabled

    thats weird... are you using the at&t specific roms? i only ask cuz this is the sprint forum. It really shouldnt affect the accelerometer in the phone, but who knows? And after rooting and experiencing this issue, have you tried recalibrating the accelerometer? May not yield anything, but its worth a shot. And if that doesnt work, you could try a rom other than the stock one. speaking of which, im really curious as to whats happening in the dev world with the official release of jellybean for this device (which was to be on the 28th) I called sprint and the rep confirmed that it was released on the 28th and that it was being pushed out in accordance with the ESN. Perhaps they are doing small batches and lord knows if our rooted devices can/will get the auto update. I sure as hell dont wanna lose root, nor do i wanna be the first poor sap in this forum to hafta post "my device auto updated to the new firmware, when can i expect to have a working root exploit?"
  7. Mr. Ed

    Mr. Ed Well-Known Member

    I believe Running a tmo or att base will result in this issue. The same is true if running a tmo or att kernel.

    What did you guys use to root?
  8. youdoofus

    youdoofus Disabled

    There's a YouTube video by qbking77 that shows what to do in Odin to root it. There's another method that doesn't trip the counter in the phone, but I don't think that's a permanent root method. But you use Odin to interface with the phone when its in download mode is the short short answer.
  9. Mr. Ed

    Mr. Ed Well-Known Member

    I am asking what specifically did they use....if it was a tmo or att Odin file the end result would be backwards rotation
  10. youdoofus

    youdoofus Disabled

    gotcha... sorry :(
  11. Ustinkoffear

    Ustinkoffear New Member


    anyone figure out a fix to this..i rooted my phone so i can use wifi tether on my unlimited data plan with tmobile...everything is working perfect except when i watch a youtube video and i use landscape it flips and its pissing me off..plz help
  12. hvrc

    hvrc Well-Known Member

    that could be your problem as you are on the sprint side of things...
    youdoofus likes this.
  13. bdk1021

    bdk1021 New Member

    I am having the same problem and I followed the rooting instructions of qbking77. I have get to figure a work around out. The problem is not hardware but software. I am assuming big brother over at sprint put a little koolaid in the system to discourage routing. I know that going to a custom from such as cm10 returns the screen to normal functions.

Share This Page