[Sprint/Cricket] Samsung S3 Won't Connect to Odin


Last Updated:

  1. frankfeeble

    frankfeeble Member This Topic's Starter

    Joined:
    Apr 10, 2013
    Messages:
    9
    Likes Received:
    2
    Hey all. I have a rooted Sprint Galaxy S3. I wanted to upgrade to 4.1.2, but I can't connect to Odin (box stays blue, won't turn yellow). I'm using the OEM cable and the phone connects and transfers with the PC fine.

    I have tried the following:

    • updated drivers on computer/allowed automatic update
    • tried connecting on two different PC's (one running W7 and one W8)
    • tried different USB ports
    • tried different cables
    • tried different versions of Odin (3.04 and 3.07)


    It appears based on the above that the issue is with the phone. What else can I do? Thanks in advance.
     

    Advertisement
  2. triger

    triger Well-Known Member

    Joined:
    Mar 17, 2013
    Messages:
    123
    Likes Received:
    9
    use samsung kies to get the driver
     
  3. funkylogik

    funkylogik share the love peeps ;) VIP Member

    Joined:
    Sep 15, 2011
    Messages:
    21,470
    Likes Received:
    7,234
    Cant remember if it has to be but is Usb Debugging checked in Developer Options mate?
     
  4. frankfeeble

    frankfeeble Member This Topic's Starter

    Joined:
    Apr 10, 2013
    Messages:
    9
    Likes Received:
    2
    I downloaded it and it says my firmware is up to date. I tried and still no yellow box. Thanks for the advice.
     
  5. frankfeeble

    frankfeeble Member This Topic's Starter

    Joined:
    Apr 10, 2013
    Messages:
    9
    Likes Received:
    2
    Yes it is checked for USB bugging.

    I'm pretty sure I rooted it using the Clockwork Recovery mod.
     
  6. mike710_0

    mike710_0 Well-Known Member

    Joined:
    Mar 26, 2013
    Messages:
    174
    Likes Received:
    18
    What version of Odin? I use v3.04 which works fine
     
  7. Mikestony

    Mikestony ~30% Carbon Black ± Moderator

    Joined:
    Sep 10, 2010
    Messages:
    27,103
    Likes Received:
    19,675
    I might be asking a stupid question here, but is the phone in download mode?
    And are you trying to unroot and take the update?
     
  8. frankfeeble

    frankfeeble Member This Topic's Starter

    Joined:
    Apr 10, 2013
    Messages:
    9
    Likes Received:
    2
    I've tried both 3.04 and 3.07.

    Yes, I reboot it in download mode with the [volume down + power + menu] method, then press volume up to enter the download mode.

    I am only trying to manually install the update.

    Thanks.
     
  9. Mikestony

    Mikestony ~30% Carbon Black ± Moderator

    Joined:
    Sep 10, 2010
    Messages:
    27,103
    Likes Received:
    19,675
    Kies and Odin don't play well with each other I have heard.

    Now, I don't use Kies, so I cannot comment when they are both trying to connect to the phone. :p

    You could try to either disable Kies or uninstall Kies and leave the drivers.

    I assume you have the drivers because you stated that your computer does see your phone normally. :)
     
  10. mike710_0

    mike710_0 Well-Known Member

    Joined:
    Mar 26, 2013
    Messages:
    174
    Likes Received:
    18
    Did you root the phone yourself or buy it like that? I can only think of a full factory reset to mind but am sure one of the more knowledgeable users on here can help
     
  11. Mikestony

    Mikestony ~30% Carbon Black ± Moderator

    Joined:
    Sep 10, 2010
    Messages:
    27,103
    Likes Received:
    19,675
    Moved to the Sprint root forum here too :)
    Personally, if you desire, I am sure there are custom roms with the 4.1.2 goodies baked into them if you don't want to unroot via Odin. :)
     
  12. frankfeeble

    frankfeeble Member This Topic's Starter

    Joined:
    Apr 10, 2013
    Messages:
    9
    Likes Received:
    2
    I've killed Kies in the Task Manager and it still won't connect.

    I rooted it myself.

    Can I unroot the phone without doing a factory reset? I'd rather not wipe the phone if I don't have to.

    Are there any other things I can try to get Odin to work? The program worked fine when I rooted it. Any ideas what could have caused my phone to not want to connect to Odin? Any potential settings/apps that could be causing this? The phone is definitely set to debugging.
     
  13. Mikestony

    Mikestony ~30% Carbon Black ± Moderator

    Joined:
    Sep 10, 2010
    Messages:
    27,103
    Likes Received:
    19,675
    Went back to your first post....what box? If it's the box I'm thinking of, it's supposed to be blue.:confused:

    [​IMG]
     
    DragonSlayer95 likes this.
  14. DragonSlayer95

    DragonSlayer95 Resident Air Bender Moderator

    Joined:
    Mar 9, 2012
    Messages:
    8,752
    Likes Received:
    3,698
    Very true, older versions of odin, Green Light is yellow.

    But the newer version is blue.

    Blue is good :) :thumbup:
     
    Mikestony likes this.
  15. frankfeeble

    frankfeeble Member This Topic's Starter

    Joined:
    Apr 10, 2013
    Messages:
    9
    Likes Received:
    2
    I tried and still got the error message, see SS below:

    [​IMG]
     
  16. Mikestony

    Mikestony ~30% Carbon Black ± Moderator

    Joined:
    Sep 10, 2010
    Messages:
    27,103
    Likes Received:
    19,675
    Are you flashing the right file?
    Looks like that file is for the I9305.
     
  17. DragonSlayer95

    DragonSlayer95 Resident Air Bender Moderator

    Joined:
    Mar 9, 2012
    Messages:
    8,752
    Likes Received:
    3,698
    :eek::eek::eek:

    Don't attempt to flash whatever your trying to flash!

    That's for India's s3 only!

    Like Mike has already stated, you can flash a rom based off of the latest OTA, much easier.

    Otherwise if your persistent on doing the actual update, I believe there is a Flashable stock recovery.
     
    Mikestony likes this.
  18. frankfeeble

    frankfeeble Member This Topic's Starter

    Joined:
    Apr 10, 2013
    Messages:
    9
    Likes Received:
    2
    I'm on a Sprint S3- should I be using the I9300 file?
     
  19. DragonSlayer95

    DragonSlayer95 Resident Air Bender Moderator

    Joined:
    Mar 9, 2012
    Messages:
    8,752
    Likes Received:
    3,698
    See my above post.

    Definitely not. You should only flash L710dspr tar files.
     
    Mikestony likes this.
  20. Mikestony

    Mikestony ~30% Carbon Black ± Moderator

    Joined:
    Sep 10, 2010
    Messages:
    27,103
    Likes Received:
    19,675
    No, the I9300 file is for an international version.
    Let me ask you this, what do you desire to do.?
    Unroot and take the latest OTA?
    Or, flash a rom with the OTA's baked into it.?

    Edit: I even get ninj'd here too :p
    It's all good tho :thumbup:
     
    DragonSlayer95 likes this.
  21. DragonSlayer95

    DragonSlayer95 Resident Air Bender Moderator

    Joined:
    Mar 9, 2012
    Messages:
    8,752
    Likes Received:
    3,698
    Mikestony likes this.
  22. frankfeeble

    frankfeeble Member This Topic's Starter

    Joined:
    Apr 10, 2013
    Messages:
    9
    Likes Received:
    2
    Do you know where I can get a rom? I am unfamiliar with the topic. Thanks for the help! Luckily I didn't brick this big beautiful phone.
     
    DragonSlayer95 likes this.
  23. DragonSlayer95

    DragonSlayer95 Resident Air Bender Moderator

    Joined:
    Mar 9, 2012
    Messages:
    8,752
    Likes Received:
    3,698
    Sure no problem, would you prefer a stock rom or a custom rom?

    You'll also need to flash the radio/modem as well.

    Give me a few and ill fetch some links for you :D
     
    Mikestony likes this.
  24. DragonSlayer95

    DragonSlayer95 Resident Air Bender Moderator

    Joined:
    Mar 9, 2012
    Messages:
    8,752
    Likes Received:
    3,698
  25. frankfeeble

    frankfeeble Member This Topic's Starter

    Joined:
    Apr 10, 2013
    Messages:
    9
    Likes Received:
    2
    Thanks dude!
     
    DragonSlayer95 likes this.

Share This Page

Loading...