1. Download the #1 Android News App:   EarlyBird - News for Android
    Dismiss Notice

[Sprint/Cricket] TWRP assert failure when flashing .zip files

Last Updated:

  1. taaz69

    taaz69 New Member

    Hello. I would like your thoughts and help on this. I have the Samsung GSIII

    I am using TWRP When I try to install a zip, no matter what zip, I get an error. This one is related to a TWRP update.

    assert failed: getprop("ro.product.device") ==
    E:Error in /sdcard/twrp exfat skunk.zip
    (Status 7)
    E:Error flashing zip /sdcard/twrp exfat skunk.zip

    I went to the build.prop to see what's what I see the line:
    #ro.build.product is obsolete; use ro.product.device

    Checking above this line , I see

    This started when I tried to run the OTA update. I was able to update freeza's Jelly Bean 4.1.2 and firmware without issues. After, I tried the TWRP update again, getting the same errors.

    I know the solution is staring me in the face but, I cannot seem to figure it out. Searching the forums is not helping much.

    Any assistance you can provide would be greatly appreciated.


  2. scary alien

    scary alien not really so scary Moderator

    Welcome to the AndroidForums, taaz69!

    Sorry for the delayed response...can you tell us which SGS3 / carrier you have (we'll probably need to move your posts re. this to an appropriate SGS3 all-things-root sub-forum (this is the VZW GNex area), but we'll take care of that later ;)).

    So every .zip file you try to flash gives you a status 7 error? Could it be because of signature checking turned on in TWRP (I haven't got installed on my GNex, so I'm not sure where that option is)?

    Also, have you tried running my OTA Verifier app against one of the .zip files? (it doesn't matter that their not OTA files--it'll attempt a verification on any .zip with a properly built edify updater-script file).

    Lemme know and I'll try to help :).
  3. jhawkkw

    jhawkkw Chinchillin' Moderator

    Looks like sprint based on the device id in the output.
    scary alien likes this.
  4. scary alien

    scary alien not really so scary Moderator

    Good catch and thank you, jhawk! :)

    Posts moved to the SGS3 Sprint all-things-root area (I'll send taaz69 a PM, too).

    taaz69, let us know what else you can tell us.

    jhawkkw likes this.
  5. taaz69

    taaz69 New Member

    Thanks you for the welcome and getting me to the right place. :)

    Signature checking is turned off. Not every zip. I first noticed this when I tried to install the OTA update. It failed with basically the same message. I tried updating TWRP with the same result.

    I thought I'd try flashing freeza's rom and firmware update. These flashed fine. Strange, huh? I would like to flash to a version of twrp that handles the 64gig sd card. I see twrp works.

    I ran OTA Verifiy. If found 6 frozen apps, non of which should effect this:
    ChatOn, Game Hub, Kies air, Kies via Wi-Fi, Nfc test, Nfc Service. Outside of this, no issues seen.


    Thanks for taking the time to help. It is very much appreciated. :)
    scary alien likes this.
  6. scary alien

    scary alien not really so scary Moderator

    No problem, taaz69--thank you also for the additional info.

    It is interesting that there's a note in the change log for TWRP which is suspiciously similar to what you are reporting:

    TeamWin Projects - TWRP 2.4 - | TeamWin

    Sounds like maybe they didn't address all of the issues?

    Perhaps upgrading to a more recent version will fix your issues (looks like is the latest version).

    Let us know if you try that :).

    taaz69 likes this.
  7. taaz69

    taaz69 New Member

    LOL, I am trying to get to a more updated version. :)

    I checked those logs but, that specific issue does not seem to be it. The system is not mounted unless I'm missing something.

    I was looking at this site to update twrp to a version that supports exfat.

    TWRP Custom Recovery with EXFAT Support - Android Forums at AndroidCentral.com

    Again, you are awesome for taking the time to help.
    scary alien likes this.
  8. GTWalling

    GTWalling Well-Known Member

    Just an FYI, you must have Stock Recovery for OTA updates and frozen system app, does not mater which ones, can sometimes cause a problem for OTA.
    taaz69 and scary alien like this.
  9. taaz69

    taaz69 New Member

    Point taken. Thanks for the reminder. It has been a while since I have had to mess with this. :D

    To tell you the truth, I'm not sure how/when I got twrp. I probably did this a while back. This rom has been running so good, I did not need to mess with it. I updated freeza's rom and all so I'm good there.

    I'm not really concerned with getting OTA's since I just flash a rom when the need arises. It just happened that when I tried, I got the error which led into the same error flashing twrp. The only thing I would like to do at this point is update twrp to get exfat support.

    Thanks for the help! :)

    Update: I finally got time to work on this. I installed the latest twrp via Goo Manager. All is good.

    May the force be with you!
  10. John Bloch

    John Bloch New Member

    I have TWRP. Last time I OTA updated, I copied the update file from the cache directoryon my phone to my PC, then I modified the updater-script file and deleted the getprop lines. Put it back in the zip file and copied back to the cache directory on my phone. It worked after that.
  11. scary alien

    scary alien not really so scary Moderator

    Just a reminder that you need to be careful when doing that (removing lines) since the getprop asserts are there to cross-check that your environment matches what the updater-script file expects to find during/for its install.

    The reason for this is that OTA's sometimes patch existing files vs. wholesale replacing (although the apply_patch_check assert will also cross-check the individual file being patched to make sure it matches what is expected, too).

    The above being said, if you've got TWRP (or another custom recovery) installed, then you should (hopefully :)) have a Nandroid backup to fall back to should any problems arise, eh? ;)

    mydian likes this.
    Last edited: Jul 26, 2015

Share This Page