[Sprint] Galaxy Victory Struck in ODIN mode

Last Updated:

  1. yakaaithiri

    yakaaithiri Member

    Hi All,

    I have a Samsung Galaxy Victory (SPRINT), the device is all the way upgraded to Android 4.1.2 ... Due to some requirement , i tried to downgrade the device to ICS 4.0.4... I used the file "COMBINATION_L300VPALH1_L300SPRALH1_934170_REV00_user_low_ship.tar.md5"
    to downgrade using ODIN... The ODIN flash went well till the last step and it failed in the last step after flashing the user data. ... The error shown in the screen is INVALID IMG EXT4 file... Currently my mobile is struck in ODIN mode and i am not able to boot.

    Can any one please guide me to recover my device. File i used to downgrade are from these 2 links..

    [ROOT][ROM][ODIN]Odin One Clicks for the Galaxy Victory

    [odin][tar]stock rom repository

  2. xInterlopeRx

    xInterlopeRx Well-Known Member Developer

    Alright, here's the skinny:
    Download: TWRP-2.5

    Sprint Galaxy Victory JB 4.1.1 Stock

    Flash the recovery with Odin using the instructions HERE!!!

    Follow them to a T!
    At this point the device will still not boot. Expect that. It should boot into recovery however and that's what you want for now.
    Next, copy the victory_jb_factoryreset.zip onto an sdcard and extract them. Recovery might not see the sdcard if it's removed and inserted while in recovery so you may have to reboot back into recovery after doing this; or do something much more logical and do it first...Or if you can navigate the file system in Windows File manager do that.

    Once in recovery hit "Advanced" then "File Manager". Navigate around to where you just copied the victory system files. Enter the directory containing them and select "Copy" This should copy the contents. Now, navigate to a TWRP/BACKUPS/serialnumber/and paste the contents there. So, you should have TRWP/BACKUPS/serialnumber/backupname/files

    If that is confirmed hit the home key and select "Restore" chose internal or external storage; whichever is appropriate. TWRP will find the backup and you will chose it. Swipe to flash. After flashing wipe Dalvik cache and reboot to system. This should all get you back to working.
  3. yakaaithiri

    yakaaithiri Member

    Thank you so much for the file, i am downloading them right away , will check and let you know ...

    Sir, is there a way to boot into Android 4.0.4 ..? .. is there is a TWRP backup or something you have that you can share will be ok great help ..
  4. yakaaithiri

    yakaaithiri Member

    Hi, I flashed the file you have given me and the mobile is up and running now.. However i am not able get the WIFI and bluetooth up .. Its not getting started. The Version of android after restoring the backup is 4.1.1 .. Do i need to flash any modem after restoring your backup ?
  5. xInterlopeRx

    xInterlopeRx Well-Known Member Developer

    I can provide 4.0.4 but it may take some time. Also, I had forgotten to subscribe to the thread and it is not automatic; I will get alerts now. I will replay again when I have a solution. In the meantime please provide the device baseband and kernel version.
  6. yakaaithiri

    yakaaithiri Member

    Baseband Version : L300VPLH1
    Kernel Version : 3.0.31-413893 se.infra@sep-63 -1
    SMP PREEMPT SAT OCT 27 14:00:29
    KST 2012

  7. xInterlopeRx

    xInterlopeRx Well-Known Member Developer

    Ok, so there is confirmation of a firmware mismatch. I am uploading a nice factory file set for 4.0.4 that will flash with Odin. Looks like it's going to take 2-3 more hours to upload but it works completely. This is the link right here

    Give it some time to finish and you will be back to 100% stock 4.0.4.
  8. yakaaithiri

    yakaaithiri Member

    I tired ODIN the rar file you gave , its throwing the same error in the last step of flashing ... Is it possible to get a 4.0.4 TWRP backup that i can restore ? ... I guess, that will be helpful for me ... Thanks ... Now the device is up and running ,but the WIFI and Bluetooth not working...
  9. xInterlopeRx

    xInterlopeRx Well-Known Member Developer

    I verified this method works with my device. Install Kies from the Samsung site to make sure you have the right drivers and if you are not using Odin3 get that program from waywardpilgrim.net

    The Samsung drivers are there too if you don't want to install the entire Kies program. Usually, these types of problems are caused by outdated drivers and bad USB cables. I can't even tell you how many people come and say "Oh, man, I switched cables and everything worked perfectly"
    Doc likes this.
  10. yakaaithiri

    yakaaithiri Member

    HI thanks for the reply, i checked in 2 different systems and 2 USB cables also , the issue persists .. Do you think its a issues with the hardware ...

    Or as i have upgarded to 4.1.2 the baseband cant be downgraded or something like that.? ... Do you have a backup TWRP backup of 4.1.2 ? ... If you can generate one and give me it will be of great help to me ...

    Or if you have a backup of Android 4.0.4 for Victory that might also help me ... Please do me a favour here , i cant live without wifi and bluetooth :( ...

    Is there any custom ROM for this device, which i can install right away form the recovery ?
  11. xInterlopeRx

    xInterlopeRx Well-Known Member Developer

    I have flashed my device nearly 400 times and have not had this many problems. I suppose the USB port on your device may be damaged. I just returned from the doctor with my arm in a splint. I can't do too much else for a few weeks. I am going to try and get you back to 100% then it's break time for me. I'll let you know when there's more files available.


    EDIT: flash the linked file and tell me what happens.
  12. xInterlopeRx

    xInterlopeRx Well-Known Member Developer

  13. yakaaithiri

    yakaaithiri Member

    Great i will check flashing both the file and let you know ... I am seeing that, when i flash via ODIN , i am getting error in the userdata.img part ... Also , when installing using TWRP i am seeing an common error called unable to mount DATA ...

    So , can we prepare a ODIN package without userdata.img part and try flashing . Will it work ? .. Is the userdata.img a mandatory one...
  14. xInterlopeRx

    xInterlopeRx Well-Known Member Developer

    you can try whatever you like, but as you can see many other have succeeded repairing their devices with the things I provide. I have tested all the files, done exactly as I have instructed and back and forth. If there is a problem at this point it's not my files. They work fine. Please read the other threads for more support. As I mentioned earlier, I've done all I can and need to be off the computer for a few weeks.
  15. jhawkkw

    jhawkkw Chinchillin' Moderator

    If you're getting mounting issues, you could possibly have corrupt partitions. Have you tried flashing the appropriate .pit file with your factory tar image?
  16. yakaaithiri

    yakaaithiri Member

    Where can i get the PIT file.? ...
  17. jhawkkw

    jhawkkw Chinchillin' Moderator

    The .pit file is the partition map that tells Odin how to repartition your device. Someone normally has to extract it from a working stock device. It might be uploaded here or another site by a developer, or it can be done on the spot by someone if it can't be found using Heimdall 1.4. Unfortunately, I don't have this device so I'm unable to do it.

    Let me do a quick search to see if I can find one, otherwise we'll have to try to convince someone to extract theirs.
  18. yakaaithiri

    yakaaithiri Member

    Thanks , please share the same when you get it ...Also let me know how to flash the pit file....
    Also if you have a 4.1.2 OTA update ZIP please share the same.
  19. Doc

    Doc Well-Known Member

    Sounds as if you could have a bad download, I have seen this a few times myself before......... I would check the MD5 SUM of the download just to double check.....

    Also this is out on XDA


    And from what I have read it does work.....
  20. yakaaithiri

    yakaaithiri Member

    The download is perfectly fine ... I guess i have corrupted partition .. May be i need a pit file as said by "jhawkkw" ... Can anyone give me a pit file for Samsung Galaxy Victory (SPRINT),...
  21. yakaaithiri

    yakaaithiri Member

  22. jhawkkw

    jhawkkw Chinchillin' Moderator

    Glad you got it working. I couldn't find a pit file by searching, and I would still recommend that someone extract it from their device and allow a staff member to upload it to a root sticky just in case people need it. I know having one saved my behind at least once in the past.
    Doc likes this.
  23. NotSoBrown

    NotSoBrown New Member

    Is there any way you could get a .md5 or .tar file for that stock ROM? that would be much appreciated! (galaxy victory 4G Virgin Mobile) I cannot tap on the screen in recovery mode nor can i even get to recovery mode anymore. I get this in download mode "Firmware upgrade encountered am issue. Please select recovery mode in Kies & try again" I tried but i do not have a code to use... if you could find a code to use.. that would be great too! Thank you for the feedback... if any haha

Share This Page