1. Introducing Channels - a new way to chat with other Android users!
    Dismiss Notice

[Sprint] I cannot relock my bootloader anymore.


Last Updated:

  1. pandacookie

    pandacookie Panda-riffic! This Topic's Starter

    Joined:
    Apr 18, 2011
    Messages:
    574
    Likes Received:
    211
    Soooo I saw this guide: Guide - Get s-off on 1.31 HTC One (Sprint) Update: - xda-developers, and I thought I'd try to s-off on the current bootloader (1.55), not knowing at the time that the exploit was patched. Well, it didn't work, to say the least. In one last attempt I tried to relock.

    And that's when the weirdness began. I got a big fat "FAILED: error unknown" in the command prompt when I issued the command to relock. The bootloader said it was relocked, though. When I would try to reboot to the OS, it would go straight to the bootloader. When I would try to go to recovery, it would go straight to the bootloader. So I unlocked, and all was back to normal. I tried relocking again and the same results occured.

    I was running this rom at the time. Not sure if that matters, or if I need to be on straight stock to do this. I haven't rooted an HTC phone in a long time and I rooted this phone the other day. The phone IS running normally, except for Facebook crashing every so often.

    I guess the main point is: should I worry? Should I leave stuff alone and stop experimenting? Should I fix this?
     

    Advertisement
  2. pandacookie

    pandacookie Panda-riffic! This Topic's Starter

    Joined:
    Apr 18, 2011
    Messages:
    574
    Likes Received:
    211
    No one wants to help a Panda out? :(
     
  3. pandacookie

    pandacookie Panda-riffic! This Topic's Starter

    Joined:
    Apr 18, 2011
    Messages:
    574
    Likes Received:
    211
    It's dead here. :(
     
  4. jhawkkw

    jhawkkw Chinchillin' Moderator

    Joined:
    Jul 30, 2011
    Messages:
    10,634
    Likes Received:
    7,396
    Try sending scotty85 a pm to check this thread out., he's a HTC guru so to speak.
     
    scotty85 likes this.
  5. pandacookie

    pandacookie Panda-riffic! This Topic's Starter

    Joined:
    Apr 18, 2011
    Messages:
    574
    Likes Received:
    211
    Yeah. I was hoping he'd spin by and see this. But yeah. I'm gonna do that. Thanks.
     
    scotty85 likes this.
  6. clsA

    clsA Well-Known Member

    Joined:
    Apr 8, 2013
    Messages:
    652
    Likes Received:
    551
    Hi .. sorry for not answering sooner
    Theirs no real point in relocking the bootloader now, you already discovered that s-off is not possible after taking the OTA update. Just flash roms and enjoy your newly rooted One.
     
    jhawkkw and scotty85 like this.
  7. scotty85

    scotty85 Guides Guide

    Joined:
    Jul 25, 2010
    Messages:
    11,138
    Likes Received:
    7,418
    sorry for the late reply,ive had a fair amount on my plate lately and havent made my usual rounds in a couple days :eek:

    the typical response to fastboot oem lock when the phone sees everything as it should(stock recovery,kernel and rom) is:
    ... INFOLock successfully...
    FAILED (status read failed (Too many links))
    finished. total time: 0.154s


    its been sooooooo long since ive locked a bootloader while still s on,but i believe your "unknown error" is typical of relocking when having a custom recovery,rom,etc. on the phone.

    the rest of what you described,is definately normal,and you likely noticed the security warning at the top of the bootloader screen.

    when the phone finds custom software it wont let you boot to the OS,recovery etc,exactly as you said. the phone stays this way until you re-unlock,or run an official,signed ruu.

    so i dont think youve anything to worry about at all. as clsA said,enjoy your newly rooted phone,and holler if you have any more questions :)
     
    jhawkkw likes this.
  8. pandacookie

    pandacookie Panda-riffic! This Topic's Starter

    Joined:
    Apr 18, 2011
    Messages:
    574
    Likes Received:
    211
    Cool! Thanks for the answers! At least I know now I didn't screw anything up! :)
     
  9. scotty85

    scotty85 Guides Guide

    Joined:
    Jul 25, 2010
    Messages:
    11,138
    Likes Received:
    7,418
    lol,yup youre fine. rest assured its difficult to impossible to screw up an s on phone with software flashes :smokingsomb:
     
    jhawkkw and pandacookie like this.

Share This Page

Loading...