[Sprint] Issues Rooting HTC One

Last Updated:

  1. apophus

    apophus New Member

    So, has anyone attempted to root an HTC One, yet? I unlocked the boot loader and flashed TWRP. But then, when I went to make a recovery it listed my internal memory at about 1.7 GB (I actually have something like 27 GB). Further, whenever I try to go through with it anyway, I get an error message that essentially tells me it is unable to mount /system. I'm honestly a bit stumped, and I've now attempted this twice to be sure I hadn't simply messed up somewhere.

    I'd love some advice from someone who may know better than I do. I'm still relatively new at this.

  2. scotty85

    scotty85 Guides Guide

    What version of twrp did you flash?
  3. apophus

    apophus New Member

    I flashed TWRP

    And thank you for responding.
  4. scotty85

    scotty85 Guides Guide

    what process did you use? sounds like you maybe have htcdumlock enabled,wich has installed twrp into the boot partition.

    if thats the case,we need to restore your original boot image.

    normally with htcdumlock,the recovery backups up the boot image,you flash the rom,and if needed,you can restore the original boot image.

    not being that familiar with actually using dumlock,im not sure wat the exact settings are,but you might look for an option in recovery to restore the boot image.

    failing that,you might try flashing a rom,or we can try and find you a stock boot image to flash using fastboot.
  5. apophus

    apophus New Member

    Ok, I may have figured out what went wrong. So, I went ahead and relocked my boot loader and ran RUU to get back to square one. I unlocked the boot loader and stopped myself...I noticed a subtle difference with TWRP versions for the HTC One. It seems like there's a difference - one is and the other is I have the Sprint model (the latter version), not the AT&T/etc. model (the former version). Once I did that, it seems like all went well.

    That's what I get for not paying more attention to details. It's a heads-up for anyone rooting an HTC One, at least.

    Thank you for responding.
  6. scotty85

    scotty85 Guides Guide

    yup.. the sprint and gsm variants are not compatible/interchangeable. admittedly, that was my first thot,but sincethe results you had are not what id have expected from flashing the wrong one,so i just assumed you had used the correct one,since it had booted and appeared to be working. :eek:

    at any rate,im glad you are now sorted and back up and running. :)
  7. Recoil1

    Recoil1 Well-Known Member

    Another problem. I did the HTC unlock, downloaded goo manager, did the open recovery download then nothing happened. Open recovery said it downloaded and it is in my goo manager as an .img file. I then tried the ADB shell and the fast boot and I still could not get TWRP on my phone. Every time I go and try to get into recovery through the boot loader it just shows me the red triangle after waiting over a minute. I have wiped and rebooted my phone and still have not been able to get twrp on. I did notice something strange is when I started goo manager there was no asking for super user permission. Do I have to download a super user program or does that come with the htc dev unlock?
  8. scotty85

    scotty85 Guides Guide

    My advice would be to leave goo manager out of the equation. Download on your PC,then transfer to your adb/fastboot folder :)
    Recoil1 likes this.
  9. Recoil1

    Recoil1 Well-Known Member

    It seems my phone says it is unlocked but I cannot get anything to have root privileges. I gave up on goo manager and just downloaded superuser chainsdd then tried to download wifi tether and it told me I did not have root privileges and it wouldn't work. I have since relocked my phone and unlocked it through htc dev and it still won't take anything that requires root even though it says it is unlocked in the boot screen.
  10. scotty85

    scotty85 Guides Guide

    being unlocked does not give you root priveledges. you also cannot download the superuser app from the market,as this only installs the app,not the matching binary that the app needs to distribute root priveledges.

    the basic steps to root are:
    1)unlock bootloader
    2)temporatily or permantly install a recovery
    3)flash superuser root package in recovery

    youve only done #1,not 2 or 3. use this guide to help you do steps 2 and 3: http://androidforums.com/international-one-all-things-root/720478-htc-one-root-thread.html
  11. Recoil1

    Recoil1 Well-Known Member

    Ok I took your advise and installed TWRP through fast boot and it actually took unlike trying to do it through goo manager. It seems compared to the other root methods I have done that HTC Dev does not grant superuser permission and I had to let TWRP do it for me. I have since been granted SU and have loaded Viper rom through TWRP. This was a little confusing coming from root methods that include super user in its own package.

    I added to your Thanks!
    scotty85 likes this.
  12. scotty85

    scotty85 Guides Guide

    awsome. glad you are sorted. :cool:

Share This Page