1. In regards to recently combined carrier specific root forums, if your device forum was affected, please see this poll/thread!

[Sprint] Need some help! Currently in a very bad situation.


  1. EXDetonator

    EXDetonator New Member

    Okay, I'm not sure exactly what happened, but long story short:

    I flashed a rom and instead of getting a new rom on my phone, the phone rebooted into fastboot. I tried to enter recovery... no dice. Somhow my recovery uninstalled itself. So now I'm stuck with a phone with no rom installed, and no recovery installed. Frustration.

    First step would be to reinstall recovery right? But when attempting to use fastboot flash command, i get stuck at <waiting for device>. I have the htc phone driver installed, and it's recognizing the phone is plugged into the pc in device manager. The phone screen even says FASTBOOT USB. I have no idea why it's not flashing. The recovery i'm trying to flash is twrp, the latest sprint build. It's the same one I had before it somehow uninstalled itself.

    he phone is coming up on device manager as "My htc", so it's definitely plugged into the computer correctly. For some reason, if I try "fastboot devices" nothing pops up. That means maybe there's a driver issue?

    Please help out guys?
    Thanks.

    BTW, Sprint HTC One.

    Advertisement
  2. BRAINZ2013

    BRAINZ2013 Well-Known Member Contributor

    Hello and welcome to the forum. I see your android device causing trouble . now you need to downgrade or get back to the stock firmware . what is the phone make and model you have
  3. EXDetonator

    EXDetonator New Member

    I have the HTC One, Sprint (m7wls, s-0n). I'm fairly certain in order to do anything more, I need to be able to use fastboot which sadly currently is not working as mentioned in my above post. I would greatly appreciate assistance. Thanks.
  4. BRAINZ2013

    BRAINZ2013 Well-Known Member Contributor

    scotty85 likes this.
  5. EXDetonator

    EXDetonator New Member

    I think there may be some confusion, or I have no clue what I'm doing. The links you sent me are just for getting the phone to boot. My phone boots perfectly fine into hboot, but I have nowhere to go from there: no rom installed, no recovery installed (as stated in my initial post). The problem is I can't flash the recovery because the fastboot command won't work from cmd. My computer recognizes the phone is plugged in, but the fastboot flash recovery command gets stuck at <waiting for device>. I'm not sure if the links you sent can help in this situation.
    scotty85 likes this.
  6. clsA

    clsA Guides Guide

    so your in the bootloader at fastboot usb and from your pc you type fastboot devices and you get nothing ?
    are you on windows 8.1 ?
    scotty85 likes this.
  7. BRAINZ2013

    BRAINZ2013 Well-Known Member Contributor

    Well I see u said u was stuck the only thing I could think of was to redo the firmware. Sorry if I was wrong but if u have all drivers installed nothing is wrong but u installed the wrong firmware and or wrong drivers u lost root that's why I did the 2url to get you wiped clean and new install of the ruu or u can keep trying to fix the problem
  8. Bodhi Brock

    Bodhi Brock VIP Member VIP Member

    I'm having a similar problem after relocking and taking OTA Kit Kat and then trying to reflash CM. Tried reflashing RUU but after the KitKat update my downloaded RUU is now outdated with no updated ones available yet. I'm very new(bie) with most of this but want to learn...and also want a working phone again. My wife is going to be going into labor any day now! She's not very happy with my unsuccessful tinkering at this point...
  9. BRAINZ2013

    BRAINZ2013 Well-Known Member Contributor

    Hello hey how you doing welcome to the forums . in order to help you I need to know what device you have ruu can be ran on every HTC device I also need your hot boot information . and what would u like to do go back to the os and unroot cause this is what the ruu will do
    Bodhi Brock likes this.
  10. Bodhi Brock

    Bodhi Brock VIP Member VIP Member

    I have the 3.05 (O.M.J's) RUU on my HTC One from Sprint (m7spr).
    HBOOT is 1.56.0000.
    RADIO: 1.00.20.1108.
    OS: 4.06.651.4
    ***Unlocked*** S-ON

    I would like to root and install the "ROM God" (Eminem Remix) of all ROM's. I'm an audiophile #1. Would like the fastest, most kickass ROM of ALLLL-TIMMEEE! :D

    Thank you!
  11. Bodhi Brock

    Bodhi Brock VIP Member VIP Member

    I HAD O.M.J's 3.05 RUU. Now I have nothing but a bricked One and a 39 week pregnant wife. :stupid:
  12. Bodhi Brock

    Bodhi Brock VIP Member VIP Member

    Going back to stock would be good too at this point. From what I understand, however, there is not a RUU out for Kit Kat (OS 4.06) yet.
  13. BRAINZ2013

    BRAINZ2013 Well-Known Member Contributor

    I need the other numbers behind the 3.05 but as I see u just made it easy you need to unbrick and returned to stock with options to reroot
  14. Bodhi Brock

    Bodhi Brock VIP Member VIP Member

    I'm sorry. 3.05.651.6. Yes.
    That would be wonderful.
  15. BRAINZ2013

    BRAINZ2013 Well-Known Member Contributor

  16. scotty85

    scotty85 Guides Guide

    Clsa has given you the steps to fix your phone in the other thread. These steps are what you'll need to do until a 4.06.651.x ruu is released. Since you are s on,you're sol for running an older ruu.

    -download recovery
    -manually install recovery
    -download rom
    -install rom via recovery adb sideload option.

    We are happy to help,but Please keep your questions about this process in that thread to avoid confusion. :)
    BRAINZ2013, Bodhi Brock and clsA like this.

Share This Page