1. Download the #1 Android News App:   EarlyBird - News for Android
    Dismiss Notice

[Sprint] UNroot HTC ONE on Sprint

Last Updated:

  1. Mjr465

    Mjr465 Member

    Im just trying to unroot my HTC ONE and go back to stock. Im getting ERROR 140 BOOTLOADER VERSION ERROR, when I run the setup.exe file, what can I do to repair this? Ive got Sprint_HTC_One_m7wls_1.29.651.7_RUU but the version on the phone Is version 1.31.651.2 I cant seem to find the correct one to return it to stock. Do you have any suggestions? I have TWRP 2.5installed, HBoot 1.44, bootloader is unlocked s-ON Now the camera, and wifi will not work.

    Just want to go back to flat out "boring stock" :confused:

    ANY and ALL help is definitely appreciated!

  2. Mjr465

    Mjr465 Member

    If I follow this process will it return me to stock? This is the closest thing Ive found to hopefully repair the issues. I found this page [PLACEHOLDER] [02.10.2013] HTC One firmware collection for different CID/MID - xda-developers

    Re-lock your bootloader (this will most probably wipe content of your device)
    Copy downloaded .zip to fastboot.exe location (e.g. c:/SDK/platform-tools/fastboot.exe)
    Re-name .zip file to firmware.zip
    Open command prompt
    Boot your device in fastboot mode (vol down + power ===> fastboot)
    Connect device to the PC
    In command prompt cd to fastboot.exe location
    Make sure you have correct modeid and cidnum (type: fastboot getvar all)
    Type: fastboot oem lock (if your device is not relocked yet)
    Type: fastboot oem rebootRUU and wait for device to reboot
    Type: fastboot flash zip firmware.zip and wait for process to complete
    Sometimes flashing for the first time doesn't work, so flash firmware.zip again just to make sure.
    Type: fastboot flash zip firmware.zip and wait for process to complete
    Type: fastboot reboot
    Unlock your bootloader and flash custom recovery if you are going to use custom ROM.
  3. clsA

    clsA Well-Known Member

    Mjr465 likes this.
  4. Mjr465

    Mjr465 Member

  5. clsA

    clsA Well-Known Member

    Mjr465 likes this.
  6. Mjr465

    Mjr465 Member

  7. scotty85

    scotty85 Guides Guide

    you dont actually need to do the whole process and s off if you do not want to.

    the guide clsa linked directs you first to this thread to lower your main version: http://forum.xda-developers.com/showthread.php?t=2390821

    since both 1.29 and 1.31 have hboot 1.44,it will pass the hboot check,and allow the slightly older firmware to flash.

    you can verify that the adb command worked by entering fastboot getvar mainver in fastboot and it should return 1.29.651.10

    for the record,i would recomend to become s off,even if you want to run "flat out boring stock" :D

    next time you need to run an ruu,a newer hboot may prevent it. as was said,soff removes security checks so you can flash older firmware with no prollem.
    Mjr465 likes this.
  8. Mjr465

    Mjr465 Member

    Where in ADB do I run these commands, platform tools? Opeing the CMD window and getting device not found.

    I appreciate the HELP that ya'll are giving. Hopefully we can get this done.
  9. scotty85

    scotty85 Guides Guide

    from the thread,you need to be in recovery,but i dont see why it wouldnt work from the booted OS as well if your phone is booting and working.

    youll need to change to the directory that adb and fastboot live in. if you followed htcdev dirrections this may be a folder called "android" or if you installed the entire sdk it may be in "tools" or "platform tools".

    if you used another guide,it may be named something different.

    hopefully you did this manually and didnt use a tool that didnt set you up with workind directory containing adb and fastboot ;)
    Mjr465 likes this.
  10. Mjr465

    Mjr465 Member

  11. Mjr465

    Mjr465 Member

    How do I get the TWRP recovery flashed to the phone? I have the openrecovery-twrp- img When I try to boot into recovery, Im getting the red triangle, then it just boots up like nothing is going on.

    I know these are noob questions, :stupido: Im just trying to get everything back to normal. I know it can be fixed, but Ive been trying for the past 2 days trying to get it right.

    Patience is running real low :banghead:
  12. scotty85

    scotty85 Guides Guide

    The red triangle is the stock recovery. Make sure you have a sprint recovery image,your bootloader is unlocked,and fastboot flash the new recover like you did initially.

    Is the phone booting into a rooted OS?
    Mjr465 likes this.
  13. Mjr465

    Mjr465 Member

    The only recovery I see is the TWRP recovery. (on my computer) When I reboot the phone in recovery, I see the red triangle, then after a few starts as normal, Sprint splash screen then the HTC do not distribute screen, then its up and running.

    From reading on XDA the red triangle sounds like I have the Sprint recovery already installed. Does this sound correct?
  14. Mjr465

    Mjr465 Member

    Ok just flashed TWRP recovery back to the phone. To make everything match

    C:\Users\Owner\Downloads\Android\HTCOneRoot>fastboot devices
    FA348S905166 fastboot

    C:\Users\Owner\Downloads\Android\HTCOneRoot>fastboot flash recovery openrecover
    sending 'recovery' (7912 KB)...
    OKAY [ 1.164s]
    writing 'recovery'...
    OKAY [ 0.742s]
    finished. total time: 1.908s

    Rebooted into recovery, TWRP started. Trying to run commands in SDK (adb shell
    echo "1.29.651.10" | dd of=/dev/block/mmcblk0p19 bs=1 seek=160
    adb reboot bootloader
    fastboot oem lock)

    couldnt get past abd shell got this:

    130917\sdk\platform-tools>adb shell
    adb server is out of date. killing...
    * daemon started successfully *
    ~ # ←[6n

    Now what? The next step is?
  15. Mjr465

    Mjr465 Member

    Where do I run these?

    adb shell
    echo "1.29.651.10" | dd of=/dev/block/mmcblk0p19 bs=1 seek=160
    adb reboot bootloader
    fastboot oem lock

    In SDK? What folder? In HTCONERoot? What folder? (the tutorial I used)
  16. Mjr465

    Mjr465 Member

    After many hours of Googling the HTC ONE, I "think" WE have finally figured it out.

    Was reading XDA, Android Forums and others plus a little bit of YouTube.

    Im getting updates as I type, lets see where this is gonna go....

    Thanks to scotty85, clsA and bigdaddy619. If there are any more issues, trust me I will be back!

    Also thanks for nobody snapping, at me about the info that I did not have! I was lost also!
    clsA and scotty85 like this.
  17. scotty85

    scotty85 Guides Guide

    glad you got is sorted! :smokingsomb: sorry for the late anwers,i was sleeping :eek:

    just to clarify a couple of things... when i said "sprint recovery" i did not mean a stock sprint recovery,i meand a twrp recovery that is for the sprint variant,as you cannot use a twrp intended for vzw or for gsm.

    the adb commands can be done with the phone twrp recovery,or in the booted OS.

    you need to have cd:\ed to the folder that specifically contains your adb utility.

    i gather you finally figured out what folder to use,and succesfully used the commands to lower your main version and ran the ruu?
  18. Mjr465

    Mjr465 Member

    HELL I havent slept for about 36hrs, :dontknow: since Ive had this issue, but, Im DL 4.3 now hopefully it takes.

    If not Ill be baaaack! But I definitely appreciate you helping me fix this issue!!! :congrats: :rock:

Share This Page