SSL Error on any HTTPS Site on Any browser


Last Updated: 2014-06-06 01:45:40
  1. TomEnns

    TomEnns New Member

    Hello,

    So I have a Galaxy Nexus running Cyanogen 4.2 and I cannot connect to ANY https sites. All I get is an SSL connection error.


    I have tried 7 different browsers, I have uninstalled all antivirus ad-blocker and other programs which might reroute web traffic and I have checked all proxy connection settings. I have also made sure the time on my phone is correct and I have checked everything I can think of.


    PLEASE help me!!! ANYTHING at all any suggestions anything would be awesome!

    Advertisement
  2. BRAINZ2013

    BRAINZ2013 Well-Known Member Contributor

    Hello and welcome to the forums . I am having the same issue but I am on kk . u may want to check your carrier signal cause it may need refreshing or update custom ROM . what area are u from
    mikedt likes this.
  3. mikedt

    mikedt 你好 Guide

    The date being wrong is probably the most common cause of SSL errors and unable to connect to HTTPS sites.

    If you've loaded a custom ROM like CM then it's quite likely the date will be wrong, unless you've set it yourself or have turned on "automatic date & time" in the settings. The default is off. You say you've checked the time, double check the date, especially the year and month.
    BRAINZ2013 likes this.
  4. BRAINZ2013

    BRAINZ2013 Well-Known Member Contributor

    Yes the date makes it a long day and real time is needed for every android to receive updates
  5. nickdalzell

    nickdalzell Well-Known Member Contributor

    i have to use a mobile device at home because HTTPS won't work. i can use any other site (including this one) perfectly fine but all HTTPS sites either lag during load or outright go to 'webpage not available' or the 'that's an error' (Desktop Google Chrome)

    there seems to be zero method to disable HTTPS redirects, even typing the URL like 'http://facebook.com' goes to 'https://www.facebook.com'. infuriating.

    like usual, any site online that has people asking how to disable it often ends with either no response at all, or a stupid 'you shouldn't do that. secure sites exist for a reason'
  6. mikedt

    mikedt 你好 Guide

    Are you going through a proxy or something, because they can sometimes give trouble with SSL.

    FB had to go HTTPS because there was a Firefox plugin that allowed you to snarf other people's login cookies, and so you could see everyone's personal stuff when using open WiFi or hotel networks. Of course you could post things on their accounts, or do anything you liked. I remember doing it at a hotel in Hong Kong, didn't do anything malicious though, was just looking.

    FB likely forces HTTPS only, in case you do get your account compromised from when using open WiFi or other shared networks, like hotel rooms. Same thing for Google, etc.
  7. nickdalzell

    nickdalzell Well-Known Member Contributor

    when i used my WISP and now my 4G Hotspot i cannot go to Https sites at all. i often have to put in the nored tag or use mobile view. m.facebook.com or the app itself avoids the problem. i am not using any proxy or vpn. this whole https was forced on us and the only workaround is avoiding any site using it. never a problem until then.

    come to think of it, perhaps that is why Play Store never worked for me, because of https or ssl.
  8. mikedt

    mikedt 你好 Guide

    HTTPS is forced likely because too many people were losing their Facebook, Google, bank accounts, etc. The alternative to using HTTPS on open WiFi and other insecure networks is to use a VPN, otherwise you're quite likely to get hacked(pwned). Same with most hotel room Ethernet, you can "sniff" everything. iTunes was always a good one, because you could often see and play other people's music libraries with it...LOL

    Anyway this is OT to the OP.

Share This Page