Steps for Installing ClockWorkMod(CWM) Recovery

Last Updated:

  1. shivakiran

    shivakiran Well-Known Member

    First of all Install usb drivers provided and download nvflash.rar tool for flashing
    Here's the link
    Google Translate

    and extract it in C:\ driver in ur computer

    Step 1: switch off the phone, hold down the vol + and power to the phone boot up the green screen (AP mode) and Remove ur Fingers off the Button :p
    Step 2: connect your phone to your computer with USB cable.
    Step 3:(those who have not installed the new driver to do this step, then also omitted): open control panel -> device manager, find APX devices among devices are connected, right click on it then select update device drivers, select the driver in C: nvflashusbpcdriver
    then wait for the installation process is complete.
    Step 4:click Start -> run, type CMD in ur Computer

    Important Step
    The Recovery.img in nvflash folder in CWM v5.0.2.0 which works both in 2.2 and 2.3 ROM's and if u want CWM v5.0.2.7 i ll provide u dat bt works only in 2.3 ROM(Not 2.2 ROM)

    Step 5:In the CMD type cd.. press enter and cd.. press enter and next type cd nvflash
    Step 6:Type nvflash --bl bootloader.bin --download 5 recovery.img (Exactly the same) and Press Enter and Dats it Done

    When flash complete, disconnect, remove the battery and then insert it, hold vol + and power until the screen appears red, then quickly drop 2 fingers hold out, we will see the phone boot up the screen has the following inscription:
    -Reboot system now
    -Apply update from sdcard
    -Wipe data / factory reset
    -Wipe cache partition
    -Install zip from sdcard
    -Backup and restore
    -Mounts and storage
    -Power off
    Dont Forget to say ThanXXXX

  2. applicationz

    applicationz Well-Known Member

    rhis does not worked when i checked it says failed execute command 14 nverror
    maybe i already have same recovery installed anyone check this out if they have stock recovery and say thankzzzz to shivakiran
  3. andlotus

    andlotus New Member

    i have same error with you, currently installed chinese touch version and i want to back to english version.
  4. shivakiran

    shivakiran Well-Known Member

    Which os r u using??? i think it works in windows xp only(i guess)
  5. aquaandro

    aquaandro Well-Known Member

    I did this... the command worked... but its showing the same options

    -Reboot system now
    -Apply update from sdcard
    -Wipe data / factory reset
    -Wipe cache partition

    Does it needs to be rooted first...?
  6. shivakiran

    shivakiran Well-Known Member

    Dude is der any recovery.img file in nvflash folder in c drive ?? and which rom r u using?? n repeat the procedure 1ce again n reply me
  7. kartikoli

    kartikoli Well-Known Member

    Is there any easy way around like rom manager app etc.....

    i will buy this phone today
  8. pri88yank

    pri88yank Member

    I also got the same error.....did u solve the issue?
  9. kartikoli

    kartikoli Well-Known Member

    is this a reversible process ... can i uninstall recovery after reverting back to stock rom

    please reply
  10. shivakiran

    shivakiran Well-Known Member

    ys u can reverse it by installing stock rom 2.2 or appy rom v2023 using nvmultidown
  11. kartikoli

    kartikoli Well-Known Member

    installed recovery successfully and installed custom rom bu there was a problem so restored the backup [2.2 original]
    now how do i remove this recovery from the phone as i am getting few hardware issue
  12. shivakiran

    shivakiran Well-Known Member

    Dude by installing stock rom u hav removed the cwm recovery
  13. kartikoli

    kartikoli Well-Known Member

    but i can see those added options

    -Reboot system now
    -Apply update from sdcard
    -Wipe data / factory reset
    -Wipe cache partition
    -Install zip from sdcard
    -Backup and restore
    -Mounts and storage
    -Power off
  14. shivakiran

    shivakiran Well-Known Member

    ok install noversion 2 then through dis recovery
  15. pri88yank

    pri88yank Member

    Does this recovery works with 2.3 gingerbread from k-touch/Igyaan or is it specifically for MMX 2.2 ROM. If it is so is there any way to customize this recovery for working with 2.3. I personally tried to nvfash this recovery.img to Igyaan ROM but failed but when i tried with 2.2 MMX it worked........Plz reply
  16. kartikoli

    kartikoli Well-Known Member

    didnt worked for me as well
  17. zeus_hunt

    zeus_hunt Active Member

    I had a difficult time with the translation Page..
    Hence pasting the actual Link Below


    This method has not worked for me..

    Under flash.cfg

    For igyaan 2.3.4

    For Stock MMX
  18. shivakiran

    shivakiran Well-Known Member

    wats the error u got???
  19. zeus_hunt

    zeus_hunt Active Member

    "Preparing to Download" and nothing will happen..
  20. pri88yank

    pri88yank Member

    You can try this trick.....
    Download the latest "noversion2" ROM. And there will be a recovery.img in that ROM. Trying installing that recovery.img onto Igyaan/Cheery ROM by replacing the original recovery.img and nvflashing it.
  21. shivakiran

    shivakiran Well-Known Member

    which os r u using????
  22. shivakiran

    shivakiran Well-Known Member

    try flashing appy rom v2023 via nvmultidown n the install noversion2
  23. surendranc

    surendranc New Member

    can you provide me with CWM v5.0.2.7, i am using 2.3
  24. micromaxa

    micromaxa Member

    C:\nvflash>nvflash --bl bootloader.bin --download 5 recovery.img
    Nvflash started
    rcm version 0X20001
    System Information:
    chip name: unknown
    chip id: 0x20 major: 1 minor: 3
    chip sku: 0xf
    chip uid: 0x033c11c7413fe2d7
    macrovision: disabled
    hdcp: enabled
    sbk burned: false
    dk burned: false
    boot device: emmc
    operating mode: 3
    device config strap: 0
    device config fuse: 0
    sdram config strap: 0

    downloading bootloader -- load address: 0x108000 entry point: 0x108000
    sending file: bootloader.bin
    \ 6914360/6914360 bytes sent
    bootloader.bin sent successfully
    waiting for bootloader to initialize
    bootloader downloaded successfully
    failed executing command 14 NvError 0x120000
    command failure: partition download failed
  25. nikhilrana1818

    nikhilrana1818 New Member

    the nvmultidown is giving me some kind of error when i plug in the cable i have installed the drivers correctly :(

Share This Page