Root Stock 2.1 to Fully Rooted Froyo 2.2

Discussion in 'Android Devices' started by Heathsrow, Aug 29, 2010.

  1. Ridley

    Ridley Active Member
    16

    Aug 11, 2010
    33
    1
    16
    Pittsburgh, PA
    I'm using Windows 7 and the CMD prompt keeps saying "Unknown command" and things of that sort. I see no indication that my phone is actually mounted through /system when I set the option in Clockwork Mod.
     

    Advertisement
  2. Heathsrow

    Heathsrow Well-Known Member
    18

    Apr 8, 2010
    67
    19
    18
    Gainesville, VA
    I am using Windows Vista, so I can be of no help. Sorry
     
  3. nbladen

    nbladen Member
    16

    May 3, 2010
    10
    1
    16
    Pharmacy Student
    Indiana
    Hey guys, I'm on step 5 and I'm having trouble with the RUU.exe file finding the phone. Every time I sync the phone with HTC sync, it says it is connected until I open the .exe file to update to 2.2 then it disconnects and the RUU program says it cannot detect the phone...any help?

    P.S. I'm on Windows 7 and I was able to start the update, until the computer said it needed to restart to update the bootloader...now I'm having the problem.
     
  4. Heathsrow

    Heathsrow Well-Known Member
    18

    Apr 8, 2010
    67
    19
    18
    Gainesville, VA
    I am using Windows Vista and had a similar experience with the HTC Sync not staying connected, What I did was get the RUU ready to go and then connected my phone, made sure USB Debugging was turned on and then started the RUU. Everything worked after that. It took a couple of minutes and then it was done. My computer never asked to restart, I am not sure if this is something with Windows 7...any one else use Windows 7 to apply the RUU that can help out nbladen????
     
  5. ronix

    ronix Member
    6

    Jul 22, 2010
    8
    1
    6
    Any reason as to in step 3 that I would install the unrevoked-forever.zip several times and still not achieve s-off status? I cannot get s-off. I have root I am sure as I have the little superuser ninja in the app drawer and when I go into recovery and apply the .zip i do not receive errors.

    Help would be appreciated. Thank You
     
  6. Heathsrow

    Heathsrow Well-Known Member
    18

    Apr 8, 2010
    67
    19
    18
    Gainesville, VA

    Double Check your SD Card to make sure it is FAT 32 and then I would suggest redownloading the Forever File and trying it again. Mine took on the first attempt.
     
    ronix likes this.
  7. k.electron

    k.electron Well-Known Member
    38

    Apr 12, 2010
    114
    18
    38
    Burlington, MA
    hey pm me an im handle and i'll take u through this.

    ok so first let htc sync detect your phone. then run the RUU. the phone will go to a screen where its all black with silver HTC, and then the RUU will give u an error. exit the RUU, but leave the phone connected as is. rerun the RUU. this time it will complete without issue. also, do this on the computer that u had to restart to update the bootloader.

    cheers
     
  8. dc006

    dc006 Active Member
    16

    Apr 2, 2010
    38
    3
    16
    I just followed this guide and got my phone running Froyo with root still. I am so excited. This post was exactly what I needed to figure it all out.

    Also, I followed the instructions on another post on how to make the RUU work with Windows 7 64-bit and it worked perfectly the first time.

    Much appreciated!
     
    Heathsrow likes this.
  9. dsb9938

    dsb9938 Well-Known Member
    53

    Jun 3, 2010
    216
    82
    53
    Datacenter Manager
    Edison, NJ
    I'm assuming since I have the OTA on my phone to flash with I can skip the Radio Update?
     
  10. Mischka7

    Mischka7 Well-Known Member
    38

    Apr 9, 2010
    217
    14
    38
    My SD card is not formatted to Fat 32. Is it possible to downgrade to 2.1 w/ S-Off, then do the OTA?

    Thanks!
    Mischka
     
  11. ronix

    ronix Member
    6

    Jul 22, 2010
    8
    1
    6
    Heathsrow Thank for the help, I finally figured out what was wrong. On my iMac it unzips the zip right away and you have to rezip, however if the zip file is touched the signature no longer works hard to to off the automatic unzip. Stupid.
     
  12. Heathsrow

    Heathsrow Well-Known Member
    18

    Apr 8, 2010
    67
    19
    18
    Gainesville, VA

    Glad you got it working. I am not familar with MACs. Welcome to your phone Forever!!
     
  13. Heathsrow

    Heathsrow Well-Known Member
    18

    Apr 8, 2010
    67
    19
    18
    Gainesville, VA

    The RUU updated my radio. I am not sure about the OTA, but it should also update the Radio as well. Although I am not sure about it, as I did the RUU and not the OTA.
     
  14. billybob275

    billybob275 Well-Known Member
    36

    Mar 22, 2010
    131
    2
    36
    Worked perfectly! Thanks for this guide!
     
  15. worknman

    worknman Well-Known Member
    16

    Apr 13, 2010
    98
    9
    16
    Hi, I am already rooted with stock 2.1. Do I need to do step 1?
     
  16. Heathsrow

    Heathsrow Well-Known Member
    18

    Apr 8, 2010
    67
    19
    18
    Gainesville, VA
    If you are already rooted with clockworkmod, then no you don't have to.
     
  17. dsb9938

    dsb9938 Well-Known Member
    53

    Jun 3, 2010
    216
    82
    53
    Datacenter Manager
    Edison, NJ
    :D

    Okay, I manged to get the RUU installed, and it tore up my phone.

    I am back to 2.1p1, restoring the backup now.

    I would like to get the OTA zip file and just use that since it doesn't wipe everyything, but haven't found a link yet.

    Does anybody have one?

    PS - RUU really hated my forgetting to put the stock recovery back :D.

    Thanks.
     
  18. Heathsrow

    Heathsrow Well-Known Member
    18

    Apr 8, 2010
    67
    19
    18
    Gainesville, VA
    Sorry to hear that. Here is the link to the OTA update over at XDA. http://androidforums.com/incredible...2-1-fully-rooted-froyo-2-2-a.html#post1484612 Although based on what they are saying you will still need to be completely stock everything for it to work. So either way you will need the Stock Recovery to do it.
     
    dsb9938 likes this.
  19. dsb9938

    dsb9938 Well-Known Member
    53

    Jun 3, 2010
    216
    82
    53
    Datacenter Manager
    Edison, NJ

    Oh I know, but after all the "stuff" I went through today, it's just easier not to have to reinstall the apps.

    Thanks for the link.
     
  20. dsb9938

    dsb9938 Well-Known Member
    53

    Jun 3, 2010
    216
    82
    53
    Datacenter Manager
    Edison, NJ
    Um, that link point to this thread I think.
     
  21. Heathsrow

    Heathsrow Well-Known Member
    18

    Apr 8, 2010
    67
    19
    18
    Gainesville, VA
    No Problem...Good Luck!!!
     
  22. dsb9938

    dsb9938 Well-Known Member
    53

    Jun 3, 2010
    216
    82
    53
    Datacenter Manager
    Edison, NJ
    Okay, I had the update in my restore.

    Finally, a piece of good luck today.

    :p
     
  23. chevy2dr56

    chevy2dr56 Member
    16

    Apr 6, 2010
    10
    2
    16
     
    Heathsrow likes this.
  24. Yaksha

    Yaksha Well-Known Member
    38

    Apr 15, 2010
    151
    12
    38
    I've already rooted my phone, but not with the unrevoked method, I rooted it before that came out when it. Do I have to do anything else, or do I start at step 1 even though I am already rooted? Will anything weird happen if I try and root my already rooted phone? I don't have clockworkmod, just Superuser.
     
  25. lpeckazca

    lpeckazca New Member
    5

    May 10, 2010
    2
    0
    5
    Awesome guide, worked like a charm. I would add (for those that don't know, I didn't) that you need to load HTC Sync on the computer to run the RUU, and the best place to find it is on the DINC itself!
     

Share This Page

Loading...