Stock Android 4.0.3 ICS for Fusion 2


  1. Brumore

    Brumore Member

    Stock Android 4.0.3 ICS for Fusion 2

    Install the Huawei stock version of ICS 4.0.3 (Bloatware removed) on your Fusion 2.

    Instructions:

    1. Download Stock_Android_4.0.3_ICS.zip - Stock_Android_4.0.3_ICS.zip - Solidfiles

    2. Extract zip and copy all files to microSD Card.

    3. Boot to ClockworkMod Recovery.

    4. Wipe data/factory reset, wipe cache partition, and advanced/wipe dalvik cache.

    5. Install from zip: ICS-Baseband-B952.

    6. Install from zip: "3G-Modem-LA" or "3G-Modem-AU" to restore 3G Networks.

    7. Restore from backup: Android_4.0.3.

    8. Reboot system.

    Images:

    [​IMG][​IMG][​IMG][​IMG][​IMG]

    Advertisement
  2. Radiance

    Radiance Well-Known Member Contributor

    To sacrifice butter or not to? That is the question. :egg:
  3. ZeRoseDev

    ZeRoseDev Well-Known Member

    Good post. It should be a bit more clear that step 6:

    Is only a partial fix, and does NOT restore 3G completely; Unless you've found a total fix?

    Thanks for the post.
  4. Brumore

    Brumore Member

    What do you mean?

    Please explain further, I require more detailed info to troubleshoot your problem?
  5. ZeRoseDev

    ZeRoseDev Well-Known Member

    We have a Jellybean ROM(CyanogenMod 10) that runs smoother than ICS. Posted at Fusion2.org

    We also have the baseband fix you're speaking of here, and have had several people flash it.

    Only partial 3G has returned; they do not get 3G in all the places they had gotten it previously.

    So this only a partial fix, and 3G is not completely restored.


    This information should be available to them, before they flash the ICS baseband.
  6. Brumore

    Brumore Member

    Why not post CyanogenMod 10 for Fusion 2 on this forum? And are you knocking down another’s contribution, ye is not humble?

    Mobile telecommunications coverage varies based on location. You can try updating the apns-conf.xml.
  7. ZeRoseDev

    ZeRoseDev Well-Known Member

    I wouldn't do that. I was just explaining why Radiance said:


    Cool I will check it out. Thank you.


    I just did. We had a bit of trouble, and I spent the last few days getting the guides back up on the other site.



    -I didn't mean to come off as rude. Forgive me if it seemed like that.
    :)
  8. Radiance

    Radiance Well-Known Member Contributor

    Didn't seem to work. But hey, don't worry! The FM works again and I'm really happy with this version of it. The app looks MUCH nicer!
  9. Radiance

    Radiance Well-Known Member Contributor

    Additional removable bloat:

    Browser.apk
    Calculator.apk
    DeskClock.apk
    Email.apk
    FrenchPack.apk
    GMS_Maps.apk
    GermanPack.apk
    HwBeyondTheSkyTheme_Small.apk
    HwDawnTheme_small.apk
    ItalianPack.apk
    LiveWallpapers.apk
    MediaCenter.apk
    NotePad.apk
    Protips.apk
    SetupWizard.apk
    SpanishPack.apk
    Street.apk

    EDIT: You can also take out the 2D Unlock (PotterUnlock.apk) and get the pure ICS lock screen.

    EDIT 2: You can remove the CD drivers by going into recovery, mounting /system and then going into shell and typing these commands:

    [HIGH]cd system
    rm -r cdrom[/HIGH]
    Brumore likes this.
  10. Brumore

    Brumore Member

    Good to know. Thank you.
  11. Radiance

    Radiance Well-Known Member Contributor

    No problem. This is so much smoother than that other ICS ROM, so thanks a LOT! Been using it all day and still have 94% battery too!
  12. Radiance

    Radiance Well-Known Member Contributor

    P.S: Good idea to format the cache partition after you've set up. I had a few problems with Snapseed and Umano freezing until I did that.
  13. teddyracer1

    teddyracer1 Active Member

    ok i need some help, all the steps 1-6 went thru ok, but step 7 : Restore from backup: Android_4.0.3. that one when i try and install, it says no files found, also my phone just boots up with the cyanogenmod in german. does anyone know what i messed up on? did i not copy the ICS Rom file onto the sd card correctly?
  14. ZeRoseDev

    ZeRoseDev Well-Known Member

    Did you place the backup file in /clockworkmod/backup/ ?
  15. teddyracer1

    teddyracer1 Active Member

    do I have to manually put that backup file in the right directory, e.g. when I do backup restore at CWM, or should that file should be already in there when I unzip the file (I looked on my comp and there's files in the Android_4.0.3 ) but when I tried to do it in CWM it says the file is empty. Should I try to put it on the SD card again?
  16. ZeRoseDev

    ZeRoseDev Well-Known Member

    Sorry for my previous post, I had not downloaded the file yet.

    I downloaded the file, and saw that the file was already placed in the clockworkmod folder, so I'm not sure why you're not able to use the file to restore the ICS backup.

    As for it being in German, Android should auto-detect your language, and switch the language to that.


    You should indeed try to put the files on the SD card again, maybe something went wrong when it was copying the files.
  17. totalundone

    totalundone Member

    Nice, another rom! Thanks! I need to think about it (my 3G is already pretty limited since I have to use refarmed T-Mobile 3G towers).

    The other ICS rom is a CM9 rom. Is this a port of the Huawei ICS rom? What was the base phone this was ported from?

    While a minimal installation would be nice, I think keeping the basics is more beneficial. Some people may need email.apk (I know I do!) and some of the others. It's easy enough to delete uneeded apks.
  18. Brumore

    Brumore Member

    You're welcome. This is not a port. It is the Huawei stock version of ICS 4.0.3 from the Ascend Y201 Pro.

    Although some of the bloatware was removed, apps such as email, file manager, fm radio, etc. (Images in first post) remain and may be uninstalled at the user’s discretion.
  19. Radiance

    Radiance Well-Known Member Contributor

    I always delete APKs as I'd rather have fresh ones from the market. I'm just weird like that. I also use alternatives to everything. Removing the stuff that isn't used seems to help a lot with RAM issues too.

    As for the ROM itself, it's great. Very stable.
  20. teddyracer1

    teddyracer1 Active Member


    I tried opening the file when the phone is plugged in USB storage mode and I verified the file is on the SD card, but when it goes in the CWM, the files don't appear.

    Anyone got any ideas?
  21. Radiance

    Radiance Well-Known Member Contributor

    Needs to be on the SD card and not internal.
  22. cameron581

    cameron581 Well-Known Member

    I recomend editing the build prop for device name for ours aka u8665
  23. cameron581

    cameron581 Well-Known Member

  24. teddyracer1

    teddyracer1 Active Member

    yeah i made sure it was.


    can u be more specific, is this is in CWM or in the user settings?
  25. ZeRoseDev

    ZeRoseDev Well-Known Member

    I was having issues with my SD card, so I didn't get a chance to put this on my phone.

    Finally got another SD and was able to restore this backup, and I must say, it is AWESOME!

    Really stellar job!

    --on a side note, if you want a sweet keyboard, with this version of android, you can sign up to test Fleksy, and the keyboard is equally as awesome.


    Thanks again, I love this one. :D

Share This Page