Stock TMO [T959UVJFD] Flashing


  1. Killing Hours

    Killing Hours Member

    I take absolutely no credit for this.

    After jacking up my vibrant... I needed to flash back to "out of the box" status. After hunting around a bit I came across this and SUCCESSFULLY flashed my phone back.

    I'm passing this on for the people who are new to flashing with this particular phone and don't know where to start etc.

    [ROM] OFFICIAL T-Mo Vibrant JFD ODIN/Nandroid Backup Images 7/29/10 (Tested/Working) - xda-developers

    A couple of things I noticed while flashing mine.

    First... getting to download mode was giving me crap at first. Then i found this tip on page 21 @ post 206:

    This worked for me.

    Also, after getting everything setup right and working.... I noticed that Odin didn't seem to be doing anything... to which I found this reply on page 20 @ post 198:

    This also worked for me. My phone didn't flash until the second time around. I also restarted my pc and made sure to be using the files provided in the first post for good measure. (Odin, the .tar & pit)

    ----------------

    As for the "NAN" backup.... I'm not that advanced yet and don't pretend to know anything about it. Hopefully this will help other people who have messed up get back on track.

    ----------------

    Edit*

    Mods, not sure if this is the correct or best section for this... but I figured if the phone is that messed up... it's probably due to actually messing around with the root files etc and deserves to be here in this sub forum.

    Advertisement
    :
    elchingon666 and smutek like this.
  2. adm1jtg

    adm1jtg New Member

    This past post saved me. I had ended up with the phone and pc screen and couldn't get out of it. Had I not found this post I would have had to swap the phone.

    GREAT WORK and thank you so much. I now have figured out how to use odin and nandroid backups, how to root the phone and how to remove bloat all from these forums.

    You guys are great
  3. Killing Hours

    Killing Hours Member

    glad to hear it!! You're the whole reason I re-posted this here and hunted down the tips so they could all be on one post here.

    I was sweating bullets a few times during this whole adventure in learningville but all in all it wasn't bad at all once I had somewhere to start. I had removed gtalk from the phone not knowing it was tied to the market was my reason for going through this, but it's great knowledge to know because I will def. be messing around with this pup. ;-)
  4. BossDj

    BossDj Well-Known Member

    i could use some help, i'm at the point i'm ready to flash a stock rom via ODIN, i have download mode, all my files, and what i thought were the right drivers installed, however, my pc won't recognize my phone in dl mode, and therefore odin sees nothing. my pc sees the phone, but doesn't have the right drivers apparently to start it. any tips on the right drivers to load would be greatly appreciated.
  5. djquick

    djquick Well-Known Member


    Let me Google that for you:

    [Drivers] MS Windows x86 and x64 USB Drivers for Samsung Galaxy S - xda-developers
  6. BossDj

    BossDj Well-Known Member

    yeah thanks quick, i saw your post in another thread, in fact had a laugh over the "let me google that for you" link and bookmarked it, like it. problem is, those are the exact drivers i have downloaded....

    and have uninstalled, removed all traces of, rebooted, reinstalled, rebooted again just to be safe, and still windows will not start my device in dl mode. feeling stuck
  7. BossDj

    BossDj Well-Known Member

    crisis averted, pending....

    so i found a thread late last night on xda where a few were posting that the drivers djquick so lovingly posted for me (while pointing and laughing no doubt) (joking quick, i'd be doing the same thing) have a known problem with starting the device in dl mode on a Win7 system. Exactly my environment.

    So this morning at work, on my XP box, loaded the drivers, booted to dl mode, and there she is, ODIN seeing her on Com3, and stock flash is running.

    (crosses fingers)
  8. BossDj

    BossDj Well-Known Member

    fingers uncrossed, crisis averted, my thanks to all that gave up their hard earned helpful info on all these threads
  9. djquick

    djquick Well-Known Member

    Glad to be of assistance
  10. Android Amateur

    Android Amateur Well-Known Member

    This thread helped me get back to Stock. I rooted my phone and got trigger happy and deleted pretty much ALL the bloatware off my phone. I later found that was a big mistake when I installed a lag fix from a guy on YouTube. I got the stock firmware flashed back to my Vibrant and it's back to normal now! THANK GOD! I would have NEVER heard the end of it from my wife.

    THANK YOU!
  11. djquick

    djquick Well-Known Member

    LMAO, I know the feeling:D
  12. aeok18109

    aeok18109 Active Member

    Will this bring back avatar. I deleted it by accident.
  13. w_bovine

    w_bovine Well-Known Member

    Avatar is stored on the external SD card. If you accidentally deleted it, I'm afraid you're out of luck. As for me, I deleted on purpose. :D
    aeok18109 likes this.
  14. aeok18109

    aeok18109 Active Member

    Thank you for clearing that up.
  15. pacothebandit

    pacothebandit Well-Known Member

    soooi have followed all the steps when i hit start. it said any <ID:0/006> File analysis..

    and then nothing happens.


    Uh oh...is it because im on a Win 7 computer?
  16. pacothebandit

    pacothebandit Well-Known Member

    UGH still not working for me. is there anyone that can help me out?? :D
  17. BossDj

    BossDj Well-Known Member

    I couldn't flash on a win7 machine, worked like a charm on xp.
  18. pacothebandit

    pacothebandit Well-Known Member


    My XP so far can not find the drivers, do i have to download them?
  19. SamsungVibrant

    SamsungVibrant Well-Known Member

    But you also probably backed up a copy, right? :D
  20. pacothebandit

    pacothebandit Well-Known Member


    Ok so now the drivers are installed on my XP machine. When i use ODIN is shows Com 14 and Com 3 I load my files proper and again...nothing is happening
  21. djquick

    djquick Well-Known Member

    I flashed my Behold II's and my Vibrants on Windows 7 ultimate without a hitch.
  22. pacothebandit

    pacothebandit Well-Known Member


    Well now im really screwed. In my frustration i was holding the volume buttons and power and now i see a Phone ! computer icon. and I cannot get out of it.....someone tell me what to do cause i am out of options.
  23. pacothebandit

    pacothebandit Well-Known Member

    hehe warranty exchange on the way...
  24. bcook75

    bcook75 New Member

    I have finally crawled my way to the point that ODIN appears to recognize my Vibrant, on COM4. After I select the PIT and TAR and click Start, it pretty quickly gets to the "<ID:0/004> File Analysis..." step, but I don't see any progress bars or other indications that anything is actually going on. This is my 3rd or 4th attempt to install the stock flash. How long should I expect the File Analysis step to take before some other activity becomes apparent? I have waited up to about 10 minutes so far before closing ODIN and starting over.
  25. umiar

    umiar New Member

    <ID:0/013> Added!!
    <ID:0/013> Odin v.3 engine (ID:13)..
    <ID:0/013> File analysis..
    <ID:0/013> Get PIT for mapping..
    <ID:0/013> Firmware update start..
    <ID:0/013> cache.rfs
    It freeze here befeore 30 min. what should i do now?
Loading...

Share This Page