Stop Firefox from playing MP3s


Last Updated:

  1. psycoking

    psycoking Member This Topic's Starter

    Joined:
    Feb 26, 2012
    Messages:
    10
    Likes Received:
    1
    I use Firefox Mobile to download podcasts onto my Samsung Galaxy SIII (Verizon). Usually, I just click on the link for the MP3 file and Firefox downloads it. A few days ago this behavior changed. Now when I click on a link to an MP3 file in Firefox, Firefox plays the MP3 in an internal player. I usually download podcasts ahead of time so that I can listen to them later during my commute home, so this behavior is very annoying.

    This seems to be a Firefox only problem, as the stock Android/TouchWiz browser is unaffected and still lets me download MP3s. Does anybody know how I can disable this functionality in Firefox?
     

    Advertisement
  2. aysiu

    aysiu Well-Known Member

    Joined:
    Mar 6, 2011
    Messages:
    955
    Likes Received:
    260
    I was frustrated by the same thing and had to use Dolphin to do it.
     
  3. hstroph

    hstroph Well-Known Member

    Joined:
    Oct 18, 2012
    Messages:
    611
    Likes Received:
    94
    I'm looking forward to using FF mobile when my Nexus 4 arrives, but in desktop FF: Edit -> Preferences -> Applications, column:"Content Type" is "MP3 Audio", column:"Action" select pull-down "Save File".

    As I say that's desktop FF, but it might hopefully steer you towards the Application Preferences in the mobile version.
     
  4. aysiu

    aysiu Well-Known Member

    Joined:
    Mar 6, 2011
    Messages:
    955
    Likes Received:
    260
    The preferences options in Android and desktop are different, unfortunately.
     

Share This Page

Loading...