stop message preview on swipe down notification bar?Support


Last Updated:

  1. chattygirl

    chattygirl Active Member This Topic's Starter

    Joined:
    May 17, 2010
    Messages:
    40
    Likes Received:
    2
    Id appreciate some help please...:)

    I'm using Whatsapp and love getting the notification icon in the top left hand corner of the screen. But is there anyway I can prevent the full message from being displayed when I swipe the notification bar down. I want to be notified I've received a message but I'd like the swipe down function disabled I guess......or no message preview??

    I can't see a way on stock....would another launcher allow me to do this?
    Many thanks in advance.
     

    Advertisement
  2. chattygirl

    chattygirl Active Member This Topic's Starter

    Joined:
    May 17, 2010
    Messages:
    40
    Likes Received:
    2
    Anyone.....please?
     
  3. DC1022

    DC1022 Well-Known Member

    Joined:
    Apr 21, 2011
    Messages:
    178
    Likes Received:
    12
    I haven't used Whatsapp before but I know other messaging apps like it have privacy settings that you can choose to show a preview of the message in the notification bar or you can turn it off. Maybe go through the settings a bit to see if you can find something like that.
     
  4. Robogar

    Robogar Active Member

    Joined:
    Jan 24, 2010
    Messages:
    37
    Likes Received:
    8
    Went though my Whatsapp v2.9.5196 settings and I'm pretty sure there's no such setting. I would'be expected it to be in the notification settings but nada....

    Also interesting to note that there's no privacy settings at all in the options.
     
  5. ooberandy

    ooberandy Well-Known Member

    Joined:
    Feb 15, 2010
    Messages:
    711
    Likes Received:
    77
    I've never known an app to have settings that limit the notification content :S

    The only options I've seen are to have notifications on or off
     
  6. czechplastik

    czechplastik Well-Known Member

    Joined:
    Apr 25, 2010
    Messages:
    335
    Likes Received:
    34
    Any reason other than privacy?
     
  7. MacFett

    MacFett Well-Known Member

    Joined:
    Mar 28, 2011
    Messages:
    3,236
    Likes Received:
    740
    Handcent has this exact option. Under settings -> notification settings -> notification settings you can check or uncheck privacy mode. Without privacy it shows there is a message and most of the message (depending on the length) with privacy enabled it just shows there is a message (may show from whom, I only used it once and did not like it).

    I have never used whatsapp so I do not know, but if you go to the play store page there should be a link to contact the dev or their website. If you get in touch with them they will know better if it is possible and if it isn't you could suggest it to them.
     
  8. dontpanicbobby

    dontpanicbobby Guides Guide

    Joined:
    Dec 31, 2011
    Messages:
    4,191
    Likes Received:
    1,890
  9. chattygirl

    chattygirl Active Member This Topic's Starter

    Joined:
    May 17, 2010
    Messages:
    40
    Likes Received:
    2
    Many thanks for your replies. I agree there are no settings within Whatsapp but yes I've emailed developer today so will wait and see in future maybe?

    I love the app as its free messaging and the whole family have it.....and yes its just a privacy preference for me lol....

    I've found a workaround by using pattern lock on lock screen. This then disables the swipedown to read the message.....but allowing the icon to remain in notification bar.

    Didn't particularly want to lock whole phone.....but this works for me at the mo.

    Many thanks again x
     
  10. Mon73

    Mon73 New Member

    Joined:
    Apr 29, 2013
    Messages:
    2
    Likes Received:
    2
    In Samsung Galaxy S4:

    In Settings:
    - choose the -More- tab
    - choose Application manager
    - choose Whatsapp
    - turn off -Show notifications-
     
  11. MacFett

    MacFett Well-Known Member

    Joined:
    Mar 28, 2011
    Messages:
    3,236
    Likes Received:
    740
    She wants the notification, just not what is contained in the message for privacy reasons. This will disable the entire notification.
     
  12. shazyy

    shazyy New Member

    Joined:
    May 1, 2013
    Messages:
    4
    Likes Received:
    0
    i have the same problem with notification on my samsung s2 whatsapp version2.9.5196
    help required
     
  13. shazyy

    shazyy New Member

    Joined:
    May 1, 2013
    Messages:
    4
    Likes Received:
    0

    i would be obliged if u share the solution to this problem with me as well coz even i am encountering this problem
    thanks in advance
     
  14. MacFett

    MacFett Well-Known Member

    Joined:
    Mar 28, 2011
    Messages:
    3,236
    Likes Received:
    740
    I would suggest emailing the dev and requesting the feature. It does not sound like the app can do what you are looking to so currently.
     
    shazyy likes this.
  15. ooberandy

    ooberandy Well-Known Member

    Joined:
    Feb 15, 2010
    Messages:
    711
    Likes Received:
    77
    Try reading the post, chattygirl has said her workaround.
     
  16. jackyarora

    jackyarora New Member

    Joined:
    Jun 2, 2013
    Messages:
    1
    Likes Received:
    0
    heyy chatty girl what did they replied..or they didnt bothered to reply..?
     
  17. chattygirl

    chattygirl Active Member This Topic's Starter

    Joined:
    May 17, 2010
    Messages:
    40
    Likes Received:
    2
    No reply from developers unfortunately....hey ho
     
  18. Blakes1164

    Blakes1164 New Member

    Joined:
    Oct 1, 2013
    Messages:
    1
    Likes Received:
    0
    To turn off the notifications in whatsapp on android goto the application manager, click on whatsapp ( this is the screen you would be at if you were to uninstall it ) there is a tick box here to turn off notifications
    Hope that helps :)
     
  19. MacFett

    MacFett Well-Known Member

    Joined:
    Mar 28, 2011
    Messages:
    3,236
    Likes Received:
    740
    The op only wanted to turn off message preview not the notification.
     

Share This Page

Loading...