Straight Talk APN settingsTips


Last Updated:

  1. TheBlueFox

    TheBlueFox Active Member

    Here are my Straight Talk settings for the AT&T sim. I've used these settings since day one, and they've been perfect so far. MMS has always worked, and I've had people text me at different times/locations to verify this (I'm OCD about everything working properly).

    I've seen that lots of people are confused about what settings to use or what combination works, and these settings work perfectly. HSPA+ is great and almost always have full signal, even where I live in rural Virginia.

    I'll attach a screen shot below of my latest speedtest.net testing. I usually average about 4.2 Mbps down and 1.2 Mbps up.

    *I also forgot to add that you don't have to have a separate MMS APN with these settings. You can use only one APN with these settings.

    Name:Straight Talk ATT (whatever you like)
    APN: att.mvno
    Proxy: Not set
    Port: Not set
    Username: Not set
    Password: Not set
    Server: Not set
    MMSC: http://mmsc.cingular.com
    MMS proxy: 66.209.11.33
    MMS port: 80
    MCC: 310
    MNC: 410
    Authentication type: Not set
    APN type: default,supl,mms,hipri (no spaces)
    APN protocol: IPv4
    APN roaming protocol: IPv4
    APN enable/disable: checked (grayed out)
    Bearer: Unspecified

    [​IMG]

    Advertisement
  2. Banished Angel

    Banished Angel Well-Known Member

    You could switch the APN protocol to IPv4/IPv6. It wouldn't hurt. Otherwise very similar settings to mine, minus the MMS proxy.
  3. mundane24

    mundane24 Well-Known Member

    How about for Straight Talk T-Mobile? any tips?
  4. hstroph

    hstroph Well-Known Member

  5. Dmowry

    Dmowry Active Member


    Couple of questions regarding your settings:
    1) What does setting/not setting the first port to 80 do or not do? Almost all other APN settings I've read or seen have this filled in.
    2) What does having hipri under APN type do? Never have seen this before!

    BTW- just set my APN to these settings and evening is working great do far. Thank you
  6. OhSeven

    OhSeven Well-Known Member Contributor

    I saw somewhere that hipri = high priority. I haven't noticed a difference, but then again I think I'm being throttled. If they're taking calls, hold time is >90 minutes. aintnobodygottimeforthat.jpg
    Dmowry likes this.
  7. TheBlueFox

    TheBlueFox Active Member

    1) I don't exactly remember. It seems like it had something to do with the Proxy, if used.

    2) Hipri = high priority. That may or may not make a difference. I added it to begin with because truthfully it couldn't hurt, ha-ha.

    I'm glad to hear everything is going well so far. My N4 has been flawless with these settings. :D
  8. aqualuv

    aqualuv New Member

    Blue Fox, are theses settings still working for you? I just got the att sim card and am waiting on an unlocked gsm phone I ordered from amazon.

Share This Page