Straight Talk super slow data speeds.

Discussion in 'Straight Talk' started by sounreal, Oct 3, 2012.

  1. sounreal

    sounreal Well-Known Member
    38

    Nov 18, 2011
    265
    14
    38
    Male
    Deckhand
    Belleville, IL
    I have a Motorola Atrix 2, I got a unlock code from eBay seller unlockliberty for $3.45 eBay My World - unlockliberty

    I also got the new BYOP package deal that Walmart sells in store. It includes 3 sim cards (1 at&t 1 T-Mobile and 1 micro at&t sim card) and a $45 card all for $59.99. Both At&t cards say that they are also for unlocked phones.

    I put activated the micro sim card. Well when I search for networks the only ones that come up are "Home" and "Roam" no at&t and T-Mobile. I never tested roam and my settings are correct yet my data is super slow. Text and calls work just fine. Any advice would be helpful.
     

    Advertisement
  2. oldnoob2

    oldnoob2 Well-Known Member
    18

    Jun 20, 2012
    76
    10
    18
    Miami, FL
    ST always shows Home as the network even though it's AT&T. The Atrix is an AT&T phone so you should get at least 3G. Make sure your APN settings are correct and in the network settings it shows HSPA preferred.

    If you ported the number over sometimes it takes a day or two for all the configuration changes in the system to take effect. Sometimes the port doesn't finish up like it should and you have to call them to check/refresh the data.
     
  3. sounreal

    sounreal Well-Known Member
    38

    Nov 18, 2011
    265
    14
    38
    Male
    Deckhand
    Belleville, IL
    This is what I did. And I did not port my number just to avoid problems.

    Create a new APN with the following values:
    APN Name: Straight Talk
    APN: att.mvno
    Proxy: proxy.mvno.tracfone.com
    Port: 80
    MMSC: http://mmsc.cingular.com
    MMS Proxy: 66.209.11.33
    MMS Port: 80

    Delete the current APN from your phone. Reboot your phone.

    After I signed up that's what the website said to do.
     
  4. UncleMike

    UncleMike Well-Known Member
    163

    Nov 15, 2009
    2,323
    482
    163
    Central NJ
    Recommendations on XDA are to leave Proxy and Port blank. It works for me. I believe the proxy merely allows them to filter your traffic, preventing the use of some apps or services.
     
  5. oldnoob2

    oldnoob2 Well-Known Member
    18

    Jun 20, 2012
    76
    10
    18
    Miami, FL
    What is the APN Type set to?
     
  6. sounreal

    sounreal Well-Known Member
    38

    Nov 18, 2011
    265
    14
    38
    Male
    Deckhand
    Belleville, IL
    right now its only "mms" but it has been settings that things that I found on the net. I have been testing everything. MMS works when it wants to.
     
  7. oldnoob2

    oldnoob2 Well-Known Member
    18

    Jun 20, 2012
    76
    10
    18
    Miami, FL
    Try setting it to default,suppl,mms Make sure you save, reboot, then verify it's still selected and the changes are intact.
     
  8. sounreal

    sounreal Well-Known Member
    38

    Nov 18, 2011
    265
    14
    38
    Male
    Deckhand
    Belleville, IL
    I already did tried just that combination. But I will try it again.
     
  9. oldnoob2

    oldnoob2 Well-Known Member
    18

    Jun 20, 2012
    76
    10
    18
    Miami, FL
    Sorry, my bad, only one p in supl. It should read default,mms,supl If you are still having the issue call the ST BYOD support number at 855-222-2355. Tell them the problem and ask them to check the account configuration and refresh the data.

    If the phone support people can't help, start a ticket on their Facebook page, or email ST.CorpResolutionTeam@straighttalk.com Either of those usually produces better results when the phone people can't get things worked out.
     

Share This Page

Loading...