Stuck in ABD listed but offline


Last Updated:

  1. ctemple

    ctemple Member This Topic's Starter

    Joined:
    Feb 18, 2013
    Messages:
    9
    Likes Received:
    2
    Not sure this is the right place to post, I'm a newbie, but here it goes anyway.

    I have a nexus 7 that I rooted with the Nexus toolkit and I made the fatal mistake of updating android to 4.2.2 and last night I noticed that I couldnt tx files through my USB drive anymore. So I went on the forum to do a bit of resaerch and installed root checker pro and it says that root access is not properly configured.

    Here is the report


    Root Access is not properly configured or was not granted.
    Super User Applications Status:
    Superuser application - is NOT installed!
    SuperSU application - version 1.04 - is installed!
    System File Properties for Root Access:
    Standard Location
    Check Command: ls -l /system/bin/su:
    Result: /system/bin/su: No such file or directory
    Analysis: File /system/bin/su does not exist.
    Standard Location
    Check Command: ls -l /system/xbin/su:
    Result: -rwxr-xr-x root shell 96144 2013-02-05 14:58 su
    Analysis: Setuid attribute NOT present BUT root user ownership is present. Root access is NOT correctly configured for this file!
    Alternative Location
    Check Command: ls -l /sbin/su:
    Result: /sbin/su: Permission denied
    Analysis: File system permissions restricted and denied access.
    Alternative Location
    Check Command: ls -l /system/xbin/sudo:
    Result: /system/xbin/sudo: No such file or directory
    Analysis: File /system/xbin/sudo does not exist.
    Root User ID and Group ID Status:
    SU binary not found or not operating properly
    System Environment PATH: /sbin /vendor/bin /system/sbin /system/bin /system/xbin
    ADB Shell Default User:
    ADB shell setting for standard access, stored in default.prop, is configured as: shell (non root) user - ro.secure=1

    I can see stickmount in SuperSU and when I try to moiunt manually it says busy. When I connect the drive it flashes and stickmount searches for the drive but comes back with an error message that card is not mounted or empty.

    I went back to the toolkit and it won't let me root becase I get stuck in "ADB is listed but offline".
    I tried all the steps recommended changed port, cable, verify that port 50.. is listening, rebooted device and computer, ticked and unticked usb debugging etc but no success.
    I'm stuck and don't know what to do next. I'm new to android, have had the tablet only for 3 months. I thought I was on top of it, but not.

    I shouldn't have updated, I did it with trepidation, I have to travel soon and I need the tablet to be able to read the external storage.

    Can anyone help please or redirect me to the right place?
     

    Advertisement
  2. racinmason001

    racinmason001 Well-Known Member

    Joined:
    Mar 7, 2012
    Messages:
    301
    Likes Received:
    30
    If you are using wugs toolkit you need to download the files to patch his tool. I had the same problem after updating to 4.2.2.
     
    ctemple likes this.
  3. ctemple

    ctemple Member This Topic's Starter

    Joined:
    Feb 18, 2013
    Messages:
    9
    Likes Received:
    2
    I went to the wug update but in the list of builds it doesn't mention android 4.2.2 and said to select any build instead so i did that. During the update a window came up saying this feature doesn't work with the build you have selected pls select another build or use boot(temporary) to boot button and a modified boot img of your choice. i'm not sure what it refers to.
     
  4. sdrawkcab25

    sdrawkcab25 Well-Known Member

    Joined:
    Aug 5, 2010
    Messages:
    5,577
    Likes Received:
    1,958
    You need the latest sdk files on your pc for it to work also... I know someone has been working on getting it together...I'll see if I can locate it.
     
    ctemple likes this.
  5. ctemple

    ctemple Member This Topic's Starter

    Joined:
    Feb 18, 2013
    Messages:
    9
    Likes Received:
    2
    It also says you are running an old twrp recovery release fir your build and it mentions two img files to select from. I also don't know what to do about that.
     
  6. sdrawkcab25

    sdrawkcab25 Well-Known Member

    Joined:
    Aug 5, 2010
    Messages:
    5,577
    Likes Received:
    1,958
    jmar and ctemple like this.
  7. palmtree5

    palmtree5 Sunny Vacation Supporter! Moderator

    Joined:
    May 2, 2012
    Messages:
    4,374
    Likes Received:
    2,849
    ctemple likes this.
  8. Rxpert83

    Rxpert83 Dr. Feelgood Moderator

    Joined:
    Aug 30, 2011
    Messages:
    17,892
    Likes Received:
    13,075
    Sounds like you just need to flash the SU files from a custom recovery.
     
  9. Jesus359

    Jesus359 Well-Known Member

    Joined:
    Nov 21, 2011
    Messages:
    57
    Likes Received:
    7
    I had this same problem, my quick fix is to flash everything again. On command prompt and flash twrp or cwm again. You need the SDK installed then in cm type fastboot flash recovery "name of recovery".img this will flash your recovery then you can just flash root with the recovery.
     
    ctemple likes this.
  10. sdrawkcab25

    sdrawkcab25 Well-Known Member

    Joined:
    Aug 5, 2010
    Messages:
    5,577
    Likes Received:
    1,958
    wug posted instructions on his site on how to patch the toolkit to work with 4.2.2 also

    Nexus Root Toolkit v1.6.2 | WugFresh

    you may also have to enable adb in your rom... by going to settings, "about phone" and tapping on the "build number" 7 times (you will be prompted that you are about to enable "developer options"). You will then see the developer options in your settings menu, where you can turn on USB debugging etc.
     
    ctemple likes this.
  11. ctemple

    ctemple Member This Topic's Starter

    Joined:
    Feb 18, 2013
    Messages:
    9
    Likes Received:
    2

    Yes I tried the instructions for the patch in the developer site and copied the new files to my wugs data, but it's still the same. I will try the min adb and investigate the enabling of the adb through settings. I think it;s a minor thing everything seems to be there just disabled.
     
  12. palmtree5

    palmtree5 Sunny Vacation Supporter! Moderator

    Joined:
    May 2, 2012
    Messages:
    4,374
    Likes Received:
    2,849
    Did you look at your device? You should see a prompt to confirm that you want to allow ADB access from the computer you're connected to
     
  13. ctemple

    ctemple Member This Topic's Starter

    Joined:
    Feb 18, 2013
    Messages:
    9
    Likes Received:
    2
    I will, debug is enabled have to check abd
     
  14. ctemple

    ctemple Member This Topic's Starter

    Joined:
    Feb 18, 2013
    Messages:
    9
    Likes Received:
    2
    jmar and sdrawkcab25 like this.
  15. bubbasd

    bubbasd Well-Known Member

    Joined:
    Jun 28, 2012
    Messages:
    119
    Likes Received:
    36
    Q. You may ask why ADB Device with 4.2.2 go offline trying to connect it?
    A. read here
    The Fix= Make sure got the newest Android Debug Bridge. (adb.exe version 1.0.31)
    --------------------------------------------------------------------------------

    Android SDK (new Rev 21.1)

    -Noticed Changes-
    Android Debug Bridge version 1.0.31
    Android SDK 21.1
    From Update SDK Platform Tools 16.0.1
    SDK included with Eclipse + ADT plugin.


    Dowload from Here
    adt-bundle-windows-x86 is about 405MB

    Downloads By The Android SDK Manager
    Android SDK Platform-Tools (platform-tools_r16.0.1-windows.zip) is about 11.3MB
    Google Usb Driver (usb_driver_r07-windows.zip) is about 8.27mb

    ----------------------------------------------------------------------------------

    Nexus Root Toolkit v1.6.3

    "All the latest Android builds and Nexus devices are now officially supported with full 4.2.2 support"


    Download From Here
    About 50.07 MB + whats needed from the program itself eg.boot images,recovery ect.
    ----------------------------------------------------------------------------------

    1 of the ADB's from these SDK or NRT 1.6.3 would definatly get around the offline problem and the "read here" at top of post would clear some confusion.

    Personaly i Like getting adb.exe, AdbWinUsbApi.dll and AdbWinApi.dll
    from \sdk\platform-tools and copying them into c:\windows\system32 folder
    so i can use adb from any folder.

    Hope thats helps;)
     
    jmar likes this.

Share This Page

Loading...