1. Hot New Devices! HTC One M9 | Samsung Galaxy S6 | LG G4

Stuck in boot-up screen.


  1. kloroformkandi

    kloroformkandi Active Member

    It's not doing anything when I click Begin unlock bootloader..
  2. doogald

    doogald Guides Guide

  3. doogald

    doogald Guides Guide

    I missed this part. I'll keep that in mind as we go forward. I have generally been assuming that you were powering down, though, (I think...)
  4. kloroformkandi

    kloroformkandi Active Member

    Nevermind I just used a different browser and it worked.
    I'm at step 9 now.
  5. kloroformkandi

    kloroformkandi Active Member

    When I copy the Token into the text and click submit, it gives me 404 error.
  6. doogald

    doogald Guides Guide

    I believe that the next step is that they email you a file and instructions, but I'd try again if you do not have an email from them yet.
    scotty85 likes this.
  7. scotty85

    scotty85 Guides Guide

    ive had that happen once or twice. the site is prolly just having some prollems,unless your internet has coincidently just crashed :eek:

    if you paste your unlock token onto a text document,or somewhere you can copy it again later,you can pick back up at that step when the site is working.

    sounds like your moving right along. doogald is doing a great job with the instructions but ill keep watching in case he becomes busy with his family activities so hopefully youll have as little down time as possible :)
    kloroformkandi likes this.
  8. kloroformkandi

    kloroformkandi Active Member

    I had to switch browsers again but I got it to work and received the email. :]
    I continue to follow it's instructions?
  9. scotty85

    scotty85 Guides Guide

    Yup. Once the bootloader is unlocked you can install a recovery. :)
  10. kloroformkandi

    kloroformkandi Active Member

    My command window is telling me 'waiting for device' after typing to unlock it.
    Do I have to redo any of these steps if I powered down?
  11. doogald

    doogald Guides Guide

    No on redo-ing steps - you have fastboot that works, you have the 1.51.0000 bootloader - these do not go away.

    Since I have never unlocked the bootloader on the 1.51.0000 method, I'm actually going to do so now, just so I know the steps, etc.
  12. scotty85

    scotty85 Guides Guide

    powering down shouldnt have any affect on the steps youve allready done. since you had everything working to get the identifier token,well assume its not a driver issue.

    -try a reboot of the PC
    -try different ports and usb cables
    -make sure your phone is in "fastboot" mode and not hboot
    -uninstall or stop htc sync,pda net,or any other program capable of comunicating with your phone.

    hopefully one of those will get you recognized again :)
  13. doogald

    doogald Guides Guide

    Ok, I just went through the process. (A bit of a pain on the Mac, as it turns out - you cannot copy a rectangular block of text as you can in the Windows CMD window - unless I am missing something - so I had to cut and paste into textedit, search and replace "INFO" with nothing, and then paste that back into the token window on the HTCDev web site.) Anyway, I now have an unlocked 1.51.0000 bootloader.

    When you successfully unlock it will restart the phone as if it was trying to start the phone normally, so, since you don't have a working system, you will probably still see the skating Droids. You can just pull battery at that point.


    It may be this - in order for the fastboot flash unlocktoken Unlock_code.bin command to work, you need the phone to be in fastboot mode again. So, start the phone in HBOOT by holding VolDn when you start the phone, then press "Send" when prompted to enter fastboot. You should see "FASTBOOT USB" in red if you have the cable connected. It won't hurt to run

    fastboot devices

    to make sure that the computer sees the phone from the CMD window. (That's what I did before I ran fastboot flash unlocktoken Unlock_code.bin). When you do finally run the command to unlock the bootloader, it will change to a graphical display - you can press VolUp to answer that, yes, you want to unlock the bootloader, then power to confirm. (Your phone will almost immediately restart, as I described above.)

    After you pull battery and replace it, you can start to HBOOT again (hold VolDn). It should say "*** UNLOCKED ***" with a pink background at the very top. If that's all set, we are ready for the next step.
    CapnO likes this.
  14. kloroformkandi

    kloroformkandi Active Member

    I forgot to go back into fastboot.
    It's unlocked now and ready for next step.:D
    You guys are so helpful. :]
  15. doogald

    doogald Guides Guide

    Ok, the next couple of steps say:

    So, to make this easier, and flesh it out a bit:

    [update: do not do this step!]- download this file PB00IMG-rescue-recovery.zip


    [update: do this instead] - download the attached file recovery.zip

    Copy that file into your c:\android folder

    Then, you are going to run a few commands that you have run before:

    - start the phone in HBOOT and put it in fastboot mode, with the phone cabled to the PC (I trust that this is old hat by now).

    - back at the CMD prompt, run these commands (you have done one of these before):

    fastboot oem rebootRUU

    fastboot flash zip PB00IMG-rescue-recovery.zip

    fastboot flash zip recovery.zip

    fastboot reboot

    Pull the battery and then restart the phone by holding VolUp.

    This should look much like this:

    Code (Text):
    1. C:\android>fastboot devices
    2. HTblahblah    fastboot
    3.  
    4. C:\Android>fastboot oem rebootRUU
    5. ...
    6. OKAY [  0.024s]
    7. finished. total time: 0.025s
    8.  
    9.  
    10. c:\Android>fastboot flash zip recovery.zip
    11.        sending 'zip' (2523 KB)... OKAY [  0.592s]
    12.                  writing 'zip'... INFOzip header checking
    13. INFOzip info parsing...
    14. INFOchecking model ID...
    15. INFOchecking custom ID...
    16. INFOchecking main version...
    17. INFOstart image[boot] unzipping & flushing...
    18. INFO[RUU]UZ,boot,0
    19. INFO[RUU]UZ,boot,42
    20. INFO[RUU]UZ,boot,94
    21. INFO[RUU]UZ,boot,100
    22. INFO[RUU]WP,boot,0
    23. INFO[RUU]WP,boot,40
    24. INFO[RUU]WP,boot,80
    25. INFO[RUU]WP,boot,100
    26. OKAY [  2.738s]
    27. finished. total time: 3.331s
    28.  
    29. c:\Android>fastboot reboot
    30.                      rebooting...
    31. finished. total time: 0.024s
    32.  
    33. c:\Android>
    This should reboot the phone to a different looking screen, with green text on a black background, which looks like this:


    [​IMG]

    Attached Files:

    CapnO likes this.
  16. kloroformkandi

    kloroformkandi Active Member

    Okay I'm there at the new screen.
  17. doogald

    doogald Guides Guide

    Excellent. You are doing great.

    The next step is

    You are already in recovery, so you don't need to power off.

    What you are going to do is (with the phone still cabled to the PC) go down to the USB-MS Toggle and press the trackball. This will connect your SD card as a drive letter on your PC.

    Drag the following files that you downloaded earlier to the SD card:

    ErisMiscReset_v0.9.zip
    MTD_Inspect_v0.9.zip
    ErisMTDNuke_v0.9.zip

    When those files are copied over (which should not take too long), disconnect the drive safely from the taskbar notification on your Windows PC and then press the trackball on the phone to return to the menu.

    Then go to "Flash zip from sdcard" and press the trackball.

    Go down to ErisMiscReset_v0.9.zip and press the trackball.
    Press the trackball to confirm.

    There will be a series of messages:

    Code (Text):
    1. Install from sdcard...
    2. Finding update package...
    3. Opening update package...
    4. Verifying update package...
    5. Installing update...
    6. Copying files...
    7. Deleting files...
    Report back if there are any error messages.
    CapnO likes this.
  18. kloroformkandi

    kloroformkandi Active Member

    Error: Run 'ums-toggle' via adb!
  19. doogald

    doogald Guides Guide

    Just curious - where did you see that error message?
  20. kloroformkandi

    kloroformkandi Active Member

    On my phone, right after selecting USB-MS Toggle
  21. scotty85

    scotty85 Guides Guide

    I believe that error is simply the battery needs charged.

    Failing that, you may need to transfer the files via a card reader mounted in the pc.

    Try and charge or change the battery. You do not want it to die mid flash with one of those files :eek:
  22. doogald

    doogald Guides Guide

    No, that's not it. I should have tested this sooner - I made a mistake. There is a better way, I think.

    Let's try this: download the attached file recovery.zip (in the next post - sorry!)

    Copy recovery.zip to c:\android if you did not do this already

    We will do the same thing that we did a few steps ago:

    - restart the phone to HBOOT, with the phone connected to the PC
    - (make sure that it still says "Unlocked" at the top - if not, let me know.)
    - press Send to start fastboot
    - fastboot oem rebootRUU
    - fastboot flash zip recovery.zip
    - (notice that last step is a little shorter - just recovery.zip)
    - (also, report if there is an error message)
    - fastboot reboot

    This should start the Amon_RA recovery again. We are still not there

    - pull battery
    - restart the phone holding VolUp
    - (if you did that last step holding VolDn and started HBOOT, no worries - there should be a prompt to press VolUp to start Recovery. Go ahead and do that.)

    Now USB-MS toggle should work. Proceed with the step to copy ErisMiscReset_v0.9.zip, MTD_Inspect_v0.9.zip, and ErisMTDNuke_v0.9.zip, and then flash ErisMiscReset_v0.9.zip, from a few posts ago.

    (Note: in my experience, this ended up re-locking the bootloader. That's not a big deal - it will just save a step later.)

    Again, report any error messages.
  23. doogald

    doogald Guides Guide

    I forgot to attach recovery.zip. Here it is:

    Attached Files:

  24. kloroformkandi

    kloroformkandi Active Member

    Okay I ended up having to use a card reader.
    I just drag it onto the SD card, not in any particular folder, correct?

    Oh wait I just saw your last post. [I haven't dragged anything in yet]
  25. doogald

    doogald Guides Guide

    Yes, that's right - not in a folder, in the top directory of the SD card.

Share This Page