Stuck in bootloop on 2.2, how do I install the newer FroYo version of Koush's recovery??Support


  1. just4747

    just4747 Well-Known Member

    I was trying deodexing manually and ran into big problems, now in bootloop. I want to just custom recovery restore to the deodexed ROM here (Droid X 2.2 Froyo Deodexed and Ready For Themes) but cannot because I get the following error every time I try to restore a backup from custom recovery: "e:Can't mount /dev/block/mmcblk0 device or resource busy...etc..."

    I think I found out that it is because this Koush recovery is the original 2.1 version, so I need the 2.2 one.

    Two things:

    -Where do I get this 2.2 newer version? His site doesn't mention it but maybe he just replaced the file download without mentioning? (http://www.koushikdutta.com/2010/08/droid-x-recovery.html)

    -How can I install this newer recovery if I am stuck in bootloop?

    Thanks guys.

    Advertisement
    :
  2. just4747

    just4747 Well-Known Member

    Can someone please help me? I need to figure out how to get the newer version of this custom recovery on so I can restore the deodexed 2.2. Until then I am stuck!

    Even when I try to apply a 2.2 update.zip from stock recovery, it says:

    "E:Error in /sdcard/update.zip
    (Status 2)
    Installation aborted."
  3. Airmaxx23

    Airmaxx23 Well-Known Member

    You're probably going to have to flash with the .sbf back to 2.1, then root, then install 2.2, then the bootstrap, then the deodexed recovery. It should take about 25-30 minutes total.
  4. just4747

    just4747 Well-Known Member

    How come I can't fix it from this point? Is there any way I can either make the stock recovery successfully flash update.zip of 2.2 that I have or make the custom recovery successfully restore the deodexed 2.2 backup??
  5. Airmaxx23

    Airmaxx23 Well-Known Member

    See if you can boot up into recovery and install the update.zip again, then download the bootstrap and apply the deodexed recovery.
  6. just4747

    just4747 Well-Known Member

    I did and it gives me an error about build.prop which I have a modded one on there now. How can I adb into the phone to replace it with the stock one? Hopefully that will let me install update.zip...

    Also, where can I find Downgrade.zip if I need to flash SBF? I already have the SBF file.


    EDIT: I got ADB to find my phone and navigated to /system and ls shows nothing in there, wtf?

    How can I fix this lol.
  7. Airmaxx23

    Airmaxx23 Well-Known Member

    If you have the SBF file just use the RSDLite program to flash back to 2.1.
  8. just4747

    just4747 Well-Known Member

    Thanks for the help once again Airmaxx, I will attempt it
    Although I already see things I don't recognize/didn't get in the zip file like pst_flash.ini ....eek

    EDIT: SBF flashing is underway :)

    Thanks again for the advice buddy.
  9. Airmaxx23

    Airmaxx23 Well-Known Member

    No problem, let us know how it goes.
  10. just4747

    just4747 Well-Known Member

    So is Koush's newer custom recovery that works on 2.2 the one on his site here? My Brain Hurts: Droid X Recovery

    It doesn't mention an update or anything.


    Nvm, I went ahead and tried it and it's workin fine!
  11. Airmaxx23

    Airmaxx23 Well-Known Member

    Have you gotten everything done, are you back to 2.2, rooted and deodexed?
  12. just4747

    just4747 Well-Known Member

    Everything worked great, thanks!

    Just stressing over changing everything back to how it was for the millionth time haha, this is great though! Will def make a nandroid backup just in case.

    Another day another mod...
  13. Airmaxx23

    Airmaxx23 Well-Known Member


    I know what you mean, but once you've done it a few times it's actually pretty simple and quick to do. I'm glad to hear that it's working now.
Loading...

Share This Page