Stuck with new (old) Desire

Last Updated:

  1. edblax

    edblax New Member

    Hi everyone,

    I've been reading these forums for a while but just signed up because I'm pretty stuck with my phone. It's an HTC Desire that I just bought second hand because my Nexus One finally bit the dust. I'll try to recount what I've done in as much detail as possible, hopefully it will make sense. (Sorry for the long post, it gets to the point at the end)

    To begin with, the phone came with what seemed like a stock ROM (I think - I didn't spend much time looking at it) but rooted. That was no concern to me as I was going to install a custom ROM anyway, and I decided on MildWild 4.3 (Oxygen)

    I flashed Mildwild 4.3 and used it for a couple of days until I got the message that I had no space remaining. No matter what I did I couldn't seem to get the space back, so I decided to try something else and flashed Mildwild 5 (CM). It was much slower than the Oxygen version so I flashed back to that but did a factory reset so I had space again. I changed the settings to make apps install to SD card by default and moved all the apps that I could to the SD card. This time I used the phone for about a week before it said there was no more storage space. By this stage I couldn't receive emails or anything, and again there seemed no way around it - the first day I got the message it went from 15mb free to 8mb free in a few hours without me downloading anything or using it much at all. There were no apps stored to internal memory other than the ones that came with the ROM.

    I had a vague recollection from playing around with my Nexus One (a couple of years ago, before its power button broke) that an ext partition on the SD card could get around this problem. Fortunately I had a brand new microSD card that I had just ordered so I partitioned and formatted that using MiniToolPartition and following some instructions I had seen on the net. The ext3 partition I created was around 3GB.

    I did another factory reset so I would have room to download link2sd. Downloaded it and got the error "cannot create /system/etc/ not enough memory" error." Googled and found that my phone was probably S-ON, checked in recovery and confirmed this, then looked at how to get S-OFF.

    My bootloader is 0.80.0000 (from memory), so I can't use unrevoked as it doesn't support that version. I saw a suggestion that upgrading to Froyo using the RUU would update my bootloader, but the RUU returned Error [131]: Customer ID Error.

    Next suggestion was to install CID Getter to check my phone's CID, however I seem to be one of the unlucky people for whom CID Getter doesn't show a CID.

    As you can see I've been playing around with it for a while (a couple of weeks in fact), am pretty stuck and then yesterday came down with a horrible cold which has completely destroyed my ability to keep searching for and testing solutions. So I thought I'd post here and ask if anyone a bit knowledgeable could tell me simply the steps I should follow to get this Desire running, not running out of space and preferably using MildWild (Oxygen) or a similarly fast ROM.

    Thanks a lot


  2. Hadron

    Hadron Well-Known Member Contributor

    Hi Ed, and welcome to AF :)

    Only have a minute, so just some brief thoughts:

    1) if you have a working ext partition then you should need nothing else with MW Oxygen. There is already an a2sd script in the ROM, though if you locate & flash the patch to move dalvik to sd that will give more space (needed with Oxygen, not certain with MW version).

    Minitool is not the best partition tool though, and 3GB is bigger than you need.

    2) app data, including system app, lives in internal memory. Sounds like that, rather than apps themselves, may be your problem. Look at app sizes and try to see which apps are using a lot of space.

    3) the official 2.3 upgrade works with many cids. You have to use Revolutionary to S-Off (& re-root) after that.

    Good luck
  3. edblax

    edblax New Member

    Thanks a heap Hadron! I did what you suggested, and I'm nearly there. Step by step:

    Found and ran the official Gingerbread RUU.

    Ran revolutionary for s-off.

    Flashed Mildwild 4.3 (Oxygen).

    But still no sd-ext. Doesn't seem to be recognised by MildWild or any of my apps. I formatted it again through the computer, and also did a factory reset which said that it formatted sd-ext. Any ideas for how I can get the sd-ext to work so I don't run out of space again?!?
  4. edblax

    edblax New Member

    Got there, just had to enable it in the settings. YAY!
  5. Tyseyh

    Tyseyh Well-Known Member

    Moving this to all things root, even though the issue is solved.
  6. wasim memon

    wasim memon Active Member

    You have to mount sd ext for the first time.
    i also face these problem i found it in recovery>mount partition >mount sd ext..
    but you can find in recovery mount sd-ext and then reboot it and then select sd for install apps.

Share This Page