SU Binary Update Fail Fix


Last Updated:

  1. sirphilk

    sirphilk Active Member This Topic's Starter

    Joined:
    Nov 23, 2011
    Messages:
    36
    Likes Received:
    18
    I'm not sure if it's a problem for all Exhibit II users, but soon after I rooted I started getting notices "SU Binary outdated". When I ran the update in Superuser I would get a message "md5 fail" every time. I updated Superuser twice since then and still had the "md5 Fail" message. Anyway I found another app on the market "Busybox Installer" by Stephen Erikson. After I ran it and used it to update my Busybox, I decided to see if it fixed the problem and it did. I then went to my Wife's Exhibit II because it had the same problem. I fixed it there too. I have seen many other posts related to the same issue, not sure if this will help there as well. But I thought I'd share this info.
     

    Advertisement
  2. Kamen999

    Kamen999 New Member

    Joined:
    Dec 31, 2011
    Messages:
    2
    Likes Received:
    1
    I saw so many discussions over this, but knew none really applied exactly to my situation - until you posted. THX!!!
     
    Spoomypabpucel likes this.
  3. sirphilk

    sirphilk Active Member This Topic's Starter

    Joined:
    Nov 23, 2011
    Messages:
    36
    Likes Received:
    18
    I'm glad I could help!
     
  4. Manny Avatar

    Manny Avatar Member

    Joined:
    Feb 28, 2012
    Messages:
    5
    Likes Received:
    0
    Signed up on this forum just to say thank you.

    This sir, was a magnificently simple fix for a problem that has been niggling away at me for weeks. Much kudos to you, may your camels be healthy and your harem grow ever larger.
     
  5. donrocko77

    donrocko77 New Member

    Joined:
    Mar 26, 2012
    Messages:
    1
    Likes Received:
    0
    Thanks, it worked for me to. Im new to smartphones period. I rooted my exhibit 2 got same message. Fixed it and now its time for a good custom rom.
     
  6. nickmorin99

    nickmorin99 Member

    Joined:
    Sep 11, 2011
    Messages:
    22
    Likes Received:
    2
    Worked for me. I had to use the program to uninstall and reinstall BusyBox for it to update properly. Kept failing if I just tried to install.

    Thanks
     
  7. may352

    may352 New Member

    Joined:
    Apr 9, 2012
    Messages:
    1
    Likes Received:
    0
    thank you very much.:)
     
  8. briisback

    briisback Member

    Joined:
    Apr 14, 2012
    Messages:
    22
    Likes Received:
    1
    Hi everyone, I ran into another problem. OK I have root accessnow,yayyyyyyy! I wanted right away to see if I could put internet on another device(my old Galaxy prevail) Now wireless hotspot turns on and says I can share internet but my galaxy is not finding it. Now I had my neighbor come by and turn her hotspot on her phone and my galaxy connected to her phone. Why isn'tmy warp not being recognized? Superuser says I have access.

    I'm also getting "su binary update" message using super user, I get failed every time soI read a forum bout installing the busy box installer from the market n which I did. its suppose to fix the update problem but I don't think it did cause I have no idea if this binary update is a part of why it won't let any devices find my warps WiFi connection. Oh her phone let's my prevail use her hotspot. . I use Google Wi-Fi for root users and it says tethering is running, Why won't my warp be recognized? And I still cannot update my su binary to the new version.. help plz?
     
  9. Friggin Joe

    Friggin Joe New Member

    Joined:
    Apr 4, 2012
    Messages:
    3
    Likes Received:
    0
    Had the problem, this fixed it, thanks!
     
  10. sirphilk

    sirphilk Active Member This Topic's Starter

    Joined:
    Nov 23, 2011
    Messages:
    36
    Likes Received:
    18
    Sorry my fix didn't help. I posted the fix here (the Exhibit II root forum) because it worked on my Exhibit II. I have heard it has worked for other phones, but I have no idea about your phone in particular. You might want to try out a tethering app from the market and see if that helps with your tethering problem, sometimes they help.
     
  11. Fatty1212

    Fatty1212 New Member

    Joined:
    Apr 28, 2012
    Messages:
    1
    Likes Received:
    0
    I am so happy i updated SU to v 3.0.3.2after reading this thread! You guys rock!!!


     
  12. ww321q

    ww321q New Member

    Joined:
    Nov 29, 2011
    Messages:
    2
    Likes Received:
    0
    sirphilk Thanks !!!!! I've been trying to solve that md5 Fail issue since I got the phone months ago. :) :) :)
     
  13. BarelyConfused

    BarelyConfused New Member

    Joined:
    Jun 25, 2012
    Messages:
    1
    Likes Received:
    0
    Geeze,i hope someone can help me out....i am trying to root using zerg root...everything through normally but i cannot seem to install any version of busybox.Ive tried busybox installer from google play and every version available,yet nothing comes through.Noted:busybox installer says my phone is rooted
     
  14. tigro80

    tigro80 New Member

    Joined:
    Nov 10, 2012
    Messages:
    1
    Likes Received:
    0
    Thank u very much...just registered to say that to you :)

    I have a Motorola XT317 and had the same issue...not anymore thanks to you!
     
  15. sirphilk

    sirphilk Active Member This Topic's Starter

    Joined:
    Nov 23, 2011
    Messages:
    36
    Likes Received:
    18
    Awesome! Glad I could help!
     
  16. DaisFlaque

    DaisFlaque Well-Known Member

    Joined:
    Jan 20, 2012
    Messages:
    1,092
    Likes Received:
    344
    One more fix... If you get the MD5 sum fail, I fixed it using Super SU, avaliable in Play Store. One thing though it not only updates the Binary but replaces it. It worked for me and my ex's Exhibit. Theres one thing though... Since it replaces the SU you have to disable the old SU app. follow the instructions and you'll be surprised at how neat the interface is, the choices are trippled..
     

Share This Page

Loading...