SU (superuser) Binary Update failed...


  1. scoobysnax

    scoobysnax Active Member

    Hi folks, just been updating from Android Market and the Superuser app had some problems, couldnt complete the binary update...


    Im rooted & running Gingervillain 3.1

    Had a search on xda and found this thread...

    "su binary is not updated" - problem updating - xda-developers


    have gone through the process in the above post(thanks to the OP "andQlimax")
    SU updated fine after this process (to 3.0.2 I think) and didnt come up with the previous Binary Updater failed error


    Just thought Id mention seeing as I couldnt find a thread about it here...

    Scooby

    Advertisement
    :
  2. Rastaman-FB

    Rastaman-FB Well-Known Member

    what hboot are you using?
    is it a custom one? how much system space do you have left?
  3. Dazza

    Dazza Well-Known Member

    I'm having issues as well.
    Today my Super User updated itself on my rooted desire. This is the first time that SU has done anything since I rooted my device months ago. Now it's saying "su binary outdated" and tap to update.
    When I do, it says current version is 2.3.1-ef. Then it goes through a couple of things successfully the says "Gaining root access.....fail!"
    Any ideas what this is and why it won't update?
    Software number is: 2.29.405.2 if that matters.
  4. scoobysnax

    scoobysnax Active Member

    HBOOT - 0.93.0001
    System memory free (from Quick system info) 115MB

    All Ive done to the phone is root about 8 months ago, partition the memory card (500MB I think) and using Gingervillain, never customised the HBOOT

    Scooby


  5. scoobysnax

    scoobysnax Active Member

    Dont quote me on this, but from reading a bit about my problem It seems that due to not being s-off, the SU app didnt have the necessary permissions to write the appropriate system files... Maybe wait for someone to confirm its the best thing to do, but you could follow the instructions in the post I linked to above, worked for me! (remember to backup first though!)

    Scooby
  6. Rastaman-FB

    Rastaman-FB Well-Known Member

    hmm yeah forgot about the s-off thing
    it wont update for me as my system doesnt have enough space
  7. scoobysnax

    scoobysnax Active Member

    In fact having just read the updates list in superuser, I see that there was an update in 3.0 that fixed the very bug I fell foul to... (app saying that the binary updater is outdated when it isnt or something)

    going from the instructions in the xda post, uninstall any updates, and flash the 3.0 zip file.

    SU then updates correctly from the market.

    Scooby.
  8. adskankster

    adskankster Well-Known Member

    Am I right in that the new su apk needs an extra 5-600k? If so the question is whether to move to the larger hboot, or live with the market always wanting to update (minor irritation).

    Anyone used su elite? I can't see that the extra functionality is useful, but then sometimes it's not obvious until you play.
  9. Rastaman-FB

    Rastaman-FB Well-Known Member

    i dont know why you would need anything more than standard superuser. all it is is an access granter. simples
  10. adskankster

    adskankster Well-Known Member

    I think it includes stuff like backup and restore of apps permissions (in beta), root console (beta again), pin input on superuser request, logging options, ghost mode (whatever that is) and some more stuff I haven't looked at. As I say I can't see that being overly useful, but that's why I wondered if anyone had it as there may be something good there that doesn't jump out.
  11. RayRayRay

    RayRayRay New Member

    Not sure if you fixed your issue by now, but I had a problem with the Binary Update failing. I finally figure out that I had Superuser blocked from using the internet with Droidwall.
  12. adskankster

    adskankster Well-Known Member

    I accidentally upgraded it today, and it worked no problem. There was a more recent update to it that may have reduced the install size (for instance it doesn't force the install of busybox now), so it may update okay for dGB users now. I'm on the 60mb hboot.
  13. Rytiou

    Rytiou Member

    Hope this worked for you man
Loading...

Share This Page