Sumvision Cyclone A9 Andoid 2.3 - Root Help?


Last Updated:

  1. TangoBretta

    TangoBretta New Member

    Hi Everyone

    I have a Sumvision Cyclone A9 Andoid 2.3 Media Player (small black box) - not nano
    I purchased this neat little box and attached a 1.5tb HDD, with the intention of sharing out the content to the rest of the family (NAS style - MAC and Win7) with the added luxury of being able to play movies / music etc attached to my living room tv via HDMI. The box is currently wireless but I also have a gigabit switch nearby that I can connect to hardwired.

    Ive already been able to install the SWIftp.apk on the box and set up this 'share' via ftp but the transfer rate is poor - avging out at 1.2Mbs. I'd expect to be getting at least 20-40Mbs over LAN if hardwired.

    Without success Ive been trying to root the Sumvision Cyclone A9 Andoid 2.3 Media Player with Z4root.apk and Gingerbreak.apk (none appear to work) so that I can utilise SuperUser with the Samba Filesharing.apk

    Does ANYONE know how to root or can offer an alternative method to get my smb fileshare up and running. Also, has anyone achieved running the Samba Filesharing app on another box? What transfer rates are you experiencing over your LAN? :confused:

    Any help appreciated :D

    PS. Ive already checked thread the rooting-ider-a10 thread but doesnt appear to solve my gear and set up.

    Quote: ruzzolone - Model A9 is there an app called z4root, for model A10 no app do the rooting( Android 2.3 )
    ....but z4root doesnt work on the Sumvision Cyclone A9 Andoid 2.3 Media Player. Ive tried. :mad:

    Advertisement
  2. TangoBretta

    TangoBretta New Member

    Can anybody help? Might seem n00bish to some but any help help in the right direction is appreciated. thanks again.
  3. next121

    next121 Well-Known Member

    Not sure to be honest the Sumvision Android boxes are typically rebrands of Geniatech Android TV devices and the firmware for those are normally rooted out of the box so to speak.

    Also these aren't really meant to be used as NAS so I doubt it is cut out for that task. You could try installing the Geniatech M1 Android 2.3 firmware, if you do digging through the pages of the thread, but keep in mind you have to be running using a certain level of firmware/spi before you can install a newer one.

    You could also install the M1 Android 4.0 firmware which Sumvision provide a vesion of on their website, this is slower than Android 2.3 but you can use the alpha version of XBMC under Android 4 and this allows streaming media scanned by XBMC into it's media library via UPnP to other clients. UPnP would offer the fastest possible transfer speeds under Android.
  4. TangoBretta

    TangoBretta New Member

    Ive already checked all Geniatech models available and none match mine ....:confused:

    Thanks for the reply and help next121!
    Id rather just root, but have tried over and over again with Z4root and gingerbreak. Gingerbreak just hangs and Z4root kicks out halfway through. Ive checked if its 'out of the box root' by attempting to install root required .apks but all of them fail = root required.

    I'd like to post the excact model I purchased but cant as im a new member but its this one:
    [​IMG]

    Any other ideas?
  5. next121

    next121 Well-Known Member

    Probably an early model, it is an Amlogic 8726-M1 box for sure, you should be able to use the Geniatech firmware on it anyway.

    One thing to watch out for is on the very first models some of them had 256MB RAM and others had 512MB, most of the recent firmwares are for 512 as the 256 models were discontinued. If yours is a 256 then you will have to go digging in the Geniatech thread for those old firmwares.

    According to this it has 512MB RAM so you should be able to force the Geniatech firmware on it. Click the support tab on that page then scroll to the bottom of the page and you will see the instructions on how to force the manual firmware update, this is the latest version of Android 2.3 from Geniatech. Download rename .zip to .img and put in sdcard then apply update on firmware recovery screen though again watch out you must be at a certain uboot/spi level in order to install that and if not you must get the older firmwares and update to those first.

    As always do the above at your own risk, but I cant think of anything else to try.
    TangoBretta likes this.
  6. bthoven

    bthoven Well-Known Member

    TangoBretta likes this.
  7. amwebby

    amwebby Member

    The root method in that thread doesn't work for my Sumvision Cyclone Android MKV Media Player (the one in the picture above). It fails signature verification. I thought I'd install CWM Recovery to turn SV off but CWM hasn't got a recovery mod for our board! Anyone got any ideas?
  8. amwebby

    amwebby Member

    Update: the root method in that thread didn't work for me as the update.zip file got corrupted whilst copying it to the Sumvision's sd card, something I only spotted by comparing the byte-size with the original.

    I copied the original on to a USB stick and applied it from Applications/Upgrade and the box is now happily rooted. :thumbup:

Share This Page