1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

Suntrust AppSupport


  1. rainbowwar24

    rainbowwar24 New Member

    I have a Samsung Galaxy Precedent from Straight Talk. I like the phone, it does what I need it to do. A few months ago I downloaded the Suntrust Mobile App. It works great!! Well, Suntrust has a new app that does more stuff. So I went to download it, and it says my device is not compatible. Suntrust says all Android devices 1.6 or above will work. Well my ph is 2.2.2. I did some reading and thought maybe if I "Root" my ph I could get the app. Well I "rooted" my ph this morning. Downloaded the "Root Checker" and it says my ph is now rooted. I went back to get the Suntrust app, and it still says my device is not compatible. Is there a way to maybe upgrade my OS?? Is that the problem? Any help would be greatly appreciated! Randy.

    Advertisement
    :
  2. Rukbat

    Rukbat Well-Known Member

    Is the app telling you that your device is not compatible, or is Google Play saying it? If it's Google Play, talk to someone at Suntrust who supports the app, and as them to incude your phone in the list of supported phones. If it's the app, speak to them (same people - the ones who write the app) and ask them to fix the error message, since your phone is running a version of Android OS above 1.6.

    In either case, it's their problem and only they can fix it. (Unless you reverse engineer the app and modify it, which isn't easy, even if you're a programmer, it's illegal, and there's no reason to do it, since they should.)

    Your chances of getting them to help you? Probably less than none, but that's the only way to go. (Don't feel bad - I can't use my phone as a scanner in my supermarket because my phone is incompatible with their scanner app, and they won't do anything about it - not even answer my very nice email.)
Loading...

Share This Page