Super Easy Root in 3 minutes...


  1. dasudevil

    dasudevil Well-Known Member


    Sorry for the delay. Are you using the paid version or the free? Im restarting my phone to see if it has anything to do with the root its self. WOW up and running already... Its soo pretty. Okay you have to be rooted to even get into the titanium backup. So we are good there...

    When you are in the app on the home page what do you see? Welcome to titanium backup free version yadda yadda yadda.

    Under the backup/restore tab in the grey bar right under the little tabs you have an option to sort them. You should see a massive lists. Something like this...

    [​IMG]

    Does yours look similar to mine (granted we may have some apps that are not the same) Do you have lots of apps that you can mess with tap or highlight without long press?

    Do you see this when you press one?

    [​IMG]


    If not use the shoot me app, open up where im at then shake phone. Then select an app and shake phone again. Then post pictures.

    Honestly im using the stock theme. caberra or something like that. Errr. scratch that I am using theme safari, under my modes i have under standard.
  2. dpshptl

    dpshptl Well-Known Member

    After a few reboots and reinstalling visionary evrything works now. Thanks
  3. dasudevil

    dasudevil Well-Known Member


    Really? Should have guess the simplest way first. Nice... Now we know for future reference.
  4. cw54o

    cw54o Well-Known Member

    i cant find visionary ANYWHERE. ive tried the link above and its not working anymore, ive tried 4shared....nothing. is it possible for someone who has it to post the apk file or a working link pls? thanks
  5. cw54o

    cw54o Well-Known Member

    well as soon as i posted i couldnt find it, i decided to check twitter....low and behold someone had posted it for download. thanks dASUdevil for posting this. i was missing shootme when i had my slide. now my 4G is complete
  6. dasudevil

    dasudevil Well-Known Member


    I edited the first post to include the direct download link. Should be good now. LOL

    Glad i can direct you to an easy rooting process.
  7. dasudevil

    dasudevil Well-Known Member

    holy crap my first thanks on this post. 800+ views and your my first. Thanks....

    Hopefully there wont be any other topics regarding the same thing like there is now. I think there are a total of what 5 now..
  8. cw54o

    cw54o Well-Known Member

    i meant to do it yesturday. it was extremely helpful to me so you deserved it :)
  9. zenijour

    zenijour Member

    Question: Do you have to re-do the temp root when you have fastboot on? Or do you only have to do it when you truly restart your phone?

    Haven't received my phone yet, this is the method of rooting i will be doing until an easier perm-root is achieved, I've been reading a lot over at xda and it sounds like the perm-root isn't a for sure thing for everyone, btw thanks for this :D
  10. dasudevil

    dasudevil Well-Known Member


    Yes however it really only takes a few minutes. If you dont want to remove anything its like what 1 minute tops. After a few removals titanium lays it out for you with the most removed up top. Makes things real easy. Perma root... Not my cup of tea. Ill stick with the temp root.
  11. I downloaded Visionary from the site you linked to but when I click on it to open .... I don't know how to get it to my phone!

    I've tried to follow the directions for screenshots without root also and my driver won't load. :( And nothing looks the same way as the instructions. So frustrating.

    Anywho... Help?? Thanks.
  12. dasudevil

    dasudevil Well-Known Member

    OMG... Use the marketplace on your phone and get the apps. Much easier...

    This is much longer..

    If you dont want to do that plug in your usb cord to the computer and phone. A Window should pop up asking what you want to do next. Select open folder to view files. Now go to your place where you downloaded the application. Drag that into the phone. Now go download from your phone ONLY astro file manager. Open that. Then look for the file you dragged over. Visionary. Then open that. Your phone needs to be able to accept unknown sources. Install. Then open it let it run.

    Start on step 1.
  13. hoagie

    hoagie New Member

    Excellent set of instructions and thanks for following up on everyone's questions. Good to see this.

    I downloaded the apps and got them installed no problem. Uninstalled the apps you mentioned above.

    I also found that upon first opening Titaninum only 5 items were displayed. Tried rebooting several times with no luck. Titanium had prompted me to click on the "Problems?" button when starting up. So finally I did so and got prompted to download a "known good version of BusyBox" if there were any issues. Accepted this. Got the new BusyBox file. Rebooted and Viola!! All apps now appear.

    Has anyone compiled a list of apps that are known as okay to uninstall? Sure would like to get all of the crapware off this thing.

    Thanks again.
    LBSF likes this.
  14. dasudevil

    dasudevil Well-Known Member


    Thank you!

    Dont know about all the "crapware" list. Everyone has a list of their own they want to remove.

    Personally removed, (great cant remember restarting phone. LOL)

    Asphalt 5
    Demo Video
    Facebook
    Mail 1.1.0 (yahoo)
    Messenger (yahoo)
    Monopoly
    News / News Widget
    Rockband
    Stocks / Stocks Widget
    Twitter
    Amazon (just added)
    Tmobile TV (just added)

    Things i think can be removed:

    AppPack
    Tmobile Themes: Carrera, Downtown, Graffiti, Redrocks, Ruby, Wildflowers
    Faves / Widget
    Flashlight
    Flicker
    Friends Stream / Widget
    Several Widgets : They are marked widgets
    Peep
    Quick Office
    Screen Share
    Setup

    I have not removed any of the think you can remove because i either use them or plan on trying them out.

    Should be a good list or start. Im sure there are more and hopefully someone can point more out. I just get the obvious ones I wont use.

    Hope that helps
  15. Unfortunately Visionary isn't in the Marketplace anymore. I'll try the other again - when I plug in my phone it just wants to download pictures.
  16. dasudevil

    dasudevil Well-Known Member

    OMG.. i did not know sorry...

    another way you can install the app...

    Install from the market APKatcher...

    From computer...
    Email yourself the file.

    Back to the phone.
    Open up the email with the attachment. Click install button then it should look like another app being installed. Finish with the install. Should work i just tested it as i was typing so i did not miss a step.

    Might be easier then what your able to do.
  17. n1oty

    n1oty Member

    I downloaded the file from Visionary's web site, got it properly unzipped, onto the phone and used Linda file manager to run the apk file, but I do not have Visionary installed. It did install the Superuser icon, but not the Visionary icon with the yellow triangle. Any thoughts folks?? I double checked that everything is installed on the micro SD card by pulling it out of the phone and sticking it into a card reader. The files are there. I've restarted the phone a couple of times, even pulled the battery. Obviously, I have the MT4G through TMo and I have the latest OTA update prior to attempting this temproot.

    Thanks,
    John
  18. dasudevil

    dasudevil Well-Known Member

    Under applications do you see Visionary installed? If so uninstall it and try re-installing it. If its not there try reinstalling it again.
  19. n1oty

    n1oty Member


    This is really bizarre. I've re-installed numerous times, tried rebooting, even pulled the battery a couple of times. The superuser icon is there, but not Visionary. When I go into "Manage Applications" and click on "All" at the top, Visionary is NOT present. To be certain that the zip file was not corrupt, I downloaded the zip file again. I know I do not have root access because I cannot run any apps that call for root access.

    It's too bad that I missed getting this through the "Market" by one day, as I just came over to Android from Blackberry.

    I am still open to suggestions.

    Thanks,
    John
  20. dasudevil

    dasudevil Well-Known Member

    the funny part is you have the superuser icon and have not rooted. Should not have it unless you rooted. Thats one im trying to figure out still.
    n1oty likes this.
  21. n1oty

    n1oty Member


    Success!!! The .apk file you sent me did the trick. I have to assume that the .zip file from the author's web site is corrupt or my jzip program was screwing things up. It will be interesting to see if anyone else has problems with the direct download of Visionary. If not, it is something with my JZip program.

    I have successfully run ShootMe and Titanium Backup, so my temproot is successful and I sincerely want to thank you for your kind assistance. I knew I was on the right course and it was simply a matter of files being screwed up or something. Your copy of the file worked like a champ the first time.

    Thanks,
    John
  22. offthecha1n

    offthecha1n Well-Known Member

    thanks dasudevil, evrything worked well.
    quick question, downloaded setcpu and maxed it out like you have it in your screen shot, any other settings i should use or have it on to help/improve
  23. dasudevil

    dasudevil Well-Known Member

    actually the screen shot in the setcpu is Super Galaxy's. Im sure he will pop in here and check it out. Then again once you root its almost impossible to forget.

    Glad i could help.
  24. Daviddc114

    Daviddc114 Member

    i have a question, you guys said if you delete the rockband app it will come back after you reboot, but when i press it to remove it a popup (in titanium) comes up and says it removes it andit is irreversable?? im a little confused.. also i am a newbie to the android platform, i am curious, when you start your phone in the boot screen, there is an option there to reformat phone to original state, will this always be there, so even if you screw up your rooted phone, and uninstall things, can you always go to this option and get the original state back, unrooted??? thanks..
  25. sativa1234

    sativa1234 New Member

    hi. i am having the same problem as everyone, trying to remove pre installed demos. you 3 minute root directions look great but the visionary link is no longer active & i cant find it in the marketplace. can you please help. thanks

Share This Page