Super User / SuperSU doesn't appear after rooting

Last Updated:

  1. bellay

    bellay New Member

    hello, I have tried many methods of rooting my phone Samsung Galaxy Ace GT-S5830. such as universal gingerbread root, and unlock root. but my phone doesn't seem to be rooted because i've checked using root checker, and it shows that my phone is not rooted.

    Then. SuperUser/SuperSU doesn't appear, too. i've installed it manually on google play, but it shows no apps in superuser and no SU binary installed in superSU. i've tried to root many times using universal gingerbread root, it seems to be rooted, but after I switched on my phone there are no such root apps (superSU/superUser) installed on my phone. what should I do? Is there any problem regarding my SD card or my phone?

    Below are my phone information such as Android version, Baseband version, etc.

    Android version : 2.3.6
    Baseband version : S5830DXKT4
    Kernel version :
    Build number : GINGERBREAD.DXKT5

    I'm hoping that all Android experts in this forum would help me in finding the solution of this problem. THANKYOU! :)

  2. StoneBoyTony

    StoneBoyTony Well-Known Member

    Follow me here: and use the remover for Quickoffice or Thinkfree Office (depends what you have on the phone) then use the file for rooting.

    The procedure will go like this:

    1. unroot - reboot the phone
    2. remover for quickoffice or thinkfreeoffice (dpends from the stock rom) - reboot the phone
    3. root with v28 (without root validator) - reboot the phone
  3. ayush29k

    ayush29k Well-Known Member

Share This Page