Root Superboot can't read my Nexus one when rooting, need help!

Discussion in 'Android Devices' started by rjizzzle, Mar 29, 2010.

  1. rjizzzle

    rjizzzle New Member
    5

    Mar 29, 2010
    4
    0
    5
    I was trying to root my nexus one. I was able to complete unlocking the bootloader but when i used superboot to root it, i won't get pass the step where you verify to make sure superboot recognizes your device. Everytime i enter fasboot-windows devices command, it just won't recognize it. I don't know what else to do. Can somebody please help? Thanks in advance!
     

    Advertisement

  2. Viralmind

    Viralmind Well-Known Member
    58

    Mar 4, 2010
    258
    16
    58
    are you sure you have the right superboot for your phone?

    are you sure you're typing in the fastboot command correctly?
     
  3. Who Cares?

    Who Cares? Well-Known Member
    16

    Dec 23, 2009
    88
    4
    16
    You also need to have USB debugging checked
     
  4. rjizzzle

    rjizzzle New Member
    5

    Mar 29, 2010
    4
    0
    5
    first of all, thanks for the quick reply. I finally got it to recognize my nexus one and my phone is finally rooted. My problem now is when i flash the latest RA recovery image using this command "fastboot-windows flash recovery recovery-RA-nexus-v1.7.0.img, it says " error: cannot load 'recovery-RA-nexus-v1.7.0.img'. What am i doing wrong? i did save it in the same directory. i followed every step. it still won't flash the recovery image.
     
  5. Who Cares?

    Who Cares? Well-Known Member
    16

    Dec 23, 2009
    88
    4
    16
    You have to save it IN the fastboot/superboot folder not the same directory
     
  6. rjizzzle

    rjizzzle New Member
    5

    Mar 29, 2010
    4
    0
    5
    i did. i saved it in the superboot folder.
     
  7. rjizzzle

    rjizzzle New Member
    5

    Mar 29, 2010
    4
    0
    5
    i even added the .img at the end.
     
  8. Who Cares?

    Who Cares? Well-Known Member
    16

    Dec 23, 2009
    88
    4
    16
    Try and re-download the recovery file.
     
  9. SBERG

    SBERG Well-Known Member
    16

    Jan 9, 2010
    97
    2
    16
    fl
    When plugging the phone in usb and having debugging checked do i have to mount the device or should that happen by itself? Cant get cmd to recognize my phone. Superboot wont work either. Been reading and trying everything and cant figure any of it out. Dont know if its a step im missing or something that need to be set in win7.
    Im trying not to post to many times about this but could really use some help in getting my phone rooted. Im not experienced with this stuff but i feel i follow direction well so i dont know where i went wrong. Please help if anyone can, Just tryin to learn more about this stuff. Im stumped lol
     
  10. Who Cares?

    Who Cares? Well-Known Member
    16

    Dec 23, 2009
    88
    4
    16
    You have to be in fastboot on your phone.
     
  11. Viralmind

    Viralmind Well-Known Member
    58

    Mar 4, 2010
    258
    16
    58
    you dont need to add '.img' at the end.

    make sure your typing the fastboot part correct.

    what you typed was correct IF your fastboot file says: 'fastboot-windows'

    if your fastboot only says 'fastboot', then only type 'fastboot recovery', not 'fastboot-windows' recovery'.

    depending on the tutorial some will say different because of how the fastboot file is named and some fastboot files are named differently.
     
  12. SBERG

    SBERG Well-Known Member
    16

    Jan 9, 2010
    97
    2
    16
    fl
    ok i think i figured it out. wow that was more than i expected but thats all part of the learning curve i guess. lol
     
Tags:

Share This Page

Loading...