Root SuperOneClick 2.1 Root :D

Discussion in 'Android Devices' started by suhel28, Jan 8, 2011.

  1. Tri-Fecta

    Tri-Fecta New Member
    5

    Jan 16, 2011
    4
    0
    5
    didn't work.. it says rooted successfully and i have superuser on my phone now.. what went wrong? i still can't install on sdcard.. i don't have any other application.. suggestions?
     

    Advertisement
  2. ktulurk

    ktulurk Member
    15

    Nov 26, 2010
    12
    0
    15
    I am having the same error. Did U manage to install after all app2sd?
    Thanks in advance.
     
  3. joel999

    joel999 Member
    15

    Dec 24, 2010
    12
    0
    15


    I have app2sd installed...even then 94 mb is free....all the new apps install in sdcard only...
     
  4. joel999

    joel999 Member
    15

    Dec 24, 2010
    12
    0
    15
     
  5. suhel28

    suhel28 Well-Known Member
    123

    Nov 2, 2010
    693
    307
    123
    Siemens
    India

    You can copy the non sony applications from /system/app to /system/SD
     
  6. Tri-Fecta

    Tri-Fecta New Member
    5

    Jan 16, 2011
    4
    0
    5
     
  7. coman_nick

    coman_nick Well-Known Member
    43

    Oct 25, 2010
    272
    27
    43
    Bucharest, Romania
  8. prabash

    prabash New Member
    5

    Jan 22, 2011
    2
    0
    5
    Hi,
    1) I am totally a newbie to the androids and Xperia X8..
    But I have been doing loads of searching to find out about rooting..and gotta tell ya this is the best thread I have seen thus far on how to do it..And I am planning to do it :D..
    In some others, I have read that there's quite some risk involved when rooting your device that you might brick it..I just wanted to make sure whether this is true and do I have that kinda risk involved when following this method as well?

    2) I am currently using a 4GB class 4 SD card. Is that good enough to do the rooting?

    3) Will the applications and the contacts that I have currently installed in the phone be deleted after the rooting?

    4) After doing it, Will I be able to unroot it? And how?

    I know that this thing is a bit lengthy :p..But I hope someone can help me with these questions. :)
    thanks in advance :D
     
  9. suhel28

    suhel28 Well-Known Member
    123

    Nov 2, 2010
    693
    307
    123
    Siemens
    India

    No
    Yes
    No
    Yes

    Sorry for the brevity
     
    prabash likes this.
  10. pandza94

    pandza94 New Member
    5

    Jan 22, 2011
    1
    0
    5
    Updated to 2.1 using PC Companion.
    Installed net framework vers 4

    When I try to launch Super OneClick it says :Unable to find a version of runtime to run this application.
     
  11. suhel28

    suhel28 Well-Known Member
    123

    Nov 2, 2010
    693
    307
    123
    Siemens
    India

    Check out microsoft's site for net framework's latest version... maybe its not installed properly on your pc
     
  12. prabash

    prabash New Member
    5

    Jan 22, 2011
    2
    0
    5
    Thanx mate..:D
    And I would like to know another thing..after rooting the phone, just in case, if SE released a android 2.2 update for X8, will I have to unroot the device before updating or can I update with the device being rooted?
     
  13. vandalism56

    vandalism56 New Member
    5

    Jan 23, 2011
    2
    0
    5
    Erm.. I'm new to rooting and I'm currently having problems with the SuperOneClick thingy.. I followed ur steps in order and when i click root, the box says : Killing ADB Server...

    OK

    Starting ADB Server...
    * daemon not running. starting it now on port 5037 *
    * daemon started successfully *

    OK

    Waiting for device...

    I do not know what to do next.. Ur help is greatly appreciated :D
     
  14. helmi44

    helmi44 New Member
    5

    Jan 23, 2011
    1
    0
    5
    more patient needed to root.....waitinng......a miracle....waitin..
     
  15. Ryukenden

    Ryukenden Member
    26

    Jan 18, 2011
    16
    1
    26
    Serbia
    Hmmm, i had the issue with "Waiting for device..." too. What solved that issue was the remounting the sdcard for windows, like, re-plug the usb cable and on the confirmation dialog choose Connect your phone, then unplug the cable from phone. Plug it back in and choose Charge phone. Then try rooting it
     
  16. capex

    capex New Member
    5

    Jan 18, 2011
    3
    0
    5
    thanks so much suhel! i've read a lot about rooting n finally found diz thread n it really works! juz wanna confirm, can i use APP2SD in 2GB sd card?
     
  17. suhel28

    suhel28 Well-Known Member
    123

    Nov 2, 2010
    693
    307
    123
    Siemens
    India

    Yes
     
  18. Ryukenden

    Ryukenden Member
    26

    Jan 18, 2011
    16
    1
    26
    Serbia
    Yes u can use 2GB card. I'm using that kind of card because it was shipped with the device, and i put 1GB for storage and ~850mb for apps
     
  19. Dinkoprim

    Dinkoprim Member
    5

    Jan 9, 2011
    5
    0
    5
    Hi there! Can you tell me what I'm doing wrong - I rooted the X8 but when installing app2sd :

    c:\adb>adb shell
    $ su
    su
    # sh /sdcard/app2sd.sh
    sh /sdcard/app2sd.sh
    sh: Can't open /sdcard/app2sd.sh
    #

    I have placed the app2sd.sh into /sdcard so whats the problem ?
    Thank you!
     
  20. suhel28

    suhel28 Well-Known Member
    123

    Nov 2, 2010
    693
    307
    123
    Siemens
    India
    make sure when you connect your phone to your pc you choose the CHARGE THE PHONE option
     
    Dinkoprim likes this.
  21. acsakvith

    acsakvith Member
    5

    Jan 25, 2011
    5
    0
    5
    Thanx. I rooted.

    Didnt install JIT cz some guyz post some issues.
     
  22. lion_king

    lion_king New Member
    5

    Dec 6, 2010
    1
    0
    5
    Hi tried to root my phone with superoneclick and i get the message Device is rooted! but when i trie to use Titanium Backup it says that i have no access to root...

    What the problem?

    Update: I can root my phone:

    http://forum.xda-developers.com/showthread.php?t=905183&page=3

    Just replace the file rageagainstthecage on superoneclick by psneuter, it works
     
  23. coman_nick

    coman_nick Well-Known Member
    43

    Oct 25, 2010
    272
    27
    43
    Bucharest, Romania
    Lion, we used this since 01.08.2011. And it worked perfect even from back there. And since I'm happily using root explorer, titanium, scriptme and other applications that would have shouted at me if I didn't have root, I really doubt I have to replace anything.
     
  24. suhel28

    suhel28 Well-Known Member
    123

    Nov 2, 2010
    693
    307
    123
    Siemens
    India
    yes yes yes.. what a great speech.. we all love ya nick :D
     
    coman_nick likes this.
  25. 20x

    20x New Member
    5

    Nov 24, 2010
    3
    0
    5
    My first attempt, I hope it goes well!
     

Share This Page

Loading...