1. Welcome to the newer, better version of Android Forums! Be sure to see the announcement and enjoy checking it out!

    Some of you have been having login issues. - Please try now. Sorry for the trouble!

Support Superpad 3 stuck on droid logo screen


  1. naa827

    naa827 New Member

    I have a Superpad 3 stuck on droid logo screen someone gave me. Any idea how to fix it??

    Advertisement
  2. tbod

    tbod Well-Known Member

    Is it a SuperPad III [9V / 2 TF Slots / sawee] or a FlyTouch III [5V / 1 TF slot / disco]?

    And what happened immediately prior to the problem? Did you flash new firmware / delete something / throw it against a wall?
  3. naa827

    naa827 New Member

    FlyTouch III [5V / 1 TF slot / disco] i am guessing, since the box just says superpad 3

    Not sure as to why its like this, thats how it was when they gave it to me.
  4. Rabid1

    Rabid1 Well-Known Member


    Except remember there are 9V 1 TF slot P041 and disco10.

    Since someone gave you the pad and it was stuck already, have you tried powering it on by holding down power+back+menu? Hold them until you see a recovery screen or it locks oon the android logo. The next step would be to try to flash new firmware if you are sure of the model.
  5. tbod

    tbod Well-Known Member

    Sadly, guessing doesn't help that much so what does the charger say? 5V or 9V and how many TF slots are there on the side of the unit?

    Yes, I know there are but they have only just been released and I suspect this tablet predates that because if it were a new one surely the donor would have sent it back rather than just given it away?

    Have you tried pressing the reset button? It is on the bottom edge of the unit and it is recessed so you will have to press it using the end of the stylus or a paper clip.
  6. Rabid1

    Rabid1 Well-Known Member

    I have another 10 and a 7 that have been given to me by people online because the hassle of returning and cost of shipping they just went ahead and bought another.

    The reason I don't usually recommend the reset button is it is no different than turning the pad on and off. Yes it couldn't hurt but if a hard revover doesn't work the reset won't do much.
  7. naa827

    naa827 New Member

    It is a 5v, i have tried reseting it holding buttons as i have read on these fourms but nothing. Any ideas?
  8. Rabid1

    Rabid1 Well-Known Member


    SuperPad2 Flytouch3 Hybrid Tim Rom
  9. Chrisnol

    Chrisnol New Member

    i have the same problem two :(


    SuperPad 3/ Flytouch 3 stuck on screen


    I factory reset my ft3 today and after that every time I try to go and boot up, my screen gets stuck on the green Android logo screen. Did not pass that screen to the linux penguin

    I have tried everything that I can think of in order to get it where it is not stuck, and yet nothing will work.
    I tried the reset button, I tried to reboot, I tried to factory reset again, I tried firmware tim6a and no luck!
    Please help me ): the system info:

    My Flyoutch 3 stats:
    Version: Unknown [Sorry, I don
  10. cbabe

    cbabe Member

    i have a super pad 3 its not rooted or anything, all stock everything. I HAVNT EVEN TRIED TO DO ANYTHING TO IT AT ALL.. the battery died lastnight and screen has been black since... sombody pleaseeeeee help!! i've tried every button combo ever invented and the charging light comes on and even went from red to green (showing its fully charged) PLEASE HELP!

Share This Page