SuperPad III'sGeneral


Do you own a SuperPad III?

  1. Yes

    63.8%
  2. No

    4.9%
  3. I'm not sure, but it came in a SuperPad III box.

    31.3%
  1. smorgan19

    smorgan19 Well-Known Member

    I'll test Tim4d2 and let you know. Looks like a lot of features have been added.
    Index of /Android/Flytouch3/Tim-V4
    Change Log
  2. solmich

    solmich Member

    Hi mikerb and shane and guys, thanks for the links for the firmware and tools, which I have them all already, but still no one solution/combination success enough to make my tablet alive. I'm pretty sure that this superpad III is a total fake, because it's only has one microsd slot, just like FT3, but from the dmesg message, it's X210, not X220.

    Recently after a full 1 week of searching and doing some tweaking, I've managed to boot froyo from sdcard/microsd slot. I've posted about that here.

    My problem is now it seems that the NAND flash got corrupt/bad blocks, so I can't do flash_image on it (as well as direct cat or dd, although it raise no error message), so maybe you guys now where I can download the busybox precompiled with mtd-utils??? I;ve tried so many busyboxes but unfortunately they don't include mtd-utils applet. I've tried cross-compile mtd-utils to run on arm, but still unluck, says something of segmentation fault and maybe needed to be cross compiled with uclibc for this tablet..... however, at least it can live

    Another problem is random freeze and hang when I run froyo from SDCARD, think it's an sdcard issue/quality/speed. I've tried hacking memory params in init.rc and increase sdcard read_ahead, but seems no significant effect....

    Still finding another solution though....

    Addendum:
    The positive about running from SDCARD, I can try so many firmware releases, say it's tim's or sol's or official one, just extract the system.tar(.gz) into the system partition (mine is mmcblk0p2), and you're ready to go.... I feel that tim4a is the fastest among others, but unfortunately I've got infamous 90 degrees rotating screen/g-sensor problem.....
  3. smorgan19

    smorgan19 Well-Known Member

    That's no good. In the FlyTouch 3's the internal storage is just an SD card, so you could open it up and replace it with e.g. 16gb (i've done and it works). But not sure about the FlyTouch 2's i think there an onboard NAND chip.

    Also TCH (the chill hacker) recompiled busybox 1.18 on his latest ROM, i think from memory but not sure if it's got mtd-utils. Might be worth D/Lin the ROM and extracting busybox out of it (Link to TCH's latest ROM) Are you flashing through ADB?
  4. solmich

    solmich Member

    Yes, I also in doubt whether the NAND is really nand flash or just something written on top of internal sdcard (like todays linux livecd, we can run the image from HD or USB). If it really an sdcard, so it's easy to replace and burn some firmware on it, maybe sometime I need to open the case...

    For TCH, I'll check about it, still downloading...

    I'm flashing from IUW and bootable SDCARD, and then connect to the tablet from adb, then doing busybox ash for better shell, and direct form there I do some testing on flash_image (included on rom), and dd/cat system.img, as well as mounting /dev/block/mtdblock3 to /somewhere and copying the whole /system structure on /somewhere.

    When I reboot and back to froyo, I'm sure the file I've copied before are still there, but anyway, when I edit the ramdisk.img, adjust the init.rc to mount /dev/block/mtdblock3 as /system instead of mounting sdcard, I've got ANDROID_, it means the system (init) can't find the /system. So, my only test remaining is doing flash_erase or flash_eraseall, but still not found the right files yet.

    Last option is: opening the case, or recompiling with uclibc, or waiting the promised firmware from my distributor....
  5. smorgan19

    smorgan19 Well-Known Member

    Have you checked the mount points in SmaRkieS ramdisk? On the FT3's it's (init.rc):

    mount ext3 /dev/block/mmcblk0p2 /system
    mount ext3 /dev/block/mmcblk0p3 /data
    mount ext3 /dev/block/mmcblk0p5 /cache
    mount vfat /dev/block/mmcblk0p6 /local
  6. solmich

    solmich Member

    Of course, actually it's running ok on sdcard, while init.rc pointing into /dev/block/mtdblock3 (nand partition for /system folder) give me android _ stuck, so it's something about mtdblock itself, thus needed to be erased
  7. bjellys

    bjellys Member

    I have just installed tim 4d firmware and it is all good with no problems and very nice to use .
  8. GMANROD

    GMANROD Member

    Just received my FlyTouch 3 or what whatever they are calling it?..Can't figure out what I actually have? It only has 1 SD Card, so I believe its the latest one available?...

    Here's my situation - I just pulled it out the box and want to backup everything. I logged onto the Android Market using my Google Account. Was atttempting to download Titanuim backup so I could backup the system files and software which came pre-installed. For what ever reason I'm receive the message, there is no account associated with this device?...What or where can I go to download Titanium backup, so I can download Tims updates?...Also, I want to know if I'm following the right procedure for this updates to Tims Roms.

    1- Download Titanium backup ( once someone tells me where to download )
    2- Backup all System Files and Pre-installed software
    a. thes backup files will be sent to the SD Card, right?
    3- Download Tims Roms- which version am I to download?
    a. is there anything I might need to be made aware of prior to updating?
    - current software is Android Version 2.2, Kernal Version 2.6.32.9 Build
    Number FFRG85B , Model Number; Disco.
    4- How do I get the current weather to indicate local time verses Shenzhan,
    China?...I read how to do that somewhere, but can't seem to find it.
    5- Any other advice would be well appreciated.......
  9. smorgan19

    smorgan19 Well-Known Member

    You need to go to Android Market from your pad and login, this will associate your device with your Market account.

    1. Titanium backup can be downloaded here: http://www.mydroid.info/android-apps/titanium-backup-pro-root-v3-8-1-1/ Your device needs to be rooted to use Titanium Backup.
    2. If you only just got the tablet and it's new, i wouldn't worry about backing up the data that's on there. I'd just install Tims ROM.
    2a. If you did choose to use titanium backup to backup system apps and data then yes they'd be stored on the SD card.
    3. I've found 3a very stable and bjellys has just install 4d and likes it. Probably go with 4d2 as Tim has made lot's of improvements. Link here: Index of /Android/Flytouch3/Tim-V4
    3a. Not really, if you follow the update procedure you'll be fine and if you get stuck just post here and i'm sure someone will be able to help.
    4. Follow the instructions below and see if it helps (outdoors):
    GPS
    If your gps is stuck in Shangai or not updating, you need to reset the agps data with the gps status software
    in the menu => tool => Manage A-GPS state
    do reset + download

    Plug in your gps antenna, and let it run until you get as many fixes as possible.
    (it should reset when it grabs 3-4+ fixes, please note that the first time it might take up to 30 minutes - 1 hour to catch all the fixes, be patient)

    Cheers,
    Shane
  10. smorgan19

    smorgan19 Well-Known Member

    Yeah i get that too with Angry Birds. When starting up the Rovio logo is out/fuzzy/pixelated white. The rest of the game is fine. :)

    I ride an 2003 R1 :D Black with Red flamed belly. How bout you?
  11. rajesh1108

    rajesh1108 Member

    I have upgraded my flytouch3 tablet to tim4d2. After that i'm getting issues with 1. Wifi and seconly launcher pro error

    1. Wifi is not connecting keeps going scanning then it says it cannot scan for wireless network.

    2. When trying to change launcher pro icon it says " Sorry! The application LauncherPro (process android.process.acore) has stopped unexpectedly. Please try again.
    Have rebooted the device but still the same.

    Any work around?
  12. denwa

    denwa Member

    Has anyone made a direct comparison of the actual hardware internals of these Superpad III's vs the Ibex/Apad Flytouch 3?

    Also, I am curious as to comparisons of the superpad III clones that report "Disco" vs "SAWEE10" under model number. Are these two separate clone manufacturers?

    Seems many with the SAWEE10 model number have more issues than those of us with "Disco".

    I suppose eventually some adventurous tech savvy soul will buy one of each and rip them apart to see what's inside.

    I'm running Tims 4d2 with no issues (well no diff than the issues that legit ibex FT3 owners have).
    4d2 had CIFS enabled so you can stream from a PC using cifs manager. Battery charging issues have been reported but they seem to be related to the battery stats file. (Use battery calibration app and cycle battery to fix).

    Once they release a kernal that allows governing of the cpu we should see better battery life and more power when needed. From what I understand, currently the existing kernal locks the cpu at 800mhz. No higher, no lower. Scaling will definitley help battery life.


    Noobs to android should keep in mind that there have been issues with just about every phone/rom released and it takes time for the bugs to get ironed out. I expect the same for the various tablets. Helps if you are used to custom roms from other android devices. Titanium backup app is a headache reducer - if used correctly.

    For example, I just put gingerbread (android 2.3) on my HTC magic 3a and spent half the day trying to sort out the quirks...

    Also, you are not limited to the stock launcher, or whatever launcher is on your custom rom. Search "launcher" in the market. Some launchers have way more bling but really imo are better for faster processors like cortex. I've found Zeam to be fairly simple, and it seems so far to be less buggy and less of a hog. You can install more than one and use home switcher app to change between them if you want an easy way to switch.

    One last thing about android apps. Some apps run certain processes in the background even when you think they are not. In fact some will do this from install even though you have never "ran" the app. Keep this in mind if you suddenly find your device getting slow or buggy. Oh, and having a ton of widgets running on your home screens will definitely hog resources.
    abdul2000sg likes this.
  13. smorgan19

    smorgan19 Well-Known Member

    Perhaps try and reflash with Tim3a instead fo 4d2. I hadn't any problems with 3a.
  14. smorgan19

    smorgan19 Well-Known Member

    The SAWEE10 model is a FlyTouch 2 not a FlyTouch 3. This is why the problems that people are experiencing with the SAWEE10's are under the assumption that they're FlyTouch 3's. This is why when they try to load for example a custom ROM on their device that's meant for the FlyTouch 3 it doesn't work (2 files on SD card and boot, update starts). The process is a lot different for FlyTouch 2s. The FlyTouch 3 model name is Wwe10. The real model name is in the build.prop file under system. If you're wondering what model you have download something from Android Market and then have a look in your Market account settings and see what the Market has detected your device as, it won't be Disco.

    You should try Cyanogenmod for your HTC alot of added functionality. Unfortunately the HTC magic isn't supported anymore and you can only get version 6 for it.
    HTC Magic | CyanogenMod
  15. denwa

    denwa Member

    Mine shows up as Disco when on the desktop market website.

    Yeah, I had a version of CM on my HTC but I upgraded to gingerbread based off the sapphire. I miss the added tools CM had.
  16. jacky99

    jacky99 New Member

    Thanks to Shane, Compubyte and also yamahaddude9 for the picture posted. I ordered my Flytouch3 from eBay a week ago. The box arrived exactly the same as what yamahaddude9's post - "SuperPad III". After open the box, there is no information about the manufacture, supporting web-site... I try to find the vendor in eBay, but the link is gone!!!I am worried a bit. However, this tablet can still boot and run. After put in a microSD card, the anger bird can installed an run, but no sound. (well, I never play anger bird before so I thought that's normal at that time :)) Look like the hardware is good. But it is slow and will hang very often between Apps. The wireless will drop very often, too. A C- machine to me...
    I am so glade I found this forum. Thanks a million to Shane. I read thru the posts and decide to flash ROM 4d2. The flash is very simple and fast. Actually it will shutdown the tablet after the firmware update. After reboot, this tablet is totally different. Response very well, and I don't see the crash anymore. Seems like from C- to A now. The 4d2 installed lots of useful Apps also -- Dolphin Browsers, Apk Manager, You Tube, Messenger,... One major problem I see it the G-sensor becomes very sensitive. The tablet will rotate back and forth once I move my sitting position. But I think I can go with it. So far so good with 4d2. BTW, the status for 4d2 after flash.
    model # DISCO10
    android version 2.2-20110503
    kernel version 2.6.32.9 zld@dtlinuxserver #47
    build number FRF85B
  17. jgwells1

    jgwells1 New Member

    I flashed to the 4d2 two weeks ago when it came out, and I am beyond happy. With the original in box os it sucked to put it bluntly. Now I love this thing. I have no complaints, wifi works, apps work, no problems found now.
  18. karlx

    karlx Member

    Hi, I have just made a purchase and awaiting delivery, from eBay u.k of a tablet claiming to be a flytouch 3 / Superpad 2. it was approx 2 weeks old, with protective film on front and back.The box is labeled "Superpad 2" on top left of lid, and on the sides. The device is 512mb/16GB. I've tried to look this actual unit up but cannot find it anywhere. It is 2.2. Does anybody know anything about this, does it run ok. will it/should it be upgraded? I have attached a similar image, Thanks

    Model: disco
    Android version: Android2.2-20110325
    Baseband: Unknown
    Kernal 2.6.32.9 zjd@dlinuxserver #28
    Build: FRF85B

    seems sluggish, wont let me DL angry birds via appworld or from website. nor anything else "starting download" only free apps show on market.


    [​IMG]
  19. meofnet

    meofnet Member

    Almost 1 month and my superpad3 is doing very good, i opened it up to change the memory to 16GB :) it was easier to do than i thought it would be. Only GPS is not good, i do not use much it would be better if it were inside and not outside, i think the chinese did not think the design very well for the gps hahaha.
  20. rebooto

    rebooto Member

    I've just got my 16GB Micro SD card so now wanting to upgrade the Tim's firmware. Just wonder if anyone tried Tim4d3? can our SP3 use Tim4e?
  21. denwa

    denwa Member

    Yes. 4e is out now. The 4a to 4d3 series had a battery issue. Looks like 4e wil be the last till June as Tim is going to be busy with real work till then.
  22. jacky99

    jacky99 New Member

    Yes, I flashed 4d3 yesterday. It is similiar to 4d2. Don't see much improvement. One problem: For both the "LOCAL" and "SD1" tab selections, the "My Pad" Apk will show the external SD card (SD1) info only. Looks like a bug there.
    BTW, in 4d2, my LOCAL tab is showing 12GB Total. Deos it mean I have 16GB internal SD? I am not sure this info is correct. However, I am sure 4d3 is not right. The "LOCAL" tab is just a mirror of "SD1"
  23. Compubyte

    Compubyte Member

    HEY thanks a million. YOU just saved me all kinds of research on replacing my AC ADAPTER lol ..
  24. rebooto

    rebooto Member

    I've manage to get Tim4d2 running and seems all good.

    I found that i can't copy any file (from my pc) into my 16gb micro sd card after inserting into SP3. anyone got this issue? The error was the card is lock.

    So to work around i've to put the micro sd into the SP3 then copy those file into a thumbdrive/portable hdd then plug to SP3 and do a transfer. So kind of tedious.
  25. Tony2k

    Tony2k Member

    I updated my Superpad III with tim4e (perfect) and then with Flytouch3 Superpad2 V4.90 Edition Beta Release.
    With last one the tablet was no longer running, press the start button and vibrates but the screen remains blank. Releasing the button stops vibrating.
    What can I do?
Loading...

Share This Page