Supersonic Matrix SC-72Mid


  1. Lverkeyn

    Lverkeyn New Member

    ugh!
    I purchased a brick!.... actually, I got it as a "perk" free.
    This 7" tablet looked like it might be an ok alternative to something like the Kindle Fire.
    Unfortunately, I realized that something was seriously wrong when I tried to download anything from Google Play. ... anything I tried just kept "downloading" and never stopped.
    I looked at various system settings until I came across the Storage area.... um wtf? Ive attached an image with some text I added showing the storage screen display.. but the storage area shows (from top down)
    ______________________
    Internal Storage 100% full
    available space 0.00mb
    ______________________
    applications: 37mb
    ______________________
    Internal Storage 1.43gb
    available space 1.43gb
    ____________________


    It looks like there is some type of partition for the Internal storage, and downloading anything is impossible, as it must be downloading to the full partition???
    I don't know android very well, and not even sure partitions are possible or if that is in fact what is happening.

    I searched, found nothing similar in forums, so I did a hard factory reset.... when it came back on, the first instructional screens showed up, just like it was brand new out of the package when I first turned it on.... good so far.... but when I went into storage, it still showed the first listing of Internal Storage to be completely full.. exactly the same as before the factory hard reset.

    Is this a Brick?
    or is there some way to "un-partition" the internal storage to combine the two?

    Attached Files:


    Advertisement
  2. laserbiz

    laserbiz Member

    I have the Matrix Supersonic SC73 MID2/12 AlthoughI cant answer your specific question I do agree that these tablets are horrible. Mine is resisitive not capacitive, and no one knows anything about these tablests or their makers. I would love to be able to modify my tablet,(it comes rooted out of the box ) but have no Idea how to get to the bootloader screen or recovery screen. ...HELP!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

    Matrix MID Tablets - Supersonic Inc << THIS IS THEIR WEBSITE AND THEY OFFER NO HELP.
  3. garyMatt

    garyMatt Member

    Got Supersonic matrix 7 (4gb sc 78 mid), with shipping it was about $120 for testing purposes (post on mine review blog) and my impressions are:

    - a bit slow
    - plastic not very quaility
    - in that price range($100) -> average

    If you plan to spend $100 on android tablet you should search for some better solution, like Coby 7 (mid70364g) or Novel 7" 2gb...
  4. mikedt

    mikedt 你好 Guide

  5. papahonk

    papahonk New Member

    could any of you guys tell me how to do a factory reset on a sc-72jb ? it only has 2 buttons plus a pinhole reset that just restarts the thing. ive tried to start it while hitting reset. ive tried starting it while holding the home button and ive tried holdng the home button while hitting the reset what am i doing wrong?

    like laserbiz said their website isnt any help at all was hoping to download a manual for it, but not from that website.

    any help would be greatly appreciated

    Mike
  6. Kevkelsar

    Kevkelsar Well-Known Member

    Yeah, this thing is crap. I got it as a 5 year gift from work...I would never pay any money for this. I'm simply installing the Kido'z app and giving it to my kids to use. While I don't have the memory issue stated by the OP, this thing only gives you 500MB of internal storage, of which maybe 450 is available for use for apps and all their data. Ridiculous.
  7. mikedt

    mikedt 你好 Guide

    What no Apple iPad? :D They must really like you then, to give you this thing. :rolleyes: Be thankful you got 450MB usable internal, some of them only have 100MB.
  8. 4freese

    4freese New Member

    any info on how to get to the menu so we can wipe this joker. Locked out of mine and cannot get in. Customer service sucks. There is nothing but a home button, power button and a reset pin hole. None of which do anything for wiping it.
  9. TechnoKhan13

    TechnoKhan13 New Member

    I am trying to factory reset the Matrix SuperSonic SC-72MID, but information on this model is as elusive as the Loch Ness Monster. Several people have the exact same issue with needing to reset it to factory default but no one seems to have a clue. This has to be one of the most worthless tablets I have ever come across. Anyway, still looking for a solution, keep the fight alive!

Share This Page