Root SuperSU no SU binary installed

Discussion in 'Android Devices' started by mahmoud98767, Aug 14, 2013.

  1. mahmoud98767

    mahmoud98767 Member
    15

    Jul 23, 2013
    20
    0
    15
    Male
    Cairo,Egypt
    Hi,
    After i used the factory image to get the stock kernel and stock rom i tried to root my device using these steps Root Nexus 7 - A Simple and Safe Method
    i did all the step exactly but when i open the SuperSU app it say "There is no SU binary installed, and SuperSU cannot install it. this is a problem!
    If you just upgraded to android 4.3,you need manually re-root - consult the revert forums for your device!"
    and i triad to download SCR recorded to test the root but i say that "No root access" and i triad to use the factory image again and reroot again but the same.
    thnx
     

    Advertisement

  2. John Bean

    John Bean Happy Wanderer
    163

    Jul 28, 2010
    1,250
    442
    163
    Male
    Waterfoot, Lancashire
    The simplest way to root any Nexus is to use Wugs Nexus Root Toolkit, which works with all versions including 4.3.
     
    jmar and mahmoud98767 like this.
  3. mahmoud98767

    mahmoud98767 Member
    15

    Jul 23, 2013
    20
    0
    15
    Male
    Cairo,Egypt
    Thnx that's worked!
     
  4. John Bean

    John Bean Happy Wanderer
    163

    Jul 28, 2010
    1,250
    442
    163
    Male
    Waterfoot, Lancashire
    Excellent, glad you got it sorted :)

    The 4.3 update broke all the existing rooting methods so a lot of the existing "How to..." guides no longer worked - along with the older versions of the Wugs toolkit which basically just automate the same set of instructions.

    It took only a few days for someone to find another way to root it (thanks Chainfire) and a little later the Wugs toolkit automated the method and now works fine with 4.3, as you found.
     
    jmar likes this.
  5. palmtree5

    palmtree5 Sunny Vacation Supporter!
    Moderator
    533

    May 2, 2012
    4,444
    3,030
    533
    Male
    Student
    USA
    Other Superuser apps seem to be catching up too. I just switched back to CWM Superuser now that it supports 4.3. Flashed through TWRP and rebooted
     

Share This Page

Loading...