Root Superuser.apk and su not found

Discussion in 'Android Devices' started by IAM2ND, Aug 17, 2012.

  1. IAM2ND

    IAM2ND New Member
    5

    Aug 17, 2012
    4
    0
    5
    Texas
    Hi,

    I have an HTC Amaze that I wanted to root. Using Mac OS X, I already unlocked the bootloader and I used root4amaze to root my phone. I installed ROM Manager but it said, "You must root your phone for ROM Manager to function. Superuser was not found at "/system/bin/su" or "/system/xbin/su". Use Google Search on your computer to find instructions to root your phone." Then I installed a Superuser app from Google Play but it still wouldn't work. I had USB debugging on and the .bin's were unzipped but it didn't work. Please help this noob and keep it clear as possible!
     

    Advertisement
  2. Caro332

    Caro332 Well-Known Member
    93

    Feb 22, 2012
    912
    238
    93
    Hi and welcome to AF!

    If you have installed Super User and it still doesn't work, try installing Super SU. And if that still doesn't work, then it means you didn't root it properly and you should go through the procedure again.
     
    IAM2ND and NightAngel79 like this.
  3. IAM2ND

    IAM2ND New Member
    5

    Aug 17, 2012
    4
    0
    5
    Texas
    I installed SuperSU and it says "There is no SU binary installed, and SuperSU cannot install it. This is a problem!" The truth is, I didn't really understand the procedure of rooting my phone. The windows version seemed easier but I don't have one that I can access to root my Amaze.
     
  4. Caro332

    Caro332 Well-Known Member
    93

    Feb 22, 2012
    912
    238
    93
    You probably didn't root it properly.
    This section of the forum will probably help you more. They have the same phone and are more knowledgeable than me about that particular phone
    Amaze 4G - All Things Root - Android Forums
     
    NightAngel79 likes this.
  5. Rush

    Rush {<>}~{<>}
    1,033

    Jan 31, 2011
    18,742
    3,140
    1,033
    Male
    Entrepreneur / Business Owner - Freelance Writer
    Loganville, GA
    NightAngel79 likes this.
  6. IAM2ND

    IAM2ND New Member
    5

    Aug 17, 2012
    4
    0
    5
    Texas
    Tried to root my phone again and it says that Superuser.apk and su failed to copy on my phone. A bunch of other operations were not even permitted. The other resources dealt with Windows computers. What do I do now?
     
  7. IAM2ND

    IAM2ND New Member
    5

    Aug 17, 2012
    4
    0
    5
    Texas
    I looked a bit closer and I saw that the root I was using only worked on Android 2.2, 2.3. So, I don't think I did anything wrong in the rooting. I'll try to find a spare PC to root my phone on. Does rooting work on the Amaze after ICS?
     
  8. DonB

    DonB ♡ Spidey Sense !! ♡ ™
    Moderator
    6,323

    Nov 30, 2009
    19,290
    7,915
    6,323
    Male
    18th Hole Of the Golf Course
    I will move your thread to your dive forum, for you to better get the proper help you need, you are not getting the proper exposure you need here, I will send you a PM with the link so you know where it is, it will also have a 3 day re direct, so if you forget where it is you can come back to the intro section and find it again.
     
    IAM2ND likes this.
  9. xXchrizhurtyXx

    xXchrizhurtyXx Well-Known Member
    78

    Mar 7, 2012
    487
    216
    78
    School
    Bronx NY
    Flash the SuperUser zip
    http://downloads.androidsu.com/superuser/Superuser-3.0.7-efghi-signed.zip
    through recovery
     
Tags:

Share This Page

Loading...