1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

superuser not doing its job


  1. alextop30

    alextop30 Well-Known Member

    Ok so I decided to update my phone to ICS and see what 4.0.3 is about. Update went fine and I used it for a day it is cool I want to stay on it. Today I went to root the damn thing because I like using titanium backup and ES file explorer and so on.


    I installed clockworkmod recovery with Odin. After that I went to install superuser app from CWM - it gave me the usual error and aborted the operation. I went to my external card and tried it from there and it said operation successful.

    Now I have superuser on my phone which don't do anything. When I run Titanium Backup it tells me that superuser permission has not been granted and the point is there was no dialogue box that would let me allow the permissions. Same with all the other apps including Rom manager (I acutually use stock rom) and terminal emulator.

    I tried to update superuser using the update binary under its own preferences and the binary updater says it cannot grab root permissions.

    I tried to find out what I can do so I can remove superuser and try downloading it from the market but I do not know how to mount the file system and have write access in order to try to remove it. Anyone have any idea how I can fix it or remove superuser?

    Advertisement
    :
  2. Atma

    Atma Well-Known Member

    I had the same problem yesterday. I tried a different su file, this one that's in one of the threads at XDA, Superuser-3.0.7-efghi-signed.zip and it worked fine.

    I did have a problem after rooting with the phone hanging at the goodbye screen. I Odin'ed back to stock ICS for now.
    alextop30 likes this.
  3. alextop30

    alextop30 Well-Known Member

    Yea I just fixed it the problem comes in when you flash the file that is in the root thread what I did was downloaded the file from android superuser website and it seems it works perfectly.
  4. alextop30

    alextop30 Well-Known Member

    Ok now that I am at my computer to put it in full words it seems that the link to the super user app in the rooting guide is to an app that is old and does not properly install. To fix superuser you will need to go to Superuser and just download the latest version which is the 3.0.7

    I personally really do not understand why it even installed when it was not working but from now on when I root I will go ahead and download it from the site above!
    Atma likes this.
  5. alextop30

    alextop30 Well-Known Member

    Same problem now super user is being just a serious pain the in the ass... Excuse my language.

    Was helping my friend get his phone rooted - installed clockworkmod recovery touch and went to install superuser 3.0.7 the one I used last time and gives the same error. Than I went to Superuser site downloaded 3.1 for x86 and binary installed it and suddenly the app force closes on top of which I do not get any prompts for super user access for titanium backup!!!

    Can anyone please give me a link to something that just works for this app so that I can install it and forget about it. Seems to me that it is always superuser that is causing some type of problem when I root.

    New update the new app 3.1 is not working but 3.0.5 seems to be doing the job. Also binary update within superuser app is not working as well. I don't really understand why 3.0.7 is not working as well but there seems to be a big problem with superuser. I hope 3.0.5 would replace 3.1 on my friend's phone so it can be all good. if any of you can help me with some findings it would be great.
  6. Atma

    Atma Well-Known Member

    What problem are you having exactly? I'm a little confused. Did you get root but SU isn't giving root permissions to apps like Ti?

    I used superuser for arm and didn't even bother with the binary file.
  7. alextop30

    alextop30 Well-Known Member

    Yep exactly what you said it is not giving root permissions can you give me which one for arm you used so I can try that one out!
  8. Atma

    Atma Well-Known Member

    I uploaded it to Mediafire for you but it might be the same 3.0.7 you used already.

    Superuser-3.0.7-efghi-signed.zip


    I had problems with Ti until I did a complete wipe of everything in recovery and used darkside super wipe and cache wipe and then odin'ed ICS.
  9. alextop30

    alextop30 Well-Known Member

    Well here is an error that I have been encountering a while it says E:Error in sdcard/su/Superuser 3.0.7-efghi-signed.zip
    (Status 0)
    Instalation aborted.

    Which basically means the package did not install!
  10. Atma

    Atma Well-Known Member

    I, and a lot of people, usually get that installation aborted 4 or 5 times before it works. When you're in recovery under install zip from sd card, try toggle signature verification. Sometimes that will fix it.
  11. alextop30

    alextop30 Well-Known Member

    I just really do not understand the error I thought the return from a permissions error was supposed to be something along the line of access the denied, authentication error or something related to the fact that you cannot give authorization for the action. This seams to me to be like a corrupt or incomplete package error because of the file path however I do not understand what the status refers to.

    I have encountered this error numerous times and it's beginning to drive me nuts which is why I seem to be getting more and more vulgar in my words for which I apologize and appreciate all the help.
  12. Atma

    Atma Well-Known Member

    Did you get it to work?
  13. alextop30

    alextop30 Well-Known Member

    I haven't been able to get my paws on my friends phone I will have a chance at that today at some point in time and I will let you know :)
  14. tronmech

    tronmech Member

    Just a small note, I've seen flashing zips fail if the download was bad. Try extracting it on a pc. I had a problem with a gapps package that drove me nuts until I did this. The download on my pc and the one on my phone were the same size all right, but there was garbage data in the file.

    So, test the archive or check the md5.
  15. alextop30

    alextop30 Well-Known Member

    That's not actually the case it must be some problem with the way Clockwork Mod flashes these packages because this one is the only one that can fail 3 times in a row and on the forth time succeed and work just fine. I don't quite know what happens as it is unpacking the files and adds the apk file into the system folder but it seems at least for me that it encounters an error couple of times before it works fine.
Loading...

Share This Page