Superuser Permissions?


  1. durandetto

    durandetto Well-Known Member

    I just rooted my phone and I noticed this app, just wondering what it is and if I can delete it?

    Advertisement
  2. treborcj

    treborcj Well-Known Member

    That is weird. When I rooted my phone, Superuser was not there. Nothing changed other than giving me root access. Did you install a ROM?
  3. treborcj

    treborcj Well-Known Member

  4. durandetto

    durandetto Well-Known Member

    Yeah I installed fresh 1.1.
  5. 702DROID

    702DROID Well-Known Member

    it like a fire wall since your phone has root access if any program or app needs root to work you have to give it permission to use it ....would not recommend deleting it
  6. djkleric

    djkleric Well-Known Member

    When I open this app up it is blank and I can not do anything with it. I have a few apps that require root and nothing shows. What am I missing here?

    I also have usb debuging on
    Running fresh 1.1
  7. LxMxFxD

    LxMxFxD Well-Known Member

    OK guys, just a bit of background:

    the act of "ROOTING" is the act of giving super user. Super users are accounts on a phone or linux/unix device that can do EVERYTHING on the machine. Like the admin on windows. The whole point of rooting a phone is so you can get super user permissoins.

    No, you dont want to delete it.
  8. djkleric

    djkleric Well-Known Member

    I know this. I am asking why I can not see anything in the app. I searched for this app and this is the forum that most closely matched my inquery.
  9. Shawn_Diggidy

    Shawn_Diggidy Member

    +1 Same problem here. When I open the Superuser Permissions program I get a black screen with "SU Request" in a gray bar at the top. The phone will only respond to the Home button when this happens which takes me to the home screen as if nothing happened. Also when trying to run SetCPU and it requests superuser permissions I get the same problem.

    Thanks in advance.
  10. ccapasso

    ccapasso Well-Known Member

    What you guys are seeing is normal. This has already been addressed at least once before. The SuperUser Permission app is by default blank. However, once you start using apps that require su permission, such as Wireless Tether, it CAN start to have entries in it. I say CAN because you will notice that when you choose the Wireless Tether app, you will get a prompt asking you to allow. If you choose allow, it will continue as always. However, if you choose Always Allow, you will no longer get that prompt. Also, once you choose Always Allow, your SuperUser Permission app will now show a listing in it. If you simply choose Allow instead, you would still have nothing listed in the SuperUser Permission app. This is how it works.

    It is a list of apps/requests that have been granted su Permissions.
  11. Shawn_Diggidy

    Shawn_Diggidy Member

    Well that makes sense for how it's supposed to work, however when I open an application that needs superuser permissions it will hang on the Superuser Permissions list. Basically what I'm saying is I can't use any programs that need root access. Is there a way to re-install Superuser Permissions or do I need to re-flash Fresh 1.1?
  12. djkleric

    djkleric Well-Known Member

    ^ this
  13. ccapasso

    ccapasso Well-Known Member

    So you have Fresh 1.1 installed right? Am I understanding your correctly when you say that if you try the Wireless Tether app it just hangs and never allows you to choose allow or always allow?

    Did you try turning on Enable USB Debugging? While I'm not sure if this will have any effect, I've read that it has helped others.
  14. Shawn_Diggidy

    Shawn_Diggidy Member

    Correct, I am given no option to pick "allow" or "always allow". Running Fresh 1.1, tried with and without USB debugging. Just re-flashed Fresh 1.1 and the issue continues.
  15. djkleric

    djkleric Well-Known Member

    Shawn I know the feeling. I was never given the option to allow or always allow.
  16. ahaurw01

    ahaurw01 New Member

    I'm having this exact problem as well with setCPU not giving me the option to allow - just a blank screen. Anybody have any ideas??
  17. ahaurw01

    ahaurw01 New Member

    Ok, just figured out how to get around this, thanks to here. Here were my steps; don't know if you need to follow this exactly, but this is what worked for me.
    1. USB debugging off
    2. Plug in the phone to your computer.
    3. Turn USB debugging on
    4. Open a command prompt and cd to C:\android-sdk-windows\tools
    5. type adb shell
    6. type su
    7. On your phone open up setCPU. It'll then prompt you to allow or disallow SU permissions!
  18. resin420

    resin420 New Member

    you are a life savior, I knew there was a solution...thank you!!!
  19. topcheffer

    topcheffer Active Member

    Thanks for that tip, I had this same issue.
    The solution I found is a little simpler though, just enable USB Debugging. I didn't have to re-enable SU settings or anything, I suppose my ROM (SenseHero 2.1 b5) or flashing process already enabled it. Superuser Permissions was not able to give out permissions w/o USB Debugging enabled.
    Thanks for the help!
  20. Noso

    Noso New Member

    Hey guys I'm new here.. Did not root my phone and I downloaded this program and now my anti virus is saying my phone is rooted and every time I try to delete superuser permissions it won't me.. I just want to delete this program because it's giving trouble. Everytime I get an update to froyo from google it tells me failed to verify I tried manually updating it.. Same story I'm thinking that this might be the reason because no one else is having this problem when they try to update.. I reallywant to update my n1 asap
  21. MahaloCat

    MahaloCat Well-Known Member

    YIKES....Ok - DON"T DELETE SUPERUSER>.....
    Also Seems there is VERY little need for Antivirus.....even rooted.
    This should solve your problem.
  22. Joehunni

    Joehunni Well-Known Member

    A: this is the Hero forum and your issue isn't pertinent to this dead thread. Try asking in the N1 forums where you are more likely to be helped. B: if you aren't rooted then there is no need for this app. C: there is very little need for an anti virus app, unless you just want one to eat your battery.
  23. Kanzeon

    Kanzeon New Member

    Mine says "permission denied" after step 6
  24. bingers

    bingers New Member

    hey iv been having similar problems only that when i open superuser its just a black screen with the app title at the top that is all, no "SU Request" and i have no clue what to do
  25. bingers

    bingers New Member

    hey guys iv been having similar problems with superuser, only when i open it i get a completely black screen with the app title at the top that is all, no "SU Request" so i really stuck n dont know what to do

Share This Page