Superuser Problems??

Last Updated:

  1. crotalus

    crotalus Member


    I rooted my wife's Eris last night. I previously rooted my moto Droid. It is rooted to 2.1 and used the Everything checks out fine, I think. I can access shell and receive a $ prompt from terminal and able to select "Allow" from the Eris.

    When I go into the superuser app though there is nothing listed.

    When I try to start the Tether app (pre-9) it just has a constant spinning circle. I finally went to bed about 3am and left it and it was still spinning this morning. So it doesn't timeout. Seems to be waiting or looking for something.

    I tried pre-8 or 70-pre2_htc and it going to a blank screen with SU Request at the top and eventually times out.

    Should I be using a different version of Tether??

    Can someone help? I would really appreciate it.


  2. Murphy

    Murphy Well-Known Member

    Check USB debugging settings. It needs to be on.
  3. crotalus

    crotalus Member

    I've tried it on and off.

    Thanks though. Any other ideas?
  4. T2noob

    T2noob Well-Known Member

    Yeah sounds like you have debugging off. Make sure that debugging stays on even when its not connected to the computer. I had the same problem, it was because My debugging was off for some reason when my phone wasnt connected to the computer.
  5. crotalus

    crotalus Member


    I got it working. 1.70 pre2;

    Is that the version that you guys have working?

    Thanks for the help.
  6. T2noob

    T2noob Well-Known Member

    The newest on of the wifi tether works for me and there is also ANetShate which has a pretty nice interface here is a download link if you want to try it.
  7. crotalus

    crotalus Member

    Thanks. I give it a try.
  8. rkymtnbum

    rkymtnbum Member

    Did your SU permissions become available at all? I am having the same problem with that...
  9. crotalus

    crotalus Member


    Sorry for the delay. It's my wife's phone and she wasn't home earlier.

    The superuser app does work now. I have no idea why it does now, but not before.

    I am not running the newer tether app, you could try that and of course have the debug on.

    Good Luck
  10. pkopalek

    pkopalek Well-Known Member

    The first time you flash a new rom or backup you have to use adb for adb shell first. Then Su should always work ok. If you're using a terminal on the phone, it won't work.

Share This Page