Support: Samsung Galaxy Note // MTP driver error + continuous USB disconnectionSupport

Last Updated:

  1. asterix7579

    asterix7579 Member


    I got a Samsung Galaxy Note yesterday and have had a lot of problems while connecting it to my PC. Here are the observations:

    -- Kies ( is installed on the PC.
    -- after connecting the phone to the PC, it throws up the usual MTP error and the USB connectivity too keeps bouncing.
    -- this is where I referenced Hawker's suggestion (
    -- now the interesting thing is that after uninstalling kies and the samsung USB drivers (and rebooting the PC), the same problem persists (that is, phone does not get detected properly and keeps bouncing (after rebooting and re-installing kies).

    -- in addition to this, there is another problem. If I connect the phone in USB mode, then also the phone-detection keeps bouncing. The phone gets recognized every 20-25 seconds and I can see it for about 5 seconds before it gets disconnected.

    Please help me out..


  2. asterix7579

    asterix7579 Member

    forgot to mention.. the first section at Hawker's suggestion works for me (after like 8-10 tries).. but there has to be some solution to this problem.. please let me know if you're aware of it.

  3. colnago

    colnago Well-Known Member

    Are you able to change the USB connection type on the Note? If not, try using an app such as "Any Cut", create a shortcut to the "USB Settings", and swtich from MTP to Mass Storage mode as needed.

    However if you simply need to be able to transfer files, if you have a wifi network, you may want to just go with a file management app such as "Estrong's File Explorer".

    MCROBO New Member

    I was having a similar problem until I went a different route. I don't know if you tried it already, but if not, this worked for me:
    - Go to USB Utilities under Settings
    - Click on 'Connect storage to PC'
    - Connect USB cable to PC when the prompt "Connect USB cable to use mass storage" appears
    - Click on "Connect USB storage" on the bottom of your Galaxy Note
    - Click "OK" to the next prompt "Connecting USB storage will stop some applications in use..."
    - Wait for 5-10 secs... et voila! two new 'hard drives' should be detected by your PC.. these should pertain to your 'phone' storage space and your 'card' (external microSD card) storage space.

    This is certainly the fastest way to transfer your pictures and video files compare to other viable options with this phone.
  5. UrbanCr33per

    UrbanCr33per New Member

    Ok ... I know this this is an discussion, but I've encountered the same issue and might be able to add a few cents worth to the thread.

    USB connection on my Galaxy Note has been working fine all the time since I got my Galaxy Note about 2 months ago ... that is, until about a week ago. A week ago, it suddenly stopped working and I've been getting continuous USB disconnections. The thing is though ... I know exactly what the culprit is, because I know exactly when it stopped working, and I know what changed at that time ... I'm just not sure what to do about it or how to fix it.

    The USB connections stopped working for me the moment I accidentally enabled "Voice Talk" (voice commands, etc) on my Galaxy Note. I have noticed that from the moment I enabled "Voice Talk", everytime I connect the USB, my phone momentarily (and very briefly) tries to start "Car Home". So I'm guessing that there's an issue with "Voice Talk" that causes it to assume that any connection in the USB port is a car dock.

    I have tried everything to disable/remove "Voice Talk" ... but it just keeps coming back as soon as I plug in the USB. At this point, I think the only option I've still got is to factory reset my Galaxy Note.
  6. touringhaggis

    touringhaggis Well-Known Member

    I have heard that it is possible to disable voice talk in ICS. I cannot confirm this since I am not willing to risk the update (due to the fact that my phone is running without a problem at the moment).

    Eric Ritchie.
  7. UrbanCr33per

    UrbanCr33per New Member

    Yes, Eric ... I've heard the same thing, but unfortunately I'm still on Gingerbread (still waiting for ICS to become available OTA).

    The most frustrating part is that Voice Talk wasn't enabled by default on my phone, which is the reason I didn't have all the issues ... and it wasn't until I accidentally enabled it, that I started to run into problems. So if it wasn't enabled by default in Gingerbread, then why couldn't there be way to disable it if you accidentally enable it? (Rhetorical question)
  8. touringhaggis

    touringhaggis Well-Known Member

    I am also still on Gingerbread, due to the face that it is working great and I simply don't need anything ICS has to offer. Voice talk is also active on my phone and I certainly did nothing to enable it. Could it be that one of the GB updates auto enabled it?

    Eric Ritchie.
  9. sg3geek

    sg3geek New Member

    I found a solution that worked. It's for a Samsung Galaxy S3, but should still apply to this issue. Below was the method I used, followed by further explanation. You may not need to follow these steps exactly, but they're the steps I used.

    1) Plug Samsung Galaxy S3 phone into computer's USB port. You will get the MTP driver failed to installed message.

    2) Backup SMS / MMS using a backup app (like MyBackup Pro).

    3) Factory reset phone (while still plugged into computer).

    4) Do NOT sign in to your Google Account when phone resets - This is CRITICAL. You can do it later.

    5) Basically, just get the phone started up again without signing into any accounts (like Dropbox, Samsung account, etc.)

    6) MTP driver should have automatically installed on computer - if not, then unplug phone from computer and reconnect.

    7) Sign into your Google Account, and feel free to re-customize your phone at this point.

    Explanation and Notes:

    1) I factory reset my phone 2x in a row. The first time, without doing ANYTHING on the phone after factory resetting it except for signing into my Google Account, the MTP driver failed to install. I believe this happens because signing into my Google Account uses the "backup and restore" functionality of the Google Android account and Google starts automatically downloading saved settings like home screen, Wallpaper, Play Store apps, and other settings. This interferes with the initial MTP driver installation. The 2nd time I factory reset (within minutes of the first factory reset), I did NOT sign into Google Account, and voila, the MTP drivers installed. Only AFTER I was able to connect to the computer did I sign in to Google Account.

    2) Previous to this solution, I had tried every solution I had found online including:

    a) checking / unchecking USB debugging mode
    b) toggling between MTP mode and Camera mode
    c) changing some hidden Android settings
    d) using different USB cables (the one that came with the phone along with others I had)
    e) uninstalling and reinstalling the Samsung drivers
    f) uninstalling and reinstalling Samsung Kies
    g) Device Manager in Microsoft Windows - deleting everything under Universal Serial Bus Controllers so it would reinstall upon Windows restart
    h) cleaning registry
    i) trying to connect to different computers (it didn't work)

    I had initially thought it was a computer problem, but then realized I was using MTP to connect other devices (like a Sony videocamera). The problem was with the Google Account automatically downloading various settings to the phone (because of the Backup and Restore functionality) PRIOR to connecting to the computer.

    For those of you who have tried everything suggested online to connect to the computer, I hope this solution helps!
  10. Zenstrive

    Zenstrive Well-Known Member

    Have you tried using another USB cable?
  11. varunshivhare

    varunshivhare New Member


    i was also having the same issue when i purchased my gnote. i format it several time and updated it to final version 4.0.4. but MTP error was still scratching my head. Finally i got the solution. Keep it in mind that there is no problem with your PC neither with gnote. the main culprit is the APPS which you would have downloaded that prevent gnote to get connected to the PC due to some crappy security reasons. Do this to solve the issue:

    1. go to settings>security>device administrators.
    2. delete what ever is the device administrator since it is creating problem in your note due to some security reasons.
    3. BOOM problem solved.

    Now connect your gnote to PC. KIES will detect it and you are done.


  12. GeeJitsu

    GeeJitsu Member

    This will not work on ever phone but try using this dial code. *#0808# it will take you to the USB settings menu. Select Mtp+Adb click ok and save. Reboot phone reconnect. Hope this helps.
  13. blumenthal

    blumenthal New Member

    good news...don't waiste valuable time... upgrade to kies3 on xp! MTP USB works flawlessly.
    the note4 with win7 64 combo has clearly not been tested!

Share This Page