Sure is lonely here...General


  1. RazoE

    RazoE Well-Known Member


    This was so easy I can't believe I didn't do it before! I am now rooted and loving it, thanks!!!
  2. kaczman

    kaczman Member

    i also wouldnt mind paying to get a forum up or a custom rom. any ideas guys? this seems to be the only place posting is even going on for this phone.
  3. crrandroid

    crrandroid New Member

    Hi there - I've never rooted, and was looking at mikeybot's instructions above, and am wondering if a beginner will know what to do when it comes to #2, working with Odin, and the next few steps.

    I haven't had this much crapware on a phone since the Verizon Vcast on a regular cell phone, the one I had before the G1. Then I had a G2. If I root, will I be able to get rid of some of it, such as the MobileLife Organizer? Reasons for rooting are 1) to use the hotspot again, 2) to use Titanium and 3) to get rid of some things.

    This is my first post, so I'm not allowed to link, but there's an article in Wired Magazine about how manufacturers and providers make the Android experience worse. "Saving Android from a Second Rate Future" by Anil Dash. This article didn't seem relevant to me with the G1 and G2, but does with the Relay.

    Also, I was really surprised I couldn't connect via USB to my Mac and see it in the Finder. The only way was through using Samusung Kies software, which is also proprietary - only lets you move media files. So after some searching, I did find a forum that recommended getting Droid NAS from the Play store, and it's great! I can see the phone as a shared device. I see information above about USB, but I haven't tried that yet. Using Droid NAS, I was able to transfer some of my G2 files.
  4. JaeWeb

    JaeWeb Well-Known Member

    Hi guys!!!!! I'm so excited about this phone! I kept wondering when T-Mo was going to get a high end QWERTY Samsung phone! I won't be able to get it for a couple of weeks but I'm drooling over it now! I have an LG Mytouch 4G Q right now since my roomie is using my Blaze while he saves up for a GS3. :)
  5. Dvalin

    Dvalin New Member

    Hey folks! So -- just got my Galaxy S Relay, and I'm going to be venturing into my first rooting effort.

    In the first part, thanks, mikeybot, jjbz, for the instructions and the links! I've got one question. On recommendation of a gearhead I know, I was going to use Odin3 1.85 (I think that was it) instead of the Odin3 3.07 linked to in Nardholio's post. Unfortunately, the image Nardholio posted failed hash in Odin3 1.85 when I tried to get it started. Does the version of Odin matter? Normally, I'd assume not -- but that's a pretty big version difference. Otherwise, I've redownloaded the image and am going to give it a second try.
  6. jjbz

    jjbz Member

    Have you removed the .md5 extension to make it a .tar?
  7. sonyrevenge5

    sonyrevenge5 New Member

    I have already rooted this phone and am now trying to get tethering working properly.

    I have tried the wifi tethering suggested in this forum. I also tried cwm tether pda net and foxfi. They all work for a minute or two then just seem to freeze up and disconnect.

    I froze the tethering provision apk.

    I have a t-mobile truly unlimited plan if that matters.

    Any suggestions?
  8. jjbz

    jjbz Member

    PDAnet USB tether works for me so far. I haven't found a reliable wifi tether option yet.
  9. mikeybot

    mikeybot Member

    I've been using the cwm usb tether. It does drop every once in a while, but it's good enough for now (and free).
    Make sure if you're using it, that you install the usb driver software from the Samsung site for the phone. The one that Tether downloads doesn't work as well/at all with it
  10. nardholio

    nardholio Member

    cellunlocker.net. T-Mobile will provide the code if you buy the phone outright or if you fulfill certain other conditions, but it's a PITA!!
    jjbz likes this.
  11. enchoy

    enchoy New Member



    Please post back here if you get the wifi tether working -- I'm wanting to do the same thing and use wifi tethering and get the unlimited data plan before it disappears
  12. the86d

    the86d Member

    I got my Relay 4g recently (as it just came out last week), and I LOVE IT!

    5-row qwerty with dedicated numbers, brightness on the shade, all the controls in the shade too without having to scroll over like on the SK4g, AND they actually did some good by allowing NO-SLIDE before an unlock with the pattern!

    The only reason I can see to root this bad boy is to remove all the boatware that targets everything you do for marketing, and maybe WiFiKill to screw with iPhruity users. :)

    Cursor keys!!! Only drawback is that the physical keyboard isn't raised at all and spaces, and some keys toward the sides of the k/board get missed when typing quite a bit. Well then again there is some lag when you hit the home button, and somethings it will ignore that you hit it, and may have to hit it like 3 times, as it is guessing that you want to task-swap, but isn't sure(?).

    I AM glad that they listened to all the complaints about prior phones before dropping this one. Every Samsung phone with touchwiz threaded through-and-through in the past was a memory-leaky-POS. This is the 1st non-Pure-google Samsung device that I have had which seems rock solid (as of yet)...

    Stability was horrible on the Sidekick 4g!
  13. mikeybot

    mikeybot Member

    So far, my only issue is with there only being an alt key on the left side of the keyboard and the placement of the search button. Other that that, I'm adjusting to it from the G2 very well
  14. Dvalin

    Dvalin New Member

    Some additional notes re: mikeybot's instructions, or: some things that this newbie found out during the process:

    Download mode: booting to download mode is more -rebooting- to download mode. Do it while your phone is powered up. At least, that's what worked for me. Also, don't have a password set on your phone; I ran into issues where my phone would lock. As said, the things a newbie finds out...

    Odin: Odin only detects hardware when it starts up, it seems? In other words, get your phone connected in download mode, and -then- start Odin.

    Anyway, successfully flashed the image from Nardholio's post! I'll admit I was expecting more fireworks when the phone restarted, but it's working perfectly, as before. Now to figure out debloating.

    I've had best luck using PDANet for tethering, at present. Wireless I've not gotten working, and I'm not 100% sure why that is. FoxFi is on, and my laptop sees the network, but it's announcing password issues even though I'm 100% sure I've entered it correctly. My bet is it's a protocol issue, so I'm not bugged.

    Also interesting: after my first successful tether and some downloading, I got a system text from T-Mobile advising me to buy tethering to avoid blocking of my tether. Huh. I didn't notice a connection hiccup, so I'm wondering if this is just their way of politely asking for more money.


    Also; hey, jjbz! I think the first time I tried to load it, I hadn't, and I just kept remembering that error message even after I fixed it. ;x I'm totally going to fess up to being the new guy at this.
  15. jjbz

    jjbz Member

    In order to tether without getting crap from T-Mobile, you have to change your user agent on your computer to match your phone's.

    If you keep using your computer's user agent, T-Mobile WILL block you from tethering.

    Personally, I use Firefox and the add-on User Agent RG to switch to the Android user agent. The only drawback is that you will be re-directed to the mobile version of a website, if there is one.

    There's usually a "View Desktop Site" at the bottom of most websites to work around this. More info in this post from the MT4GS forums.
    Dvalin likes this.
  16. dillalade

    dillalade New Member

    I moved from mt4gs to the Relay.
    My first sammy device & I'm happy I've stepped away from HTC.

    Never used Odin or Download mode. So thanks for the tutorial - everything was simple and I have gained superuser root access :)
    Allowing me to gain superuser rights, adfree, sixaxis control & titanium/root explorer functionality to delve into debloating/depinking.

    I have a question regarding the potential for flashing the GSiii CWM you mention below.
    If I try this, can you point me to the file I need, and how to use Odin to flash this?

    From that point, can I use ADB to run any/all of the traditional CWM features (like nand backup, restore, wipes, installs etc.)

    If this is possible I want to give this a try.

    Thank you in advance
  17. Joe_PDA

    Joe_PDA Well-Known Member

    Did you get your unlock code direct from T-Mobile or a website? I wanted to get mine too but I heard T-Mo makes you wait 90 days after purchasing the device.



    [​IMG]

    JJBZ,

    I called T-Mobile and they texted it to me the same day. However I've been with them for many years. If your new, they will still send it to you, within 30 days, depending on how much you sweet talk the CSR.
    jjbz likes this.
  18. mikeybot

    mikeybot Member

    Since this appears to be the catch-all thread, just saw this awesome post over on xda:

    xda-developers - View Single Post - Any one planning on getting the Galaxy Relay 4G

  19. JD421

    JD421 Member

    Boy am I glad to see you here. I need you to check something on your phone for me. Please go to Applications-Settings-Storage and tell me what it says under USB storage and SYSTEM storage.

    thank you so much. I May have to bring my captivate back today !!

    jd
  20. JD421

    JD421 Member

  21. RazoE

    RazoE Well-Known Member


    Uh, glad to be seen? Hahaha. Sorry i don't see that in my settings. I don't mind looking, but if it's on the my touch, then i already sent back to gingerbread with rubix 5.2
  22. psygnosi

    psygnosi Member

    Hi Everyone,

    I have not rooted my Relay 4g yet due to the fact i'm playing Chaos Rings GP but I have a question for all you users who have rooted this device:
    Are you able to save your applications to ext sd card? Does the option to save to sd card show up under applications when rooted? I know this phone has alot of internal memory but installing big games like asphalt 7 and MC3, etc. starts to eat up the internal memory storage fast. I have a 32g Samsung Class 10 microsd card which I would like to use instead of the phones internal memory storage. Thanks for any help in advance.:)
  23. psygnosi

    psygnosi Member

    Never mind. I just rooted it. Awesome!:D
Loading...

Share This Page