Sygic on FT3 anyone?General


  1. BillHally

    BillHally Member

    Hi guys

    Anyone managed to successfully install Sygic Navigator onthe FT3? I have installed it onto three android phones easily but am struggling to get this thing to work with the FT3 :(

    Advertisement
  2. dart16

    dart16 Well-Known Member

    Sygic Mobile 10 (or was it 11?) and Sygic Aura both run on the FT3...
  3. BillHally

    BillHally Member

    Well I thought it would also but I have tried many things on the FT3 and it just wont go and thats after doing it on three Android phones successfully :(

    Would certainly be interested to hear from anyone recently that has done it and it works to see exactly where they installed the files etc ie Local or SD1 etc.
  4. dart16

    dart16 Well-Known Member

    which one are you trying to install?
  5. BillHally

    BillHally Member

    I'ts the 11.02 version the same as I have used three times previously, I am just wondering if this is a path issue? but during the installation process it only offers me one icon "Sygic Download" and not the icon to actually run the app :(
  6. jonsaddles

    jonsaddles Member

    Hi Bill,
    I've also been trying to Sygic to install. I've tried 10 & 11 but can only get the map downloader to install.
    I can get as far as downloading a set of maps but can't see anywhere that the program itself has installed.
    Would love to get some help with this also as I've got it on my wifes Samsung Galaxy S11 & it's pretty good.
  7. dart16

    dart16 Well-Known Member

    Sygic have AFAIK two navigation products. Sygic Aura installs and runs fine on my FT3, I can download maps from the Sygic server and it all runs fine.

    I did have a WinCE tablet a while ago and it is just possible that I had Sygic Mobile Maps running on that and not my FT3 as when I try to install MM10 now it falls over with a process stopped failure. However, there are people reporting MM10 working on Android here Sygic

    and here Sygic GPS System
  8. BillHally

    BillHally Member

    @ jon

    Yes the same as me here after install only the "Downloader" icon is present for launching :( It appears to allow me to download the base files and maps but then cannot see them in the downloader window this is strange as it works great on my Droid phone. This is why I was thinking this was maybe a path issue with the FT3 having more than one SD card accessible? The tablet is the 32GB latest one from ************.

    @ dart16

    I think it is the Aura version that I am using at least it has the Aura folder containing the base files and maps etc. Is it possible for you to check on your FT3 where it is working as to where the Aura folder is located as I am wondering if maybe the database.xml file may need editing?

    As an aside has anyone else here recently (within the last week) installed Sygic on the Flytouch 3 successfully?

    Cheers
  9. tolisn

    tolisn New Member

    Hi,
    I know this is an old thread but I just got my flytouch3 superpad2 tablet and what to install sygic Aura on it. Has anyone managed to install this. I can only get the map downloader to install and not the application icon. Any ideas ?
  10. dart16

    dart16 Well-Known Member

    Try registering at THIS forum and following the download and install instructions

Share This Page