Sync Contacts with GmailSupport


Last Updated:

  1. zoo5174

    zoo5174 Member This Topic's Starter

    Joined:
    Jul 10, 2010
    Messages:
    13
    Likes Received:
    0
    Just got the Samsung galaxy s, can anyone help me sync my contacts from my phone to my gmail contacts??

    Thanks


    z
     

    Advertisement
  2. deeoh1084

    deeoh1084 Well-Known Member

    Joined:
    Dec 21, 2009
    Messages:
    252
    Likes Received:
    16
    aren't they suppose to automatically sync with gmail when u log in with ur gmail account?? that's what all my android handsets did.... hmm...
     
  3. Jaseamondo

    Jaseamondo Active Member

    Joined:
    Feb 23, 2010
    Messages:
    41
    Likes Received:
    3
    Samsung in there infinite wisdom have removed this feature :confused:, hopefully it will be addressed in a firmware update if that's possible, fingers crossed. I actually thought that I was doing something wrong when the contacts did not automatically sync. If anyone knows of a workaround please jump in.

    Regards Jase.
     
  4. knowledge1973

    knowledge1973 Member

    Joined:
    Jul 6, 2010
    Messages:
    6
    Likes Received:
    0
    Funny yours didnt as my contacts sync straight away as soon as i logged nto gmail account. Samsung cant have taken the feature out.
     
  5. Jaseamondo

    Jaseamondo Active Member

    Joined:
    Feb 23, 2010
    Messages:
    41
    Likes Received:
    3

    you would think not eh! , a quick google search seems to say otherwise.

    regards Jase.
     
  6. knowledge1973

    knowledge1973 Member

    Joined:
    Jul 6, 2010
    Messages:
    6
    Likes Received:
    0
    Not sure what you actually mean by that reply, do you not believe me? I can assure you my contacts were synced straight away!
     
  7. Jaseamondo

    Jaseamondo Active Member

    Joined:
    Feb 23, 2010
    Messages:
    41
    Likes Received:
    3

    sorry for the confusion knowlege1973, I definitely believe you. I did not realise that you were also referring to the samsung galaxy s. I can sync fine with my other phone but for some reason it does not automatically update the contacts for me on the samsung. I am In the Uk so maybe it has something to do with it if you perhaps are not, just a thought as sometimes the phones are not exactly the same. I also can sync it just fine vice versa i.e. if I change a contact in gmail via my laptop it will automatically change on the phone. I'd be surprised if I had something set wrong but I'm not discounting it either. Hope someone on here can shed some light on the situation.

    Regards Jase.
     
  8. rleal2010

    rleal2010 Well-Known Member

    Joined:
    May 6, 2010
    Messages:
    385
    Likes Received:
    43
    In your settings, do you have something called "Accounts and sync"?

    It should be a core component of the system and not a special samsung thing.

    If you dont, I would reccomend doing a master reset.

    If that doesnt work then contact samsung/ or your wireless carrier.
     
  9. Jaseamondo

    Jaseamondo Active Member

    Joined:
    Feb 23, 2010
    Messages:
    41
    Likes Received:
    3
    I'm not saying that the auto sync setting is not there, I'm saying it only syncs in one direction, from google to phone. Normally there would be a setting in phone to save contacts as google contacts or phone or to sim etc but the save as google contact option is simply not there. No reset is going to fix that unfortunately. Hope it gets sorted in a phone update soon.
     
  10. landale

    landale Well-Known Member

    Joined:
    Jun 26, 2010
    Messages:
    93
    Likes Received:
    11
    So you're saying that you can sync contacts to your phone from your Gmail account and that the problem is when you add a new contact to your phone or make a change it doesn't sync the change back to Gmail? Just trying to understand so that we can better figure out the problem and if there might be a fix.
     
  11. Jaseamondo

    Jaseamondo Active Member

    Joined:
    Feb 23, 2010
    Messages:
    41
    Likes Received:
    3

    yeah exactly m8. I know it's not the end of the world but It is rather unexpected.

    I had opened a new discussion about this on another part of the forum but the mods moved it to here, both threads are about the same subject though. Could maybe close the other thread? moderator what would be best?
     
  12. mrqs

    mrqs Well-Known Member

    Joined:
    Sep 28, 2009
    Messages:
    1,446
    Likes Received:
    92
  13. Jaseamondo

    Jaseamondo Active Member

    Joined:
    Feb 23, 2010
    Messages:
    41
    Likes Received:
    3
    I'm going to try Samsung support and see what they say, Ill post back when they reply. I don't hold out much hope of a fix being released soon, fingers crossed though.

    regards Jase.
     
  14. sionyboy

    sionyboy Member

    Joined:
    Jul 12, 2010
    Messages:
    6
    Likes Received:
    0
    My girlfriends Hero also does this, we lost all her contacts when her phone magically decided to reset itself one day. I knew I'd turn sync on but none of her contacts were on her gmail account, instead we had to dig out an old sim to get her numbers back.

    Looking around it seems the problem is that Android will only upload contacts that are labelled as 'Google' in your phonebook (as opposed to Sim or Phone) Try creating a few new contacts, label them as Google and try syncing to see if they appear in your gmail account.

    Otherwise, try looking for an app on marketplace called ContactSync by happydroid.
     
  15. mrqs

    mrqs Well-Known Member

    Joined:
    Sep 28, 2009
    Messages:
    1,446
    Likes Received:
    92
    i don't see any option like that anywhere
     
  16. Jaseamondo

    Jaseamondo Active Member

    Joined:
    Feb 23, 2010
    Messages:
    41
    Likes Received:
    3

    yeah that's the problem , you get that option on other phones like the Hero which I also have. You can't set it if its not there lol.
     
  17. Jaseamondo

    Jaseamondo Active Member

    Joined:
    Feb 23, 2010
    Messages:
    41
    Likes Received:
    3
    A member of the samsung galaxy s support team is going to call me back at some point today, I'll post back when I have something to report.

    Jase.
     
  18. landale

    landale Well-Known Member

    Joined:
    Jun 26, 2010
    Messages:
    93
    Likes Received:
    11
    Another option could be to sync contacts using the exchange option instead of via the native gmail method. You would just m.google.com as the server.
     
  19. yakboy

    yakboy Well-Known Member

    Joined:
    Jun 2, 2009
    Messages:
    128
    Likes Received:
    3
    I have similar issues. Never had any problem with my Nexus one. Why oh why did Samsung have to meddle with the stock dialer / contacts apps? Wish I had more time to investigate rooting and installing the standard 2.1 apk. I could easily live without video calls.
     
  20. Jaseamondo

    Jaseamondo Active Member

    Joined:
    Feb 23, 2010
    Messages:
    41
    Likes Received:
    3

    For me it turns out that because I had transferred my contacts before setting up the google account on the phone they were not saved as google contacts, in fact the option to save them as this was not there(makes sense when I think about it now). With the google account now set up I do have the option to save to new contacts to google, and as advised over on another thread all I had to do was export contacts to the sd card them import them back and hey presto you can save them as google contacts this time. (delete contacts from phone before importing back or you'll end up with multiple copies of everything though, for anyone who has done the same as me)
     
  21. rleal2010

    rleal2010 Well-Known Member

    Joined:
    May 6, 2010
    Messages:
    385
    Likes Received:
    43
    ya if you dont save it under a google account when you create a new contact, then it wont be update to your google account.

    When you create an account, there should be an option to select between (phone, google or tmobile/ATT/SIM/Etc).

    if you do see a drop down menu in your new contact form, then try pressing menu. If you have google selected, then the contact will automatically sync to your google address book
     
  22. mrqs

    mrqs Well-Known Member

    Joined:
    Sep 28, 2009
    Messages:
    1,446
    Likes Received:
    92
    like previously mentioned, that's the problem - the option isn't there
     
  23. rleal2010

    rleal2010 Well-Known Member

    Joined:
    May 6, 2010
    Messages:
    385
    Likes Received:
    43
    Export your phone contacts to your SD card, and then import them, but this time, choose gmail.

    when you import a vtf file from your SD card, you get to choose where to import to



    Jaseamondo
    Junior Member

    Join Date: Feb 2010
    Location: Scotland
    Posts: 21

    Device(s): Hero, galaxy s
    Thanks: 1
    Thanked 1 Time in 1 Post

    Default
    So I'm guessing that transferring contacts to the phone before setting up the google account is the reason I could not set the contacts to google, once there in the phone you can't change it. exporting to sd card then back sorts this out, thanks snapper. A point to note for anyone else in this situation ,once you have exported contacts to sd card delete contacts in phone or when you transfer the contacts back from sd you will have multiple copies of everything( not that I was daft enough to do that lo l)


    Problem
    Solved!
     
  24. rleal2010

    rleal2010 Well-Known Member

    Joined:
    May 6, 2010
    Messages:
    385
    Likes Received:
    43
    The only way I know how to import contacts is through my gmail address book. I go online, click export contacts, save it as a vtf file, then plug my phone in a load it on the sim card, I guess.

    Then I would guess that you open it on your phone and select gmail.

    I dunno, but just try it and report back here.
     
  25. woletall

    woletall New Member

    Joined:
    Jul 19, 2010
    Messages:
    3
    Likes Received:
    0
    Hi everyone, I have a similar but slightly different problem...

    I used a program called Sprite Migrate to transfer my contacts from a Windows Mobile smart phone to my new Galaxy S. This was fairly painless (and free :D) but all my contacts automatically became marked as google contacts. The problem is that I can't put any of my 'google' contacts into groups created on the Galaxy S; they just don't show up if I try...only contacts created on the phone show up.

    To compound the problems, any groups created on the Galaxy S don't show up on my google account and vice-versa.

    Any ideas please?
     

Share This Page

Loading...