1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

Sync past Google Calendar events. A solutionTips


  1. Hawker

    Hawker Well-Known Member

    As I am constantly factory resetting and flashing ROMs, I sometimes get annoyed as I lose all but the last 30 days of my Calendar history as this is how far the Google Calendar sync goes back.

    I have been playing about with this and found a solution. You can only go back ONE YEAR AT A TIME.

    1. Ensure you are fully connected via wifi.
    2. Go to Settings>Account and Sync. Turn off sync if it is on.
    3. Go to Settings>Time + date. Turn off automatic date+time and Time Zone, and manually set your date to say 01/01/2012.
    4. Go to Settings>Applications>All, and clear data for Calendar and Calendar Storage.
    5. Reboot.
    6. Keep the phone idle for a minute.
    7. Ensure the system date is still the date to which you previously it set to.
    8. Open up your Calendar app, Settings>Calendars and select all the Google calendars you require
    9. Again, recheck the date on the phone. If it has changed to the current date, then set it back to the date you require.
    10. If you are happy the date is "correct", go to Settings>Accounts and Sync. Manually synchronise your Calendar.
    11. Open your Calendar app and you should see all your events for this year etc.
    12. Go to Settings>Time + date. Manually set the date back to today's date, or turn automatic date+time and Time Zone back on if this is how you set it.
    13. Go to Accounts and Sync and turn back on Sync if this is how you set it.

    NOTE: If you are rooted, I recommend you backup your Calendar and Calendar Storage before doing this just in case. Either use Titanium Backup, or go the whole hog and do a CWM Backup.

    NOTE2: For those of you constantly flashing ROMs who want all events for this year, it makes more sense on first boot to not set the phone to automatically obtain date+time, and manually set the date to 1st Jan in the setup wizard, and put it back to the correct date/automatic after google has synchronised all its stuff.

    Advertisement
    :
    Galaxy SII Fan and ironass like this.
  2. janoslavski

    janoslavski New Member

    Hi,

    First of all, thank you for your tuto,

    I've tryed your solution ; but it's not working for me ...

    it's seems that when my calendar apk synchronyse with gmail ;
    the correct date and time is synchronized from internet!

    Have you a solution?

    Maybe should I try to modify the date and time on my gmail account?

    Thank you,

    I hope you have an answere because I really would like to have my entire agenda on my android ... I often need to see my past events for my work organisation.

    All the best,
    Janoslavski
  3. Hawker

    Hawker Well-Known Member

    Try turning on flight mode first
  4. TheWeyrd1

    TheWeyrd1 New Member

    This didn't work for me. Got nothing and also since ya know for us novices, you didn't put FIRST before the WIFI that you should back up your outlook events...so not they're totally gone and sync'd as null files.

    Step 5 is incorrect. There are no Google files to chose in the Calendar once you clear data. It only offers ALL or PC sync.
  5. TheWeyrd1

    TheWeyrd1 New Member

    Also my calendar colors changed. They used to match my colors on web based versions. Where can that be changed? My old Evo was better about settings...sigh
  6. athegn

    athegn Well-Known Member

    Don't know if this is any help.

    I had trouble with Pimlical and Rick Jones gave me a working solution:_

    Yahoo! Groups
  7. linksmask1

    linksmask1 New Member

    A solution that worked for me:

    In the settings screen of google calendar, click export calendars, this will give you a zip file containing one .ics file for each of your calendars. Unzip this file, then use import calendars to import each .ics into its corresponding calendar. This does not duplicate events, but just refreshes the modified date, thus causing Android to resync the entries.
  8. jkg

    jkg Active Member

    For $5.99 I bought Calangoo from Google Play. Calangoo syncs independently of the Android calendar app and has no date restrictions so EVERYTHING gets synced without needing to go through all the weird date tricks.
    I tried various date changing tricks and they sometimes worked once, but then, sometime later, all the old ones would be gone again.
    Calengoo always keeps them all.

    Cheers
    John K
  9. qayyah

    qayyah New Member

  10. kgundry1

    kgundry1 New Member

    Thank you, thank you, thank you. After many hours of experimenting, trying several apps that were supposed to allow this, one of which entered hundreds of items on one date (and they could only be removed one by one!), this method actually works, and without the need for an additional application. Ken
  11. ptoniolo

    ptoniolo New Member

    Good idea, thanks. It is working for most of my events, but there is still a problem... the modified date changes, but the Android calendar does not sync dates before more or less 50 years ago. I use to register the birthdays with the birth-date, repeated yearly: Android does not sync any event occurred before 1962 (e.g my mother's birthday)!

    Actually I find very strange that this problem has not yet been addressed by the Android team...
  12. ecarlson

    ecarlson Well-Known Member

    Thanks, that was quick and easy, and worked great. I had tried changing the date on my phone, but then it wouldn't sync at all, but this did the trick, and I didn't even have to touch the phone to do it.

    The hardest part was finding the "Export Calendars" option in the Gmail web interface, but I finally found it in the middle of the "Calendars" tab on the "Calendar Settings" screen.
  13. mcluvin737

    mcluvin737 Member

    Yeah, Baby! Back in bidness! Thanks for the great tip. Export calendar and re-import worked like a charm!
  14. advancedal

    advancedal New Member

    Thanks for the tip on exporting and re-importing. I was afraid it would double up events, but it did not. I was trying to switch to a new phone and use Pocket Informant. Prior to this, I was not aware the Google would only sync back 30 days because on my previous phone, there are multiple years of events. I was at wit's end because I refer back to last year all the time.

    THANKS!!!!
  15. MartinGruber

    MartinGruber New Member

    Perfect, easy and fast solution. Thank you very very much. I tried the workaround with setting the phone date - no success even after 1 hour of experimenting. Your solution solved my problem in 2 minutes.
  16. Pinmac1

    Pinmac1 Well-Known Member

    Old thread revived as I had been searching for a solution to this for my Galaxy Note. Was a little nervous but worked fine. Did say that it had failed as it had not imported 3 of the 3,500-odd entries but I'll take that as a success.
  17. metropical

    metropical Member

    linksmask1, that worked. stupid easy. Thanks very.
  18. John_Clark

    John_Clark New Member

    I signed up on these forums just to say thanks to linksmask1. After hours of searching the Internet for a solution to a good portion of events not syncing to my BlackBerry Z10 I found hundreds of iPhone and Android users having the same Caldav issue with no solution, even on the Google and Apple forums.

    This solution worked, not only to get my old calendar items sync'd over, but future items that weren't syncing either. I'm still considering moving to Outlook.com to get Exchange Active Sync back but this solved the problem for now. Simple and easy.

    Thank you thank you!
Loading...

Share This Page